Blob Blame History Raw
%{?scl:%scl_package rubygem-%{gem_name}}
%{!?scl:%global pkg_name %{name}}

%global gem_name rack-test

%{?_with_bootstrap: %global bootstrap 1}

Summary:        Simple testing API built on Rack
Name:           %{?scl_prefix}rubygem-%{gem_name}
Version:        0.6.3
Release:        5%{?dist}
Group:          Development/Languages
License:        MIT
URL:            http://gitrdoc.com/brynary/rack-test/tree/master
Source0:        http://gems.rubyforge.org/gems/%{gem_name}-%{version}.gem
# Fix test errors caused by Rack 2.x changes.
# https://github.com/brynary/rack-test/pull/148
Patch0:         rubygem-rack-test-0.6.3-Fix-test-suite-for-Rack-2.x-compatiblity.patch
# Fix test for RSpec 3.
# https://github.com/brynary/rack-test/pull/134
Patch1:         rubygem-rack-test-0.6.3-Fix-test-for-RSpec-3.patch
# Fix test for uri.query
# https://github.com/brynary/rack-test/commit/4a4b2c1
Patch2:         rubygem-rack-test-0.6.3-Fix-test-uri.query.patch
# Fix test for uploaded file.
# https://github.com/brynary/rack-test/commit/5f78451
Patch3:         rubygem-rack-test-0.6.3-Fix-test-uploaded-file.patch

Requires:       %{?scl_prefix_ruby}ruby(release)
Requires:       %{?scl_prefix_ruby}ruby(rubygems)
Requires:       %{?scl_prefix}rubygem(rack) >= 1.0
BuildRequires:  %{?scl_prefix_ruby}rubygems-devel
BuildRequires:  %{?scl_prefix}rubygem(rack) >= 1.0.0
BuildRequires:  %{?scl_prefix}rubygem(rspec)
%if ! 0%{?bootstrap}
BuildRequires:  %{?scl_prefix}rubygem(sinatra)
%endif
BuildArch:      noarch
Provides:       %{?scl_prefix}rubygem(%{gem_name}) = %{version}

# Explicitly require runtime subpackage, as long as older scl-utils do not generate it
%{?scl:Requires: %{?scl_prefix}runtime}

%description
Rack::Test is a small, simple testing API for Rack apps. It can be used on its
own or as a reusable starting point for Web frameworks and testing libraries
to build on. Most of its initial functionality is an extraction of Merb 1.0's
request helpers feature.

%package doc
Summary: Documentation for %{pkg_name}
Group: Documentation
Requires: %{?scl_prefix}%{pkg_name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{pkg_name}

%prep
%setup -n %{pkg_name}-%{version} -q -c -T
%{?scl:scl enable %{scl} - << \EOF}
%gem_install -n %{SOURCE0}
%{?scl:EOF}

pushd .%{gem_instdir}
%patch0 -p1
%patch1 -p1
%patch2 -p1
%patch3 -p1
popd

%build

%install
mkdir -p %{buildroot}%{gem_dir}
cp -pa .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/

%check
%if ! 0%{?bootstrap}
pushd .%{gem_instdir}
# We don't care about code coverage.
sed -i '/[cC]ode[cC]/ s/^/#/' spec/spec_helper.rb

sed -i '/require "bundler\/setup"/d' spec/spec_helper.rb
%{?scl:scl enable %{scl} - << \EOF}
LANG="en_US.UTF-8" rspec spec
%{?scl:EOF}
popd
%endif

%files
%dir %{gem_instdir}
%exclude %{gem_instdir}/.*
%{gem_libdir}
%doc %{gem_instdir}/MIT-LICENSE.txt
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%doc %{gem_instdir}/README.rdoc
%doc %{gem_instdir}/MIT-LICENSE.txt
%doc %{gem_instdir}/History.txt
%{gem_instdir}/Gemfile*
%{gem_instdir}/Thorfile
%{gem_instdir}/%{gem_name}.gemspec
%{gem_instdir}/spec
%{gem_instdir}/Rakefile

%changelog
* Thu Oct 20 2016 Jun Aruga <jaruga@redhat.com> - 0.6.3-5
- Fix test suite for Rack 2.x compatibilty.
- Fix test suite for Rspec 3

* Wed Feb 24 2016 Pavel Valena <pvalena@redhat.com> - 0.6.3-4
- Update to 0.6.3

* Fri Jan 16 2015 Josef Stribny <jstribny@redhat.com> - 0.6.2-2
- rebuilt for ror41
- update URLs

* Mon Oct 14 2013 Josef Stribny <jstribny@redhat.com> - 0.6.2-1
- Update to 0.6.2

* Thu Jun 13 2013 Josef Stribny <jstribny@redhat.com> - 0.6.1-4
- Rebuild for https://fedoraproject.org/wiki/Features/Ruby_2.0.0

* Wed Feb 27 2013 Vít Ondruch <vondruch@redhat.com> - 0.6.1-3
- Rebuild to fix documentation vulnerability due to CVE-2013-0256.

* Wed Jul 25 2012 Bohuslav Kabrda <bkabrda@redhat.com> - 0.6.1-2
- Specfile cleanup

* Mon Apr 02 2012 Bohuslav Kabrda <bkabrda@redhat.com> - 0.6.1-1
- Rebuilt for scl.
- Updated to 0.6.1.

* Tue Jan 24 2012 Bohuslav Kabrda <bkabrda@redhat.com> - 0.6.0-4
- Rebuilt for Ruby 1.9.3.

* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.0-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild

* Mon Jul 07 2011 Michal Fojtik <mfojtik@redhat.com> - 0.6.0-2
- Fixed broken RSpec tests by temporary removing bundler

* Mon Jun 20 2011 Michal Fojtik <mfojtik@redhat.com> - 0.6.0-1
- Version bump

* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.4-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild

* Wed Sep 08 2010 Michal Fojtik <mfojtik@redhat.com> - 0.5.4-1
- Update to 0.5.4

* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild

* Tue Jun 30 2009 Lubomir Rintel (Good Data) <lubo.rintel@gooddata.com> - 0.4.0-1
- Update to 0.4.0
- Drop useless sitelib macro

* Fri Jun 26 2009 Lubomir Rintel (Good Data) <lubo.rintel@gooddata.com> - 0.3.0-3
- Get rid of duplicate files (thanks to Mamoru Tasaka)

* Mon Jun 08 2009 Lubomir Rintel (Good Data) <lubo.rintel@gooddata.com> - 0.3.0-2
- Fix up documentation list
- Depend on ruby(abi)
- Replace defines with globals

* Fri Jun 05 2009 Lubomir Rintel (Good Data) <lubo.rintel@gooddata.com> - 0.3.0-1
- Package generated by gem2rpm
- Fix up License