Blob Blame History Raw
%{?scl:%scl_package nodejs-validate-npm-package-license}
%{!?scl:%global pkg_name %{name}}

# spec file for package nodejs-nodejs-validate-npm-package-license

%global npm_name validate-npm-package-license
%{?nodejs_find_provides_and_requires}

%global enable_tests 0

Name:		%{?scl_prefix}nodejs-validate-npm-package-license
Version:	3.0.1
Release:	3%{?dist}
Summary:	Give me a string and I'll tell you if it's a valid npm package license string
Url:		https://github.com/kemitchell/validate-npm-package-license.js#readme
Source0:	https://registry.npmjs.org/%{npm_name}/-/%{npm_name}-%{version}.tgz
License:	Apache-2.0

BuildArch:	noarch

%if 0%{?fedora} >= 19
ExclusiveArch: %{nodejs_arches} noarch
%else
ExclusiveArch: %{nodejs_arches} noarch
%endif

BuildRequires:  %{?scl_prefix}nodejs-devel

%if 0%{?enable_tests}
BuildRequires:	%{?scl_prefix}npm(defence-cli)
BuildRequires:	%{?scl_prefix}npm(replace-require-self)
%endif

%description
Give me a string and I'll tell you if it's a valid npm package license string

%prep
%setup -q -n package

rm -rf node_modules

%build

%install
mkdir -p %{buildroot}%{nodejs_sitelib}/%{npm_name}

cp -pr package.json *.js \
%{buildroot}%{nodejs_sitelib}/%{npm_name}

%{nodejs_symlink_deps}

%if 0%{?enable_tests}

%check
%{nodejs_symlink_deps} --check

%endif

%files
%{nodejs_sitelib}/validate-npm-package-license

%doc README.md
%doc LICENSE

%changelog
* Mon May 28 2018 Zuzana Svetlikova <zsvetlik@redhat.com> - 3.0.1-3
- Resolves: RHBZ#1543198, rebuild for multiarch

* Sun Feb 14 2016 Zuzana Svetlikova <zsvetlik@redhat.com> - 3.0.1-2
- rebuilt

* Mon Nov 23 2015 Tomas Hrcka <thrcka@redhat.com> - 3.0.1-1
- Initial build