%{?scl:%scl_package nodejs-%{npm_name}}
%{!?scl:%global pkg_name %{name}}
%{?nodejs_find_provides_and_requires}
%global npm_name glob-parent
# Disable until dependencies are met
%global enable_tests 0
Summary: Strips glob magic from a string to provide the parent path
Name: %{?scl_prefix}nodejs-%{npm_name}
Version: 2.0.0
Release: 5%{?dist}
License: ISC
URL: https://github.com/es128/glob-parent
Source0: http://registry.npmjs.org/%{npm_name}/-/%{npm_name}-%{version}.tgz
BuildRequires: %{?scl_prefix}nodejs-devel
ExclusiveArch: %{nodejs_arches} noarch
BuildArch: noarch
%if 0%{?enable_tests}
BuildRequires: %{?scl_prefix}npm(mocha)
BuildRequires: %{?scl_prefix}npm(coveralls)
%endif
%description
Javascript module to extract the non-magic parent path from a glob string.
%prep
%setup -q -n package
%build
%install
mkdir -p %{buildroot}%{nodejs_sitelib}/%{npm_name}
cp -pr index.js package.json %{buildroot}%{nodejs_sitelib}/%{npm_name}
%nodejs_symlink_deps
%if 0%{?enable_tests}
%check
%nodejs_symlink_deps --check
istanbul cover _mocha && cat ./coverage/lcov.info | coveralls
%endif
%files
%doc README.md
%license LICENSE
%{nodejs_sitelib}/%{npm_name}
%changelog
* Mon May 28 2018 Zuzana Svetlikova <zsvetlik@redhat.com> - 2.0.0-5
- Resolves: RHBZ#1543198, rebuild for multiarch
* Tue Feb 16 2016 Zuzana Svetlikova <zsvetlik@redhat.com> - 2.0.0-4
- Use macro in -runtime dependency
* Sun Feb 14 2016 Zuzana Svetlikova <zsvetlik@redhat.com> - 2.0.0-3
- Rebuilt with updated metapackage
* Wed Jan 06 2016 Tomas Hrcka <thrcka@redhat.com> - 2.0.0-2
- Enable scl macros
* Wed Dec 16 2015 Troy Dawson <tdawson@redhat.com> - 2.0.0-1
- Initial package