%global pkg_name maven-shared-incremental
%{?scl:%scl_package %{pkg_name}}
%{?maven_find_provides_and_requires}
Name: %{?scl_prefix}%{pkg_name}
Version: 1.1
Release: 6.12%{?dist}
Summary: Maven Incremental Build support utilities
License: ASL 2.0
URL: http://maven.apache.org/shared/maven-shared-incremental/
Source0: http://repo1.maven.org/maven2/org/apache/maven/shared/%{pkg_name}/%{version}/%{pkg_name}-%{version}-source-release.zip
BuildArch: noarch
BuildRequires: %{?scl_prefix}maven-local
BuildRequires: %{?scl_prefix}mvn(org.apache.maven.shared:maven-shared-components:pom:)
BuildRequires: %{?scl_prefix}mvn(org.apache.maven.shared:maven-shared-utils)
BuildRequires: %{?scl_prefix}mvn(org.apache.maven:maven-core)
BuildRequires: %{?scl_prefix}mvn(org.apache.maven:maven-plugin-api)
BuildRequires: %{?scl_prefix}mvn(org.codehaus.plexus:plexus-component-annotations)
BuildRequires: %{?scl_prefix}mvn(org.codehaus.plexus:plexus-component-api)
%description
Various utility classes and plexus components for supporting
incremental build functionality in maven plugins.
%package javadoc
Summary: API documentation for %{pkg_name}
%description javadoc
This package provides %{summary}.
%prep
%setup -q -n %{pkg_name}-%{version}
%build
%{?scl:scl enable %{scl} - <<"EOF"}
set -e -x
%mvn_build
%{?scl:EOF}
%install
%{?scl:scl enable %{scl} - <<"EOF"}
set -e -x
%mvn_install
%{?scl:EOF}
%files -f .mfiles
%doc LICENSE NOTICE
%dir %{_mavenpomdir}/%{pkg_name}
%dir %{_javadir}/%{pkg_name}
%files javadoc -f .mfiles-javadoc
%doc LICENSE NOTICE
%changelog
* Mon Feb 08 2016 Michal Srb <msrb@redhat.com> - 1.1-6.12
- Fix BR on maven-local & co.
* Mon Jan 11 2016 Michal Srb <msrb@redhat.com> - 1.1-6.11
- maven33 rebuild #2
* Sat Jan 09 2016 Michal Srb <msrb@redhat.com> - 1.1-6.10
- maven33 rebuild
* Thu Jan 15 2015 Mikolaj Izdebski <mizdebsk@redhat.com> - 1.1-6.9
- Add directory ownership on %%{_mavenpomdir} subdir
* Wed Jan 14 2015 Mikolaj Izdebski <mizdebsk@redhat.com> - 1.1-6.8
- Fix BR on maven-shared POM
* Tue Jan 13 2015 Michael Simacek <msimacek@redhat.com> - 1.1-6.8
- Mass rebuild 2015-01-13
* Tue Jan 06 2015 Michael Simacek <msimacek@redhat.com> - 1.1-6.7
- Mass rebuild 2015-01-06
* Mon May 26 2014 Mikolaj Izdebski <mizdebsk@redhat.com> - 1.1-6.6
- Mass rebuild 2014-05-26
* Wed Feb 19 2014 Mikolaj Izdebski <mizdebsk@redhat.com> - 1.1-6.5
- Mass rebuild 2014-02-19
* Tue Feb 18 2014 Mikolaj Izdebski <mizdebsk@redhat.com> - 1.1-6.4
- Mass rebuild 2014-02-18
* Mon Feb 17 2014 Mikolaj Izdebski <mizdebsk@redhat.com> - 1.1-6.3
- SCL-ize build-requires
* Thu Feb 13 2014 Mikolaj Izdebski <mizdebsk@redhat.com> - 1.1-6.2
- Rebuild to regenerate auto-requires
* Tue Feb 11 2014 Mikolaj Izdebski <mizdebsk@redhat.com> - 1.1-6.1
- First maven30 software collection build
* Fri Dec 27 2013 Daniel Mach <dmach@redhat.com> - 1.1-6
- Mass rebuild 2013-12-27
* Fri Jun 28 2013 Mikolaj Izdebski <mizdebsk@redhat.com> - 1.1-5
- Rebuild to regenerate API documentation
- Resolves: CVE-2013-1571
* Wed Apr 24 2013 Michal Srb <msrb@redhat.com> - 1.1-4
- Remove alias for fake artifactId
* Wed Apr 24 2013 Michal Srb <msrb@redhat.com> - 1.1-3
- Build with original POM file
- Temporarily provide fake artifactId
* Wed Apr 24 2013 Michal Srb <msrb@redhat.com> - 1.1-2
- Build 1.1 with fake artifactId
* Wed Apr 10 2013 Mikolaj Izdebski <mizdebsk@redhat.com> - 1.1-1
- Update to upstream version 1.1
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
* Wed Jan 23 2013 Mikolaj Izdebski <mizdebsk@redhat.com> - 1.0-1
- Initial packaging