| %global pkg_name jsch |
| %{?scl:%scl_package %{pkg_name}} |
| %{?java_common_find_provides_and_requires} |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| Name: %{?scl_prefix}%{pkg_name} |
| Version: 0.1.50 |
| Release: 5.14%{?dist} |
| Epoch: 0 |
| Summary: Pure Java implementation of SSH2 |
| License: BSD |
| URL: http://www.jcraft.com/jsch/ |
| Source0: http://download.sourceforge.net/sourceforge/jsch/jsch-%{version}.zip |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| Source1: MANIFEST.MF |
| Source2: plugin.properties |
| Source3: http://repo1.maven.org/maven2/com/jcraft/%{pkg_name}/%{version}/%{pkg_name}-%{version}.pom |
| |
| BuildRequires: %{?scl_prefix}javapackages-tools |
| BuildRequires: %{?scl_prefix}jzlib >= 0:1.0.5 |
| BuildRequires: %{?scl_prefix}ant |
| BuildRequires: zip |
| |
| BuildArch: noarch |
| |
| Requires: %{?scl_prefix}jzlib >= 0:1.0.5 |
| |
| %description |
| JSch allows you to connect to an sshd server and use port forwarding, |
| X11 forwarding, file transfer, etc., and you can integrate its |
| functionality into your own Java programs. |
| |
| %package javadoc |
| Summary: Javadoc for %{pkg_name} |
| |
| %description javadoc |
| %{summary}. |
| |
| %package demo |
| Summary: Examples for %{pkg_name} |
| Requires: %{?scl_prefix}runtime |
| |
| %description demo |
| %{summary}. |
| |
| |
| %prep |
| %setup -q -n %{pkg_name}-%{version} |
| |
| %build |
| %{?scl:scl enable %{scl_maven} %{scl} - <<"EOF"} |
| set -e -x |
| export CLASSPATH=$(build-classpath jzlib) |
| ant dist javadoc |
| |
| |
| mkdir META-INF |
| cp %{SOURCE1} META-INF |
| cp %{SOURCE2} plugin.properties |
| zip dist/lib/%{pkg_name}-*.jar META-INF/MANIFEST.MF |
| zip dist/lib/%{pkg_name}-*.jar plugin.properties |
| %{?scl:EOF} |
| |
| %install |
| %{?scl:scl enable %{scl_maven} %{scl} - <<"EOF"} |
| set -e -x |
| |
| install -Dpm 644 dist/lib/%{pkg_name}-*.jar \ |
| $RPM_BUILD_ROOT%{_javadir}/%{pkg_name}.jar |
| |
| |
| install -dm 755 $RPM_BUILD_ROOT%{_javadocdir}/%{name} |
| cp -pr javadoc/* $RPM_BUILD_ROOT%{_javadocdir}/%{name} |
| |
| |
| install -dm 755 $RPM_BUILD_ROOT%{_datadir}/%{pkg_name}-%{version} |
| cp -pr examples/* $RPM_BUILD_ROOT%{_datadir}/%{pkg_name}-%{version} |
| ln -s %{pkg_name}-%{version} $RPM_BUILD_ROOT%{_datadir}/%{pkg_name} |
| |
| |
| install -d -m 755 $RPM_BUILD_ROOT%{_mavenpomdir} |
| install -p -m 644 %{SOURCE3} $RPM_BUILD_ROOT%{_mavenpomdir}/JPP-%{pkg_name}.pom |
| %add_maven_depmap |
| %{?scl:EOF} |
| |
| %files -f .mfiles |
| %doc LICENSE.txt |
| |
| %files javadoc |
| %doc %{_javadocdir}/%{name}* |
| %doc LICENSE.txt |
| |
| %files demo |
| %doc %{_datadir}/%{pkg_name}* |
| %doc LICENSE.txt |
| |
| |
| %changelog |
| * Wed Jan 14 2015 Mikolaj Izdebski <mizdebsk@redhat.com> - 0:0.1.50-5.14 |
| - Add requires on SCL filesystem package |
| |
| * Tue Jan 13 2015 Michael Simacek <msimacek@redhat.com> - 0:0.1.50-5.13 |
| - Mass rebuild 2015-01-13 |
| |
| * Fri Jan 09 2015 Michal Srb <msrb@redhat.com> - 0:0.1.50-5.12 |
| - Mass rebuild 2015-01-09 |
| |
| * Wed Jan 07 2015 Michal Srb <msrb@redhat.com> - 0.1.50-5.11 |
| - Migrate to .mfiles |
| |
| * Tue Dec 16 2014 Mikolaj Izdebski <mizdebsk@redhat.com> - 0:0.1.50-5.10 |
| - Migrate requires and build-requires to rh-java-common |
| |
| * Mon Dec 15 2014 Mikolaj Izdebski <mizdebsk@redhat.com> - 0:0.1.50-5.9 |
| - Mass rebuild 2014-12-15 |
| |
| * Mon Dec 15 2014 Mikolaj Izdebski <mizdebsk@redhat.com> - 0:0.1.50-5.8 |
| - Rebuild for rh-java-common collection |
| |
| * Mon May 26 2014 Mikolaj Izdebski <mizdebsk@redhat.com> - 0:0.1.50-5.7 |
| - Mass rebuild 2014-05-26 |
| |
| * Wed Feb 19 2014 Mikolaj Izdebski <mizdebsk@redhat.com> - 0:0.1.50-5.6 |
| - Mass rebuild 2014-02-19 |
| |
| * Tue Feb 18 2014 Mikolaj Izdebski <mizdebsk@redhat.com> - 0:0.1.50-5.5 |
| - Mass rebuild 2014-02-18 |
| |
| * Tue Feb 18 2014 Mikolaj Izdebski <mizdebsk@redhat.com> - 0:0.1.50-5.4 |
| - Remove requires on java |
| |
| * Mon Feb 17 2014 Mikolaj Izdebski <mizdebsk@redhat.com> - 0:0.1.50-5.3 |
| - SCL-ize build-requires |
| - SCL-ize requires |
| |
| * Thu Feb 13 2014 Mikolaj Izdebski <mizdebsk@redhat.com> - 0:0.1.50-5.2 |
| - Rebuild to regenerate auto-requires |
| |
| * Tue Feb 11 2014 Mikolaj Izdebski <mizdebsk@redhat.com> - 0:0.1.50-5.1 |
| - First maven30 software collection build |
| |
| * Fri Dec 27 2013 Daniel Mach <dmach@redhat.com> - 00.1.50-5 |
| - Mass rebuild 2013-12-27 |
| |
| * Fri Jul 19 2013 Mikolaj Izdebski <mizdebsk@redhat.com> - 0:0.1.50-4 |
| - Remove unneeded copyright header |
| |
| * Fri Jul 19 2013 Mikolaj Izdebski <mizdebsk@redhat.com> - 0:0.1.50-3 |
| - Update jsch-0.1.50.pom to new upstream version |
| |
| * Fri Jun 28 2013 Mikolaj Izdebski <mizdebsk@redhat.com> - 0:0.1.50-2 |
| - Rebuild to regenerate API documentation |
| - Resolves: CVE-2013-1571 |
| |
| * Fri May 10 2013 Krzysztof Daniel <kdaniel@redhat.com> 0:0.1.50-1 |
| - Update to latest upstream. |
| |
| * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:0.1.49-2 |
| - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild |
| |
| * Tue Jan 15 2013 Alexander Kurtakov <akurtako@redhat.com> 0:0.1.49-1 |
| - Update to latest upstream. |
| |
| * Thu Nov 1 2012 Mikolaj Izdebski <mizdebsk@redhat.com> - 0:0.1.48-3 |
| - Add maven POM |
| |
| * Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:0.1.48-2 |
| - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild |
| |
| * Wed May 2 2012 Alexander Kurtakov <akurtako@redhat.com> 0:0.1.48-1 |
| - Update to latest upstream 0.1.48. |
| |
| * Thu Mar 15 2012 Krzysztof Daniel <kdaniel@redhat.com> 0:0.1.46-2 |
| - Updated MANIFEST.MF to match the actual upstream version. |
| - Added plugin.properties to get proper vendor name in Eclipse. |
| |
| * Wed Feb 15 2012 Alexander Kurtakov <akurtako@redhat.com> 0:0.1.46-1 |
| - Update to latest upstream version 0.1.46. |
| |
| * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:0.1.45-2 |
| - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild |
| |
| * Wed Nov 2 2011 Alexander Kurtakov <akurtako@redhat.com> 0:0.1.45-1 |
| - Update to new upstream version. |
| |
| * Thu Sep 15 2011 Alexander Kurtakov <akurtako@redhat.com> 0:0.1.44-4 |
| - Guidelines fixes. |
| |
| * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:0.1.44-3 |
| - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild |
| |
| * Wed Dec 8 2010 Alexander Kurtakov <akurtako@redhat.com> 0:0.1.44-2 |
| - BR zip. |
| - Don't install versioned jar. |
| |
| * Tue Nov 2 2010 Alexander Kurtakov <akurtako@redhat.com> 0:0.1.44-1 |
| - New upstream version. |
| |
| * Fri Sep 24 2010 Alexander Kurtakov <akurtako@redhat.com> 0:0.1.43-2 |
| - Fix merge review comments ( |
| |
| * Mon Aug 16 2010 Alexander Kurtakov <akurtako@redhat.com> 0:0.1.43-1 |
| - Update to new upstream version. |
| |
| * Mon Jan 11 2010 Andrew Overholt <overholt@redhat.com> 0:0.1.41-4 |
| - Fix changelog formatting error |
| |
| * Mon Jan 11 2010 Andrew Overholt <overholt@redhat.com> 0:0.1.41-3 |
| - Update URL in comment for MANIFEST.MF |
| - Fix Groups |
| - Remove ghost symlinking |
| |
| * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:0.1.41-2 |
| - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild |
| |
| * Wed Apr 8 2009 Alexander Kurtakov <akurtako@redhat.com> 0:0.1.41-1 |
| - Update to new version 0.1.41. |
| |
| * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:0.1.39-2.1 |
| - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild |
| |
| * Fri Jul 11 2008 Andrew Overholt <overholt@redhat.com> 0:0.1.39-1.1 |
| - 0.1.39 |
| |
| * Wed Jul 9 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0:0.1.31-2.5 |
| - drop repotag |
| |
| * Thu May 29 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0:0.1.31-2jpp.4 |
| - fix license tag |
| |
| * Mon Apr 07 2008 Deepak Bhole <dbhole@redhat.com> - 0:0.1.31-2jpp.3 |
| - Fix bz |
| |
| * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0:0.1.31-2jpp.2 |
| - Autorebuild for GCC 4.3 |
| |
| * Thu Sep 20 2007 Deepak Bhole <dbhole@redhat.com> - 0:0.1.31-1jpp.2 |
| - Added %%{?dist} as per new policy |
| |
| * Tue Jun 5 2007 Ben Konrath <bkonrath@redhat.com> - 0:0.1.31-1jpp.1 |
| - 0.1.31. |
| |
| * Tue Apr 3 2007 Ben Konrath <bkonrath@redhat.com> - 0:0.1.28-1jpp.6 |
| - Add OSGi Manifest to jar. |
| - Disable aot-compile-rpm on ia64. |
| |
| * Thu Aug 10 2006 Deepak Bhole <dbhole@redhat.com> - 0:0.1.28-1jpp.5 |
| - Updated changelog entries in spec. |
| |
| * Fri Aug 04 2006 Deepak Bhole <dbhole@redhat.com> - 0:0.1.28-1jpp.4 |
| - Added conditional compiling support. |
| - Added missing requirements. |
| - Additionally, for synchronizaion between logs: |
| - From r.apel@r-apel.de: |
| - 0.1.26 |
| - From fnasser@redhat.com: |
| - 0.1.20 |
| |
| * Sat Jul 22 2006 Jakub Jelinek <jakub@redhat.com> - 0:0.1.28-1jpp_3fc |
| - Rebuilt |
| |
| * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0:0.1.28-1jpp_2fc |
| - rebuild |
| |
| * Thu Jun 1 2006 Ben Konrath <bkonrath@redhat.com> - 0:0.1.28-1jpp_1fc |
| - 0.1.28 |
| - Add BuildRequires ant. |
| |
| * Mon Mar 6 2006 Jeremy Katz <katzj@redhat.com> - 0:0.1.18-1jpp_7fc |
| - stop scriptlet spew |
| |
| * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0:0.1.18-1jpp_6fc |
| - bump again for double-long bug on ppc(64) |
| |
| * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0:0.1.18-1jpp_5fc |
| - rebuilt for new gcc4.1 snapshot and glibc changes |
| |
| * Wed Dec 21 2005 Andrew Overholt <overholt@redhat.com> 0.1.18-1jpp_4fc |
| - Rebuild again |
| |
| * Tue Dec 13 2005 Andrew Overholt <overholt@redhat.com> 0.1.18-1jpp_3fc |
| - Rebuild with gcc 4.1. |
| |
| * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com> |
| - rebuilt |
| |
| * Fri Jul 15 2005 Gary Benson <gbenson@redhat.com> 0.1.18-1jpp_2fc |
| - Build on ia64, ppc64, s390 and s390x. |
| - Switch to aot-compile-rpm. |
| |
| * Fri Apr 22 2005 Andrew Overholt <overholt@redhat.com> 0.1.18-1jpp_1fc |
| - Build into Fedora. |
| - Natively-compile. |
| |
| * Fri Apr 22 2005 Fernando Nasser <fnasser@redhat.com> 0:0.1.18-1jpp_1rh |
| - Merge with upstream for 0.1.18 upgrade |
| |
| * Fri Apr 22 2005 Fernando Nasser <fnasser@redhat.com> 0:0.1.18-1jpp |
| - 0.1.18 |
| |
| * Fri Mar 18 2005 Andrew Overholt <overholt@redhat.com> 0.1.17-2jpp_1fc |
| - Build into Fedora. |
| - Remove Distribution and Vendor tags. |
| - Add BuildRequires: java-devel for javadoc requirement. |
| |
| * Tue Nov 02 2004 David Walluck <david@jpackage.org> 0:0.1.17-2jpp |
| - rebuild with jdk 1.4.2 |
| |
| * Tue Oct 19 2004 David Walluck <david@jpackage.org> 0:0.1.17-1jpp |
| - 0.1.17 |
| |
| * Sun Aug 23 2004 Randy Watler <rwatler at finali.com> - 0:0.1.13-2jpp |
| - Rebuild with ant-1.6.2 |
| |
| * Sat Feb 14 2004 David Walluck <david@anti-microsoft.org> 0:0.1.13-1jpp |
| - 0.1.13 |
| |
| * Wed Jan 14 2004 Ralph Apel <r.apel@r-apel.de> - 0:0.1.12-1jpp |
| - First JPackage build. |