Blob Blame Raw
From f98862c05573261a3fd0cd30ed27992290183835 Mon Sep 17 00:00:00 2001
From: Eduardo Otubo <otubo@redhat.com>
Date: Fri, 28 Sep 2018 07:56:38 +0100
Subject: [PATCH 4/6] configure: require libseccomp 2.2.0
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

RH-Author: Eduardo Otubo <otubo@redhat.com>
Message-id: <20180928075639.16746-5-otubo@redhat.com>
Patchwork-id: 82312
O-Subject: [RHEL-8 qemu-kvm PATCH 4/5] configure: require libseccomp 2.2.0
Bugzilla: 1618356
RH-Acked-by: Dr. David Alan Gilbert <dgilbert@redhat.com>
RH-Acked-by: Marc-André Lureau <marcandre.lureau@redhat.com>
RH-Acked-by: Thomas Huth <thuth@redhat.com>

From: Marc-André Lureau <marcandre.lureau@redhat.com>

commit d0699bd37c48067cffbd80383172efc29da6d2f9
Author: Marc-André Lureau <marcandre.lureau@redhat.com>
Date:   Wed Aug 22 19:02:49 2018 +0200

    configure: require libseccomp 2.2.0

    The following patch is going to require TSYNC, which is only available
    since libseccomp 2.2.0.

    libseccomp 2.2.0 was released February 12, 2015.

    According to repology, libseccomp version in different distros:

      RHEL-7: 2.3.1
      Debian (Stretch): 2.3.1
      OpenSUSE Leap 15: 2.3.2
      Ubuntu (Xenial):  2.3.1

    This will drop support for -sandbox on:

      Debian (Jessie): 2.1.1 (but 2.2.3 in backports)

    Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com>
    Acked-by: Eduardo Otubo <otubo@redhat.com>

Signed-off-by: Eduardo Otubo <otubo@redhat.com>
Signed-off-by: Danilo C. L. de Paula <ddepaula@redhat.com>
---
 configure | 7 ++-----
 1 file changed, 2 insertions(+), 5 deletions(-)

diff --git a/configure b/configure
index 23d8d18..efd9eb6 100755
--- a/configure
+++ b/configure
@@ -2137,13 +2137,10 @@ fi
 ##########################################
 # libseccomp check
 
+libseccomp_minver="2.2.0"
 if test "$seccomp" != "no" ; then
     case "$cpu" in
-    i386|x86_64)
-        libseccomp_minver="2.1.0"
-        ;;
-    mips)
-        libseccomp_minver="2.2.0"
+    i386|x86_64|mips)
         ;;
     arm|aarch64)
         libseccomp_minver="2.2.3"
-- 
1.8.3.1