Blob Blame History Raw
%global git0 https://github.com/projectatomic/%{name}
%global commit0 299e781918c053d72b3d5fed8c6c149366d20ab0
%global shortcommit0 %(c=%{commit0}; echo ${c:0:7})

Name: oci-umount
Epoch: 2
Version: 2.0.0
Release: 1.git%{shortcommit0}%{?dist}
# no go-md2man for ppc64
ExcludeArch: ppc64
URL: %{git0}
Source0: %{git0}/archive/%{commit0}/%{name}-%{shortcommit0}.tar.gz
License: GPLv3+
Summary: OCI umount hook for container runtimes
BuildRequires: autoconf
BuildRequires: automake
BuildRequires: git
BuildRequires: go-md2man
BuildRequires: pkgconfig(yajl)
BuildRequires: pkgconfig(libselinux)
BuildRequires: pkgconfig(mount)
BuildRequires: pcre-devel
Obsoletes: docker-%{name} <= 2:1.13.1-22
Provides: docker-%{name} = %{epoch}:%{version}-%{release}

%description
OCI umount hooks unmount potential leaked mount points in a containers
mount namespaces.

%prep
%autosetup -Sgit -n %{name}-%{commit0}

%build
autoreconf -i
%configure --libexecdir=%{_libexecdir}/oci/hooks.d/
make %{?_smp_mflags}

%install
%make_install

%check

#define license tag if not already defined
%{!?_licensedir:%global license %doc}

%files
%license LICENSE
%doc README.md
%config(noreplace) %{_sysconfdir}/%{name}.conf
%dir %{_libexecdir}/oci
%dir %{_libexecdir}/oci/hooks.d
%{_libexecdir}/oci/hooks.d/%{name}
%{_mandir}/man1/%{name}.1*

%changelog
* Mon Aug 14 2017 Lokesh Mandvekar <lsm5@fedoraproject.org> - 2:2.0.0-1.git299e781
- initial build as independent package
- obsoletes docker-oci-umount