| %{?scl:%scl_package nodejs-%{npm_name}} |
| %{!?scl:%global pkg_name %{name}} |
| |
| %{?nodejs_find_provides_and_requires} |
| %global npm_name is-glob |
| |
| Summary: Returns true if the given string looks like a glob |
| Name: %{?scl_prefix}nodejs-%{npm_name} |
| Version: 2.0.1 |
| Release: 2%{?dist} |
| License: MIT |
| URL: https://github.com/jonschlinkert/is-glob |
| Source0: http://registry.npmjs.org/%{npm_name}/-/%{npm_name}-%{version}.tgz |
| BuildRequires: nodejs010-runtime |
| ExclusiveArch: %{nodejs_arches} noarch |
| BuildArch: noarch |
| Provides: %{?scl_prefix}nodejs-%{npm_name} = %{version} |
| |
| %description |
| Returns true if the given string looks like a glob pattern |
| or an extglob pattern. This makes it easy to create code |
| that only uses external modules like node-glob when necessary, |
| resulting in much faster code execution and initialization |
| time, and a better user experience. |
| |
| %prep |
| %setup -q -n package |
| |
| %build |
| |
| %install |
| mkdir -p %{buildroot}%{nodejs_sitelib}/%{npm_name} |
| cp -pr index.js package.json %{buildroot}%{nodejs_sitelib}/%{npm_name} |
| |
| %nodejs_symlink_deps |
| |
| %files |
| %doc README.md |
| %license LICENSE |
| %{nodejs_sitelib}/%{npm_name} |
| |
| %changelog |
| * Wed Jan 06 2016 Tomas Hrcka <thrcka@redhat.com> - 2.0.1-2 |
| - Enable scl macros |
| |
| * Wed Dec 16 2015 Troy Dawson <tdawson@redhat.com> - 2.0.1-1 |
| - Initial package |