| %{?scl:%scl_package nodejs-async} |
| %{!?scl:%global pkg_name %{name}} |
| %{?nodejs_find_provides_and_requires} |
| |
| %global enable_tests 0 |
| |
| Name: %{?scl_prefix}nodejs-async |
| Version: 0.2.9 |
| Release: 3%{?dist} |
| Summary: Higher-order functions and common patterns for asynchronous code |
| BuildArch: noarch |
| ExclusiveArch: %{nodejs_arches} noarch |
| |
| Group: System Environment/Libraries |
| License: MIT |
| URL: http://github.com/caolan/async/ |
| Source0: http://registry.npmjs.org/async/-/async-%{version}.tgz |
| |
| |
| |
| Source10: dl-tests.sh |
| BuildRoot: %{_tmppath}/%{pkg_name}-%{version}-%{release}-root-%(%{__id_u} -n) |
| |
| BuildRequires: %{?scl_prefix}nodejs-devel |
| |
| |
| |
| |
| |
| %description |
| Async is a utility module which provides straight-forward, powerful functions |
| for working with asynchronous JavaScript. Although originally designed for |
| use with Node.js, it can also be used directly in the browser. |
| |
| Async provides around 20 functions that include the usual 'functional' |
| suspects (map, reduce, filter, forEach…) as well as some common patterns |
| for asynchronous control flow (parallel, series, waterfall…). All these |
| functions assume you follow the Node.js convention of providing a single |
| callback as the last argument of your async function. |
| |
| %prep |
| %setup -q -n package |
| |
| |
| %build |
| |
| |
| %install |
| rm -rf %buildroot |
| mkdir -p %{buildroot}%{nodejs_sitelib}/async |
| cp -pr package.json lib %{buildroot}%{nodejs_sitelib}/async |
| |
| |
| |
| |
| |
| |
| %clean |
| rm -rf %buildroot |
| |
| %files |
| %defattr(-,root,root,-) |
| %{nodejs_sitelib}/async |
| %doc README.md LICENSE |
| |
| %changelog |
| * Thu Oct 17 2013 Tomas Hrcka <thrcka@redhat.com> - 0.2.9-3 |
| - replace provides and requires with macro |
| |
| * Sun Jun 23 2013 T.C. Hollingsworth <tchollingsworth@gmail.com> - 0.2.9-2 |
| - restrict to compatible arches |
| |
| * Tue May 28 2013 Jamie Nguyen <jamielinux@fedoraproject.org> - 0.2.9-1 |
| - update to upstream release 0.2.9 |
| - add %%check |
| |
| * Sat May 25 2013 Jamie Nguyen <jamielinux@fedoraproject.org> - 0.2.8-1 |
| - update to upstream release 0.2.8 |
| |
| * Mon Apr 15 2013 T.C. Hollingsworth <tchollingsworth@gmail.com> - 0.2.6-2 |
| - add macro for EPEL6 dependency generation |
| |
| * Thu Apr 11 2013 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.2.6-2 |
| - Add support for software collections |
| |
| * Wed Mar 13 2013 T.C. Hollingsworth <tchollingsworth@gmail.com> - 0.2.6-1 |
| - new upstream release 0.2.6 |
| |
| * Wed Feb 13 2013 T.C. Hollingsworth <tchollingsworth@gmail.com> - 0.2.5-1 |
| - new upstream release 0.2.5 |
| |
| * Sat Feb 09 2013 T.C. Hollingsworth <tchollingsworth@gmail.com> - 0.2.4-1 |
| - new upstream release 0.2.4 |
| |
| * Tue Jan 08 2013 T.C. Hollingsworth <tchollingsworth@gmail.com> - 0.1.22-3 |
| - add missing build section |
| |
| * Tue Jan 08 2013 T.C. Hollingsworth <tchollingsworth@gmail.com> - 0.1.22-2 |
| - Fix URL |
| - Provide a better description |
| |
| * Mon Dec 31 2012 T.C. Hollingsworth <tchollingsworth@gmail.com> - 0.1.22-1 |
| - initial package generated by npm2rpm |