Blob Blame History Raw
# We build libbpf from RHEL kernel sources, that's why we use
# directly kernel tar for RHEL kernel build.
# We update libbpf's 'sources' file with proper hash that's
# used as kernel tar.

# RHEL kernel version-release
%define kver   4.18.0-167
%define source linux-%{kver}.el8

Name:           libbpf
Version:        0.0.4
Release:        3%{?dist}
Summary:        Libbpf library

License:        LGPLv2 or BSD
Source0:        %{source}.tar.xz
Patch0:         0001-fix-i686-compilation.patch
BuildRequires:  gcc elfutils-libelf-devel elfutils-devel python3

%description
A mirror of bpf-next linux tree bpf-next/tools/lib/bpf directory plus its
supporting header files. The version of the package reflects the version of
ABI.

%package devel
Summary:        Development files for %{name}
Requires:       %{name} = %{version}-%{release}
Requires:       kernel-headers >= %{kver}

%description devel
The %{name}-devel package contains libraries header files for
developing applications that use %{name}

%package static
Summary: Static library for libbpf development
Requires: %{name}-devel = %{version}-%{release}

%description static
The %{name}-static package contains static library for
developing applications that use %{name}

%global libbpf_make \
  make EXTRA_CFLAGS="${RPM_OPT_FLAGS}" EXTRA_LDFLAGS="%{__global_ldflags}" DESTDIR=%{buildroot} V=1

%prep
%setup -n %{source}
%patch0 -p1

%build
pushd tools/lib/bpf
%{libbpf_make}
popd

%install
pushd tools/lib/bpf
%{libbpf_make} prefix=%{_prefix} install_lib install_headers
popd

%files
%{_libdir}/libbpf.so.%{version}
%{_libdir}/libbpf.so.0

%files devel
%{_libdir}/libbpf.so
%{_includedir}/bpf

%files static
%{_libdir}/libbpf.a

%changelog
* Sun Dec 15 2019 Jiri Olsa <jolsa@redhat.com> - 0.0.4-3
- new kernel version [1759154]

* Tue Dec 10 2019 Jiri Olsa <jolsa@redhat.com> - 0.0.4-2
- new build for gating [1759154]

* Mon Nov 02 2019 Jiri Olsa <jolsa@redhat.com> - 0.0.4-1
- version 0.0.4 [1759154]

* Mon Nov 02 2019 Jiri Olsa <jolsa@redhat.com> - 0.0.2-1
- initial package [1759154]