# Set to 1 if building an empty subscription-only package.
%define empty_package 0
#######################################################
# Only need to update these variables and the changelog
%define kernel_ver 3.10.0-1160.105.1.el7
%define kpatch_ver 0.9.2
%define rpm_ver 1
%define rpm_rel 2
%if !%{empty_package}
# Patch sources below. DO NOT REMOVE THIS LINE.
#
# https://issues.redhat.com/browse/RHEL-8456
Source100: CVE-2023-42753.patch
#
# https://issues.redhat.com/browse/RHEL-8831
Source101: CVE-2022-42896.patch
#
# https://issues.redhat.com/browse/RHEL-15213
Source102: CVE-2023-45871.patch
#
# https://issues.redhat.com/browse/RHEL-14416
Source103: CVE-2023-4921.patch
# End of patch sources. DO NOT REMOVE THIS LINE.
%endif
%define sanitized_rpm_rel %{lua: print((string.gsub(rpm.expand("%rpm_rel"), "%.", "_")))}
%define sanitized_kernel_ver %{lua: print((string.gsub(string.gsub(rpm.expand("%kernel_ver"), ".el7", ""), "%.", "_")))}
%define kernel_ver_arch %{kernel_ver}.%{_arch}
Name: kpatch-patch-%{sanitized_kernel_ver}
Version: %{rpm_ver}
Release: %{rpm_rel}.el7
%if %{empty_package}
Summary: Initial empty kpatch-patch for kernel-%{kernel_ver_arch}
%else
Summary: Live kernel patching module for kernel-%{kernel_ver_arch}
%endif
Group: System Environment/Kernel
License: GPLv2
ExclusiveArch: x86_64 ppc64le
Conflicts: %{name} < %{version}-%{release}
Provides: kpatch-patch = %{kernel_ver_arch}
Provides: kpatch-patch = %{kernel_ver}
%if !%{empty_package}
Requires: systemd
%endif
Requires: kpatch >= 0.4.0-3
Requires: kernel-uname-r = %{kernel_ver_arch}
%if !%{empty_package}
BuildRequires: gcc elfutils-devel rpmdevtools asciidoc bc hmaccalc m4 net-tools xmlto zlib-devel binutils-devel newt-devel python-devel perl(ExtUtils::Embed) bison audit-libs-devel numactl-devel pciutils-devel openssl gettext kernel-devel ncurses-devel hostname java-devel python-docutils
BuildRequires: kernel-devel = %{kernel_ver}
BuildRequires: kernel-debuginfo = %{kernel_ver}
%ifarch x86_64
BuildRequires: pesign
%endif
%ifarch ppc64le
BuildRequires: gcc-plugin-devel
%endif
Source0: https://github.com/dynup/kpatch/archive/v%{kpatch_ver}.tar.gz
Source10: kernel-%{kernel_ver}.src.rpm
# kpatch-build patches
# Patch1: backport.patch
Patch1: v0.9.2-backport-MR-1281-create-diff-object-add-suppo.patch
Patch2: v0.9.2-backport-MR-1200-Make-sure-section-symbols-ex.patch
%global _dupsign_opts --keyname=rhelkpatch1
%define builddir %{_builddir}/kpatch-%{kpatch_ver}
%define kpatch %{_sbindir}/kpatch
%define kmoddir %{_usr}/lib/kpatch/%{kernel_ver_arch}
%define patchmodname kpatch-%{sanitized_kernel_ver}-%{version}-%{sanitized_rpm_rel}
%define patchmod %{patchmodname}.ko
%define _missing_build_ids_terminate_build 1
%define _find_debuginfo_opts -r
%undefine _include_minidebuginfo
%undefine _find_debuginfo_dwz_opts
%description
This is a kernel live patch module which can be loaded by the kpatch
command line utility to modify the code of a running kernel. This patch
module is targeted for kernel-%{kernel_ver}.
%prep
%autosetup -n kpatch-%{kpatch_ver} -p1
%build
kdevdir=/usr/src/kernels/%{kernel_ver_arch}
vmlinux=/usr/lib/debug/lib/modules/%{kernel_ver_arch}/vmlinux
# kpatch-build
make -C kpatch-build
# patch module
for i in %{sources}; do
[[ $i == *.patch ]] && patch_sources="$patch_sources $i"
done
export CACHEDIR="%{builddir}/.kpatch"
kpatch-build/kpatch-build -n %{patchmodname} -r %{SOURCE10} -v $vmlinux --skip-cleanup $patch_sources || { cat "${CACHEDIR}/build.log"; exit 1; }
%install
installdir=%{buildroot}/%{kmoddir}
install -d $installdir
install -m 755 %{builddir}/%{patchmod} $installdir
%files
%{_usr}/lib/kpatch
%post
if [[ %{kernel_ver_arch} = $(uname -r) ]]; then
cver="%{rpm_ver}_%{rpm_rel}"
pname=$(echo "kpatch_%{sanitized_kernel_ver}" | sed 's/-/_/')
lver=$({ %{kpatch} list | sed -nr "s/^${pname}_([0-9_]+)\ \[enabled\]$/\1/p"; echo "${cver}"; } | sort -V | tail -1)
if [ "${lver}" != "${cver}" ]; then
echo "WARNING: at least one loaded kpatch-patch (${pname}_${lver}) has a newer version than the one being installed."
echo "WARNING: You will have to reboot to load a downgraded kpatch-patch"
else
%{kpatch} load %{kmoddir}/%{patchmod}
fi
fi
%{kpatch} install -k %{kernel_ver_arch} %{kmoddir}/%{patchmod}
sync
exit 0
%postun
%{kpatch} uninstall -k %{kernel_ver_arch} %{patchmod}
sync
exit 0
%else
%description
This is an empty kpatch-patch package which does not contain any real patches.
It is only a method to subscribe to the kpatch stream for kernel-%{kernel_ver}.
%files
%doc
%endif
%changelog
* Wed Mar 06 2024 Yannick Cote <ycote@redhat.com> [1-2.el7]
- kernel: use-after-free in sch_qfq network scheduler [RHEL-14416] {CVE-2023-4921}
- kernel: IGB driver inadequate buffer size for frames larger than MTU [RHEL-15213] {CVE-2023-45871}
- kernel: use-after-free in l2cap_connect and l2cap_le_connect_req in net/bluetooth/l2cap_core.c [RHEL-8831] {CVE-2022-42896}
* Fri Jan 05 2024 Yannick Cote <ycote@redhat.com> [1-1.el7]
- kernel: netfilter: potential slab-out-of-bound access due to integer underflow [RHEL-8456] {CVE-2023-42753}
* Wed Nov 08 2023 Yannick Cote <ycote@redhat.com> [0-0.el7]
- An empty patch to subscribe to kpatch stream for kernel-3.10.0-1160.105.1.el7 [RHEL-16012]