| Name: glassfish-jaxb |
| Version: 2.2.5 |
| Release: 6%{?dist} |
| Summary: JAXB Reference Implementation |
| |
| Group: Development/Libraries |
| License: CDDL and GPLv2 with exceptions |
| URL: http://jaxb.java.net |
| |
| |
| |
| |
| |
| |
| |
| Source0: %{name}-%{version}.tar.gz |
| |
| |
| Source1: http://repo1.maven.org/maven2/com/sun/xml/bind/jaxb-impl/2.2.5/jaxb-impl-2.2.5.pom |
| |
| |
| Source2: http://repo1.maven.org/maven2/com/sun/xml/bind/jaxb-xjc/2.2.5/jaxb-xjc-2.2.5.pom |
| |
| |
| |
| Source3: build-javadoc.xml |
| |
| |
| Patch0: %{name}-dont-use-internal-resolver.patch |
| |
| |
| Patch1: %{name}-dont-generate-1.0-runtime.patch |
| |
| |
| Patch2: %{name}-dont-generate-jing-rnc-driver.patch |
| |
| |
| Patch3: %{name}-dont-bundle-other-jars.patch |
| |
| |
| Patch4: %{name}-remove-classpath-from-manifests.patch |
| |
| |
| |
| Patch5: %{name}-add-dependencies.patch |
| |
| |
| Patch6: %{name}-dont-use-prebuilt-javadocs.patch |
| |
| |
| Patch7: %{name}-dont-build-examples.patch |
| |
| BuildArch: noarch |
| |
| BuildRequires: jpackage-utils |
| BuildRequires: java-devel |
| |
| BuildRequires: ant |
| BuildRequires: codemodel |
| BuildRequires: istack-commons |
| BuildRequires: relaxngcc |
| BuildRequires: xml-commons-resolver |
| BuildRequires: txw2 |
| BuildRequires: relaxngDatatype |
| BuildRequires: glassfish-dtd-parser |
| BuildRequires: glassfish-jaxb-api |
| BuildRequires: glassfish-fastinfoset |
| BuildRequires: jing |
| BuildRequires: stax-ex |
| BuildRequires: isorelax |
| BuildRequires: xsom |
| BuildRequires: rngom |
| |
| Requires: glassfish-dtd-parser |
| Requires: xml-commons-resolver |
| Requires: xsom |
| Requires: rngom |
| Requires: isorelax |
| Requires: jing |
| Requires: stax-ex |
| Requires: glassfish-fastinfoset |
| Requires: glassfish-jaxb-api |
| Requires: relaxngDatatype |
| Requires: txw2 |
| Requires: istack-commons |
| Requires: codemodel |
| Requires: jpackage-utils |
| Requires: java |
| |
| |
| %description |
| GlassFish JAXB Reference Implementation. |
| |
| |
| %package javadoc |
| Summary: Javadocs for %{name} |
| Group: Documentation |
| Requires: jpackage-utils |
| |
| |
| %description javadoc |
| This package contains the API documentation for %{name}. |
| |
| |
| %prep |
| |
| |
| %setup -q |
| |
| |
| |
| |
| cp %{SOURCE1} jaxb-impl.pom |
| cp %{SOURCE2} jaxb-xjc.pom |
| |
| |
| %patch0 -p1 |
| %patch1 -p1 |
| %patch2 -p1 |
| %patch3 -p1 |
| %patch4 -p1 |
| %patch5 -p1 |
| %patch6 -p1 |
| %patch7 -p1 |
| |
| |
| ln -s $(build-classpath codemodel) tools/lib/rebundle/compiler/codemodel.jar |
| ln -s $(build-classpath glassfish-dtd-parser) tools/lib/rebundle/compiler/dtd-parser.jar |
| ln -s $(build-classpath istack-commons-tools) tools/lib/rebundle/compiler/istack-commons-tools.jar |
| ln -s $(build-classpath relaxngDatatype) tools/lib/rebundle/compiler/relaxngDatatype.jar |
| ln -s $(build-classpath xml-commons-resolver) tools/lib/rebundle/compiler/resolver.jar |
| ln -s $(build-classpath rngom) tools/lib/rebundle/compiler/rngom.jar |
| ln -s $(build-classpath xsom) tools/lib/rebundle/compiler/xsom.jar |
| ln -s $(build-classpath isorelax) tools/lib/rebundle/runtime/isorelax.jar |
| ln -s $(build-classpath msv-msv) tools/lib/rebundle/runtime/msv.jar |
| ln -s $(build-classpath relaxngDatatype) tools/lib/rebundle/runtime/relaxngDatatype.jar |
| ln -s $(build-classpath istack-commons-runtime) tools/lib/rebundle/runtime2/istack-commons-runtime.jar |
| ln -s $(build-classpath txw2) tools/lib/rebundle/runtime2/txw2.jar |
| ln -s $(build-classpath jaxb-api) tools/lib/redist/jaxb-api.jar |
| ln -s %{_javadir}/glassfish-fastinfoset/FastInfoset.jar tools/lib/util/FastInfoset.jar |
| ln -s $(build-classpath args4j) tools/lib/util/args4j.jar |
| ln -s $(build-classpath codemodel-annotation-compiler) tools/lib/util/codemodel-annotation-compiler.jar |
| ln -s $(build-classpath dom4j) tools/lib/util/dom4j.jar |
| ln -s $(build-classpath jing) tools/lib/util/jing.jar |
| ln -s $(build-classpath relaxngcc) tools/lib/util/relaxngcc.jar |
| ln -s $(build-classpath stax-ex) tools/lib/util/stax-ex.jar |
| ln -s $(build-classpath txwc2) tools/lib/util/txwc2.jar |
| |
| |
| |
| cp %{SOURCE3} build-javadoc.xml |
| |
| |
| %build |
| |
| |
| ant \ |
| -Dbuild.sysclasspath=last \ |
| -Dbuild.number=1 \ |
| dist |
| |
| |
| ant \ |
| -Dbuild.sysclasspath=last \ |
| -f build-javadoc.xml |
| |
| |
| %install |
| |
| |
| install -d -m 755 %{buildroot}%{_javadir}/%{name} |
| install -m 644 dist/lib/jaxb-impl.jar %{buildroot}%{_javadir}/%{name}/jaxb-impl.jar |
| install -m 644 dist/lib/jaxb-xjc.jar %{buildroot}%{_javadir}/%{name}/jaxb-xjc.jar |
| install -m 644 tools/pretty-printer/build/pretty-printer.jar %{buildroot}%{_javadir}/%{name}/pretty-printer.jar |
| install -m 644 tools/xmllint/build/xmllint.jar %{buildroot}%{_javadir}/%{name}/xmllint.jar |
| |
| |
| install -d -m 755 %{buildroot}%{_mavenpomdir} |
| install -m 644 jaxb-impl.pom %{buildroot}%{_mavenpomdir}/JPP.%{name}-jaxb-impl.pom |
| install -m 644 jaxb-xjc.pom %{buildroot}%{_mavenpomdir}/JPP.%{name}-jaxb-xjc.pom |
| |
| |
| install -d -m 755 %{buildroot}%{_javadocdir}/%{name} |
| cp -rp apidocs/* %{buildroot}%{_javadocdir}/%{name}/. |
| |
| |
| %add_maven_depmap JPP.%{name}-jaxb-impl.pom %{name}/jaxb-impl.jar |
| %add_maven_depmap JPP.%{name}-jaxb-xjc.pom %{name}/jaxb-xjc.jar |
| |
| |
| %files |
| %{_mavenpomdir}/* |
| %{_mavendepmapfragdir}/* |
| %{_javadir}/* |
| %doc License.txt |
| %doc License.html |
| |
| |
| %files javadoc |
| %{_javadocdir}/%{name} |
| %doc License.txt |
| %doc License.html |
| |
| |
| %changelog |
| * Fri Dec 27 2013 Daniel Mach <dmach@redhat.com> - 2.2.5-6 |
| - Mass rebuild 2013-12-27 |
| |
| * Fri Oct 25 2013 Ade Lee <alee@redhat.com> - 2.2.5-5 |
| - Resolves rhbz |
| |
| * Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2.5-4 |
| - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild |
| |
| * Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2.5-3 |
| - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild |
| |
| * Tue Mar 13 2012 Juan Hernandez <juan.hernandez@redhat.com> 2.2.5-2 |
| - Add missing xsom and rngom dependencies to the POM files |
| |
| * Sat Mar 10 2012 Juan Hernandez <juan.hernandez@redhat.com> 2.2.5-1 |
| - Updated to upstream version 2.2.5 |
| - Removed classpath from manifest files |
| |
| * Wed Mar 7 2012 Juan Hernandez <juan.hernandez@redhat.com> 2.2.4u1-4 |
| - Updated to reflect the change from glassfish-fi to glassfish-fastinfoset |
| |
| * Wed Feb 22 2012 Juan Hernandez <juan.hernandez@redhat.com> 2.2.4u1-3 |
| - Updated to reflect the changes of the jar names in txw2 |
| |
| * Wed Feb 22 2012 Juan Hernandez <juan.hernandez@redhat.com> 2.2.4u1-2 |
| - Cleanup of the spec file |
| |
| * Sat Jan 21 2012 Marek Goldmann <mgoldman@redhat.com> 2.2.4u1-1 |
| - Initial packaging |
| |