| |
| %if %{!?fedora:6}%{?fedora} >= 6 |
| %define gccver 34 |
| %else |
| %define gccver 32 |
| %endif |
| |
| Summary: QEMU is a FAST! processor emulator |
| Name: qemu |
| Version: 0.8.2 |
| Release: 2%{?dist} |
| License: GPL/LGPL |
| Group: Development/Tools |
| URL: http://www.qemu.org/ |
| Source0: http://www.qemu.org/%{name}-%{version}.tar.gz |
| Source1: qemu.init |
| Patch0: qemu-0.7.0-build.patch |
| Patch1: qemu-0.8.0-sdata.patch |
| Patch2: qemu-0.8.2-kernheaders.patch |
| Patch3: qemu-0.8.2-target-sparc.patch |
| BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) |
| BuildRequires: SDL-devel compat-gcc-%{gccver} zlib-devel which texi2html |
| Requires(post): /sbin/chkconfig |
| Requires(preun): /sbin/service /sbin/chkconfig |
| Requires(postun): /sbin/service |
| ExclusiveArch: %{ix86} x86_64 ppc alpha sparc armv4l |
| |
| %description |
| QEMU is a generic and open source processor emulator which achieves a good |
| emulation speed by using dynamic translation. QEMU has two operating modes: |
| |
| * Full system emulation. In this mode, QEMU emulates a full system (for |
| example a PC), including a processor and various peripherials. It can be |
| used to launch different Operating Systems without rebooting the PC or |
| to debug system code. |
| * User mode emulation. In this mode, QEMU can launch Linux processes compiled |
| for one CPU on another CPU. |
| |
| As QEMU requires no host kernel patches to run, it is safe and easy to use. |
| |
| %prep |
| %setup -q |
| %patch0 -p1 |
| %patch1 -p1 |
| %patch2 -p1 |
| %patch3 -p1 |
| |
| %build |
| ./configure \ |
| --prefix=%{_prefix} \ |
| --interp-prefix=%{_prefix}/qemu-%%M \ |
| --cc=gcc%{gccver} \ |
| --enable-alsa |
| make %{?_smp_mflags} |
| |
| %install |
| rm -rf $RPM_BUILD_ROOT |
| |
| make prefix="${RPM_BUILD_ROOT}%{_prefix}" \ |
| bindir="${RPM_BUILD_ROOT}%{_bindir}" \ |
| sharedir="${RPM_BUILD_ROOT}%{_prefix}/share/qemu" \ |
| mandir="${RPM_BUILD_ROOT}%{_mandir}" \ |
| docdir="${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}" \ |
| datadir="${RPM_BUILD_ROOT}%{_prefix}/share/qemu" install |
| |
| install -D -p -m 0755 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/qemu |
| |
| %clean |
| rm -rf $RPM_BUILD_ROOT |
| |
| %post |
| /sbin/chkconfig --add qemu |
| |
| %preun |
| if [ $1 -eq 0 ]; then |
| /sbin/service qemu stop &>/dev/null || : |
| /sbin/chkconfig --del qemu |
| fi |
| |
| %postun |
| if [ $1 -ge 1 ]; then |
| /sbin/service qemu condrestart &>/dev/null || : |
| fi |
| |
| %files |
| %defattr(-,root,root) |
| %doc Changelog README README.distrib TODO |
| %doc qemu-doc.html qemu-tech.html |
| %config %{_sysconfdir}/rc.d/init.d/qemu |
| %{_bindir}/qemu* |
| %{_prefix}/share/qemu/ |
| %{_mandir}/man1/* |
| |
| %changelog |
| * Thu Aug 24 2006 Matthias Saou <http://freshrpms.net/> 0.8.2-2 |
| - Remove the target-list iteration for x86_64 since they all build again. |
| - Make gcc32 vs. gcc34 conditional on %%{fedora} to share the same spec for |
| FC5 and FC6. |
| |
| * Wed Aug 23 2006 Matthias Saou <http://freshrpms.net/> 0.8.2-1 |
| - Update to 0.8.2 ( |
| - Drop upstreamed syscall-macros patch2. |
| - Put correct scriplet dependencies. |
| - Force install mode for the init script to avoid umask problems. |
| - Add %%postun condrestart for changes to the init script to be applied if any. |
| - Update description with the latest "about" from the web page (more current). |
| - Update URL to qemu.org one like the Source. |
| - Add which build requirement. |
| - Don't include texi files in %%doc since we ship them in html. |
| - Switch to using gcc34 on devel, FC5 still has gcc32. |
| - Add kernheaders patch to fix linux/compiler.h inclusion. |
| - Add target-sparc patch to fix compiling on ppc (some int32 to float). |
| |
| * Thu Jun 8 2006 David Woodhouse <dwmw2@infradead.org> 0.8.1-3 |
| - More header abuse in modify_ldt(), change BuildRoot: |
| |
| * Wed Jun 7 2006 David Woodhouse <dwmw2@infradead.org> 0.8.1-2 |
| - Fix up kernel header abuse |
| |
| * Tue May 30 2006 David Woodhouse <dwmw2@infradead.org> 0.8.1-1 |
| - Update to 0.8.1 |
| |
| * Sat Mar 18 2006 David Woodhouse <dwmw2@infradead.org> 0.8.0-6 |
| - Update linker script for PPC |
| |
| * Sat Mar 18 2006 David Woodhouse <dwmw2@infradead.org> 0.8.0-5 |
| - Just drop $RPM_OPT_FLAGS. They're too much of a PITA |
| |
| * Sat Mar 18 2006 David Woodhouse <dwmw2@infradead.org> 0.8.0-4 |
| - Disable stack-protector options which gcc 3.2 doesn't like |
| |
| * Fri Mar 17 2006 David Woodhouse <dwmw2@infradead.org> 0.8.0-3 |
| - Use -mcpu= instead of -mtune= on x86_64 too |
| - Disable SPARC targets on x86_64, because dyngen doesn't like fnegs |
| |
| * Fri Mar 17 2006 David Woodhouse <dwmw2@infradead.org> 0.8.0-2 |
| - Don't use -mtune=pentium4 on i386. GCC 3.2 doesn't like it |
| |
| * Fri Mar 17 2006 David Woodhouse <dwmw2@infradead.org> 0.8.0-1 |
| - Update to 0.8.0 |
| - Resort to using compat-gcc-32 |
| - Enable ALSA |
| |
| * Mon May 16 2005 David Woodhouse <dwmw2@infradead.org> 0.7.0-2 |
| - Proper fix for GCC 4 putting 'blr' or 'ret' in the middle of the function, |
| for i386, x86_64 and PPC. |
| |
| * Sat Apr 30 2005 David Woodhouse <dwmw2@infradead.org> 0.7.0-1 |
| - Update to 0.7.0 |
| - Fix dyngen for PPC functions which end in unconditional branch |
| |
| * Fri Apr 7 2005 Michael Schwendt <mschwendt[AT]users.sf.net> |
| - rebuilt |
| |
| * Sun Feb 13 2005 David Woodhouse <dwmw2@infradead.org> 0.6.1-2 |
| - Package cleanup |
| |
| * Sun Nov 21 2004 David Woodhouse <dwmw2@redhat.com> 0.6.1-1 |
| - Update to 0.6.1 |
| |
| * Tue Jul 20 2004 David Woodhouse <dwmw2@redhat.com> 0.6.0-2 |
| - Compile fix from qemu CVS, add x86_64 host support |
| |
| * Mon May 12 2004 David Woodhouse <dwmw2@redhat.com> 0.6.0-1 |
| - Update to 0.6.0. |
| |
| * Sat May 8 2004 David Woodhouse <dwmw2@redhat.com> 0.5.5-1 |
| - Update to 0.5.5. |
| |
| * Thu May 2 2004 David Woodhouse <dwmw2@redhat.com> 0.5.4-1 |
| - Update to 0.5.4. |
| |
| * Thu Apr 22 2004 David Woodhouse <dwmw2@redhat.com> 0.5.3-1 |
| - Update to 0.5.3. Add init script. |
| |
| * Thu Jul 17 2003 Jeff Johnson <jbj@redhat.com> 0.4.3-1 |
| - Create. |