18d3a4 import which-2.21-18.el8

Authored and Committed by centosrcm 2 years ago
    import which-2.21-18.el8
    
        
file modified
+1 -1
SOURCES/which2.sh CHANGED
@@ -20,7 +20,7 @@ bash|sh)
20
20
;;
21
21
esac
22
22
23
- which () {
23
+ function which {
24
24
(alias; eval ${which_declare}) | /usr/bin/which --tty-only --read-alias --read-functions --show-tilde --show-dot $@
25
25
}
26
26
file modified
+4 -1
SPECS/which.spec CHANGED
@@ -1,7 +1,7 @@
1
1
Summary: Displays where a particular program in your path is located
2
2
Name: which
3
3
Version: 2.21
4
- Release: 17%{?dist}
4
+ Release: 18%{?dist}
5
5
License: GPLv3
6
6
Source0: http://ftp.gnu.org/gnu/which/%{name}-%{version}.tar.gz
7
7
Source1: which2.sh
@@ -42,6 +42,9 @@ rm -f $RPM_BUILD_ROOT%{_infodir}/dir
42
42
%{_mandir}/man1/which.1*
43
43
44
44
%changelog
45
+ * Mon Apr 11 2022 Than Ngo <than@redhat.com> - 2.21-18
46
+ - Resolves: #2044450 - custom profile generates shell error
47
+
45
48
* Thu Nov 25 2021 Than Ngo <than@redhat.com> - 2.21-17
46
49
- Resolves: #2025709, check shell correctly
47
50
- Resolves: #2009547, which treats function contents as aliases when parsing ksh