cde090 - patchlevel 088

Authored and Committed by Karsten Hopp 15 years ago
    - patchlevel 088
    
        
file added
+99
7.2.088 ADDED
@@ -0,0 +1,99 @@
1
+ To: vim-dev@vim.org
2
+ Subject: Patch 7.2.088 (extra)
3
+ Fcc: outbox
4
+ From: Bram Moolenaar <Bram@moolenaar.net>
5
+ Mime-Version: 1.0
6
+ Content-Type: text/plain; charset=ISO-8859-1
7
+ Content-Transfer-Encoding: 8bit
8
+ ------------
9
+
10
+ Patch 7.2.088 (extra)
11
+ Problem: OpenClipboard() may fail when another application is using the
12
+ clipboard.
13
+ Solution: Retry OpenClipboard() a few times. (Jianrong Yu)
14
+ Files: src/os_mswin.c
15
+
16
+
17
+ *** ../vim-7.2.087/src/os_mswin.c Thu Nov 20 17:09:09 2008
18
+ --- src/os_mswin.c Thu Jan 22 18:38:12 2009
19
+ ***************
20
+ *** 1224,1229 ****
21
+ --- 1224,1248 ----
22
+ #endif /* FEAT_MBYTE */
23
+
24
+ /*
25
+ + * Wait for another process to Close the Clipboard.
26
+ + * Returns TRUE for success.
27
+ + */
28
+ + int
29
+ + vim_open_clipboard()
30
+ + {
31
+ + int delay = 10;
32
+ +
33
+ + while (!OpenClipboard(NULL))
34
+ + {
35
+ + if (delay > 500)
36
+ + return FALSE; /* waited too long, give up */
37
+ + Sleep(delay);
38
+ + delay *= 2; /* wait for 10, 20, 40, 80, etc. msec */
39
+ + }
40
+ + return TRUE;
41
+ + }
42
+ +
43
+ + /*
44
+ * Get the current selection and put it in the clipboard register.
45
+ *
46
+ * NOTE: Must use GlobalLock/Unlock here to ensure Win32s compatibility.
47
+ ***************
48
+ *** 1254,1260 ****
49
+ * Don't pass GetActiveWindow() as an argument to OpenClipboard() because
50
+ * then we can't paste back into the same window for some reason - webb.
51
+ */
52
+ ! if (!OpenClipboard(NULL))
53
+ return;
54
+
55
+ /* Check for vim's own clipboard format first. This only gets the type of
56
+ --- 1273,1279 ----
57
+ * Don't pass GetActiveWindow() as an argument to OpenClipboard() because
58
+ * then we can't paste back into the same window for some reason - webb.
59
+ */
60
+ ! if (!vim_open_clipboard())
61
+ return;
62
+
63
+ /* Check for vim's own clipboard format first. This only gets the type of
64
+ ***************
65
+ *** 1562,1568 ****
66
+ * because then we can't paste back into the same window for some
67
+ * reason - webb.
68
+ */
69
+ ! if (OpenClipboard(NULL))
70
+ {
71
+ if (EmptyClipboard())
72
+ {
73
+ --- 1581,1587 ----
74
+ * because then we can't paste back into the same window for some
75
+ * reason - webb.
76
+ */
77
+ ! if (vim_open_clipboard())
78
+ {
79
+ if (EmptyClipboard())
80
+ {
81
+ *** ../vim-7.2.087/src/version.c Thu Jan 22 21:31:24 2009
82
+ --- src/version.c Thu Jan 22 21:47:52 2009
83
+ ***************
84
+ *** 678,679 ****
85
+ --- 678,681 ----
86
+ { /* Add new patch number below this line */
87
+ + /**/
88
+ + 88,
89
+ /**/
90
+
91
+ --
92
+ hundred-and-one symptoms of being an internet addict:
93
+ 22. You've already visited all the links at Yahoo and you're halfway through
94
+ Lycos.
95
+
96
+ /// Bram Moolenaar -- Bram@Moolenaar.net -- http://www.Moolenaar.net \\\
97
+ /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
98
+ \\\ download, build and distribute -- http://www.A-A-P.org ///
99
+ \\\ help me help AIDS victims -- http://ICCF-Holland.org ///
file modified
+9 -0
README.patches CHANGED
@@ -104,3 +104,12 @@ Individual patches for Vim 7.2:
104
104
4745 7.2.077 (after 7.2.076) rename() fails if names differ only in case
105
105
3298 7.2.078 problems with deleting folds
106
106
6947 7.2.079 "killed" netbeans events are not handled correctly
107
+ 9942 7.2.080 accessing wrong memory with completion and composing char
108
+ 1728 7.2.081 compiler warning for float overflow on VAX
109
+ 2134 7.2.082 if 'ff' is "mac" then "ga" on a ^J shows 0x0d instead of 0x0a
110
+ 1733 7.2.083 ":tag" doesn't return to the right tag entry in the tag stack
111
+ 4331 7.2.084 Python: vim.eval() is wrong for recursive structures
112
+ 1862 7.2.085 ":set <M-b>=<Esc>b" does not work when 'encoding' is utf-8
113
+ 3045 7.2.086 using ":diffget 1" in buffer 1 corrupts the text
114
+ 1570 7.2.087 adding URL to 'path' doesn't work to edit a file
115
+ 2895 7.2.088 (extra) Win32: Using the clipboard sometimes fails
file modified
+23 -3
vim.spec CHANGED
@@ -18,13 +18,13 @@
18
18
#used for pre-releases:
19
19
%define beta %{nil}
20
20
%define vimdir vim72%{?beta}
21
- %define patchlevel 079
21
+ %define patchlevel 088
22
22
23
23
Summary: The VIM editor
24
24
URL: http://www.vim.org/
25
25
Name: vim
26
26
Version: %{baseversion}.%{beta}%{patchlevel}
27
- Release: 2%{?dist}
27
+ Release: 1%{?dist}
28
28
License: Vim
29
29
Group: Applications/Editors
30
30
Source0: ftp://ftp.vim.org/pub/vim/unix/vim-%{baseversion}%{?beta}%{?CVSDATE}.tar.bz2
@@ -145,6 +145,15 @@ Patch076: ftp://ftp.vim.org/pub/vim/patches/7.2/7.2.076
145
145
Patch077: ftp://ftp.vim.org/pub/vim/patches/7.2/7.2.077
146
146
Patch078: ftp://ftp.vim.org/pub/vim/patches/7.2/7.2.078
147
147
Patch079: ftp://ftp.vim.org/pub/vim/patches/7.2/7.2.079
148
+ Patch080: ftp://ftp.vim.org/pub/vim/patches/7.2/7.2.080
149
+ Patch081: ftp://ftp.vim.org/pub/vim/patches/7.2/7.2.081
150
+ Patch082: ftp://ftp.vim.org/pub/vim/patches/7.2/7.2.082
151
+ Patch083: ftp://ftp.vim.org/pub/vim/patches/7.2/7.2.083
152
+ Patch084: ftp://ftp.vim.org/pub/vim/patches/7.2/7.2.084
153
+ Patch085: ftp://ftp.vim.org/pub/vim/patches/7.2/7.2.085
154
+ Patch086: ftp://ftp.vim.org/pub/vim/patches/7.2/7.2.086
155
+ Patch087: ftp://ftp.vim.org/pub/vim/patches/7.2/7.2.087
156
+ Patch088: ftp://ftp.vim.org/pub/vim/patches/7.2/7.2.088
148
157
149
158
Patch3000: vim-7.0-syntax.patch
150
159
Patch3002: vim-7.1-nowarnings.patch
@@ -357,7 +366,15 @@ perl -pi -e "s,bin/nawk,bin/awk,g" runtime/tools/mve.awk
357
366
%patch077 -p0
358
367
%patch078 -p0
359
368
%patch079 -p0
360
-
369
+ %patch080 -p0
370
+ %patch081 -p0
371
+ %patch082 -p0
372
+ %patch083 -p0
373
+ %patch084 -p0
374
+ %patch085 -p0
375
+ %patch086 -p0
376
+ %patch087 -p0
377
+ %patch088 -p0
361
378
362
379
# install spell files
363
380
%if %{withvimspell}
@@ -816,6 +833,9 @@ rm -rf $RPM_BUILD_ROOT
816
833
%{_datadir}/icons/hicolor/*/apps/*
817
834
818
835
%changelog
836
+ * Mon Jan 26 2009 Karsten Hopp <karsten@redhat.com> 7.2.088-1
837
+ - patchlevel 88
838
+
819
839
* Thu Jan 08 2009 Karsten Hopp <karsten@redhat.com> 7.2.079-2
820
840
- patchlevel 79
821
841