52ed02 - patchlevel 363

Authored and Committed by Zdenek Dohnal 7 years ago
    - patchlevel 363
    
        
file modified
+1 -0
.gitignore CHANGED
@@ -38,3 +38,4 @@
38
38
/vim-8.0-342.tar.bz2
39
39
/vim-8.0-344.tar.bz2
40
40
/vim-8.0-347.tar.bz2
41
+ /vim-8.0-363.tar.bz2
file modified
+151 -0
README.patches CHANGED
@@ -1,3 +1,154 @@
1
+ commit 3834e3d039777e0144914a86289870bee147c0a2
2
+ Author: Bram Moolenaar <Bram@vim.org>
3
+ Date: Thu Feb 23 20:20:53 2017 +0100
4
+
5
+ patch 8.0.0363: Travis is too slow to keep up with patches
6
+
7
+ Problem: Travis is too slow to keep up with patches.
8
+ Solution: Increase git depth to 20
9
+
10
+ commit 10c6029e28ab666a42190fcceb0bb098a4ebf724
11
+ Author: Bram Moolenaar <Bram@vim.org>
12
+ Date: Thu Feb 23 20:17:13 2017 +0100
13
+
14
+ patch 8.0.0362: tests fail on MS-Windows
15
+
16
+ Problem: Tests fail on MS-Windows.
17
+ Solution: Use $*.vim instead of $<.
18
+
19
+ commit 8be2fbb6705dfb41d06d688701803d206c968404
20
+ Author: Bram Moolenaar <Bram@vim.org>
21
+ Date: Thu Feb 23 19:32:47 2017 +0100
22
+
23
+ patch 8.0.0361: GUI initialisation is not sufficiently tested
24
+
25
+ Problem: GUI initialisation is not sufficiently tested.
26
+ Solution: Add the gui_init test. (Kazuki Kuriyama)
27
+
28
+ commit b544f3c81f1e6a50322855681ac266ffaa8e313c
29
+ Author: Bram Moolenaar <Bram@vim.org>
30
+ Date: Thu Feb 23 19:03:28 2017 +0100
31
+
32
+ patch 8.0.0360: sometimes VimL is used instead of "Vim script"
33
+
34
+ Problem: Sometimes VimL is used, which is confusing.
35
+ Solution: Consistently use "Vim script". (Hirohito Higashi)
36
+
37
+ commit dc9a081712ec8c140e6d4909e9f6b03a629d32d3
38
+ Author: Bram Moolenaar <Bram@vim.org>
39
+ Date: Thu Feb 23 18:46:50 2017 +0100
40
+
41
+ patch 8.0.0359: 'number' and 'relativenumber' are not properly tested
42
+
43
+ Problem: 'number' and 'relativenumber' are not properly tested.
44
+ Solution: Add tests, change old style to new style tests. (Ozaki Kiichi,
45
+ closes #1447)
46
+
47
+ commit 60629d642541a089c322e65963c0a77e5f77eb79
48
+ Author: Bram Moolenaar <Bram@vim.org>
49
+ Date: Thu Feb 23 18:08:56 2017 +0100
50
+
51
+ patch 8.0.0358: invalid memory access in C-indent code
52
+
53
+ Problem: Invalid memory access in C-indent code.
54
+ Solution: Don't go over end of empty line. (Dominique Pelle, closes #1492)
55
+
56
+ commit 24922ec23360e7ea7c5a803c9edf476bb6395b32
57
+ Author: Bram Moolenaar <Bram@vim.org>
58
+ Date: Thu Feb 23 17:59:22 2017 +0100
59
+
60
+ patch 8.0.0357: crash when setting 'guicursor' to weird value
61
+
62
+ Problem: Crash when setting 'guicursor' to weird value.
63
+ Solution: Avoid negative size. (Dominique Pelle, closes #1465)
64
+
65
+ commit 354796c19a0a4a048017059a0281938cc0b8f09a
66
+ Author: Bram Moolenaar <Bram@vim.org>
67
+ Date: Thu Feb 23 17:18:37 2017 +0100
68
+
69
+ patch 8.0.0356: leaking memory when setting 'ttytype'
70
+
71
+ Problem: Leaking memory when setting 'ttytype'.
72
+ Solution: Get free_oldval from the right option entry.
73
+
74
+ commit 187a4f28140f10ff833862be7e3ef823d317e1c7
75
+ Author: Bram Moolenaar <Bram@vim.org>
76
+ Date: Thu Feb 23 17:07:14 2017 +0100
77
+
78
+ patch 8.0.0355: using uninitialized memory when 'isfname' is empty
79
+
80
+ Problem: Using uninitialized memory when 'isfname' is empty.
81
+ Solution: Don't call getpwnam() without an argument. (Dominique Pelle,
82
+ closes #1464)
83
+
84
+ commit 1c410400fad79068b16dc4c6c7a023463a0858cf
85
+ Author: Bram Moolenaar <Bram@vim.org>
86
+ Date: Thu Feb 23 15:20:03 2017 +0100
87
+
88
+ patch 8.0.0354: test to check that setting termcap key fails sometimes
89
+
90
+ Problem: Test to check that setting termcap key fails sometimes.
91
+ Solution: Check for "t_k1" to exist. (Christian Brabandt, closes #1459)
92
+
93
+ commit 3457d295f4035293a78f9a9851ea416f923dd59e
94
+ Author: Bram Moolenaar <Bram@vim.org>
95
+ Date: Thu Feb 23 14:55:59 2017 +0100
96
+
97
+ patch 8.0.0353: if [RO] is translated it may be truncated
98
+
99
+ Problem: If [RO] in the status line is translated to a longer string, it is
100
+ trunctted to 4 bytes.
101
+ Solution: Skip over the resulting string. (Jente Hidskes, closes #1499)
102
+
103
+ commit f06e5a549f42396be3478ccc1b5f03be64e1173e
104
+ Author: Bram Moolenaar <Bram@vim.org>
105
+ Date: Thu Feb 23 14:25:17 2017 +0100
106
+
107
+ patch 8.0.0352: not easy to see when a typval needs to be cleared
108
+
109
+ Problem: The condition for when a typval needs to be cleared is too
110
+ complicated.
111
+ Solution: Init the type to VAR_UNKNOWN and clear it always.
112
+
113
+ commit 218426896cbb2129aa4e85803ea97c5b57df1eaa
114
+ Author: Bram Moolenaar <Bram@vim.org>
115
+ Date: Thu Feb 23 13:50:38 2017 +0100
116
+
117
+ patch 8.0.0351: no test for concatenating an empty string
118
+
119
+ Problem: No test for concatenating an empty string that results from out of
120
+ bounds indexing.
121
+ Solution: Add a simple test.
122
+
123
+ commit ae177b716626c8d517b7c6c7d77f8b1aec6ba5f9
124
+ Author: Bram Moolenaar <Bram@vim.org>
125
+ Date: Thu Feb 23 13:45:57 2017 +0100
126
+
127
+ patch 8.0.0350: not enough test coverage for Perl
128
+
129
+ Problem: Not enough test coverage for Perl.
130
+ Solution: Add more Perl tests. (Dominique Perl, closes #1500)
131
+
132
+ commit fe344a9875667537ce32fc11936dc56ad51f2139
133
+ Author: Bram Moolenaar <Bram@vim.org>
134
+ Date: Thu Feb 23 12:20:35 2017 +0100
135
+
136
+ patch 8.0.0349: redrawing errors with GTK 3
137
+
138
+ Problem: Redrawing errors with GTK 3.
139
+ Solution: When updating, first clear all rectangles and then draw them.
140
+ (Kazunobu Kuriyama, Christian Ludwig, closes #848)
141
+
142
+ commit b7a59906d7ce41b7e74ec31b910375c21e427c0a
143
+ Author: Bram Moolenaar <Bram@vim.org>
144
+ Date: Wed Feb 22 22:04:04 2017 +0100
145
+
146
+ patch 8.0.0348: using shadow dir on Mac lack +clipboard
147
+
148
+ Problem: When building with a shadow directory on macOS lacks the
149
+ +clipboard feature.
150
+ Solution: Link *.m files, specifically os_macosx.m. (Kazunobu Kuriyama)
151
+
1
152
commit d099e033703ce0772f152b8df8a763f0b65303ee
2
153
Author: Bram Moolenaar <Bram@vim.org>
3
154
Date: Tue Feb 21 23:00:36 2017 +0100
file modified
+1 -1
sources CHANGED
@@ -1 +1 @@
1
- SHA512 (vim-8.0-347.tar.bz2) = 2e1cc927c154db7a3200cf8b0ba3f2b7054ed971dd438efa1e157260d646b52e895f721b5ebe056e81c90e8299b74a7db58a2e3af7286150636748fcbbc0492d
1
+ SHA512 (vim-8.0-363.tar.bz2) = 4f102287119aa1f891389d0f20a5d4f489ef879893312d06e9b1552ad15a717d953688450d7ae8562e46012a8a269407d889b803ed6833a235c669e4a4268bcb
file modified
+5 -4
vim.spec CHANGED
@@ -1,4 +1,4 @@
1
- %define patchlevel 347
1
+ %define patchlevel 363
2
2
%if %{?WITH_SELINUX:0}%{!?WITH_SELINUX:1}
3
3
%define WITH_SELINUX 1
4
4
%endif
@@ -21,7 +21,7 @@ Summary: The VIM editor
21
21
URL: http://www.vim.org/
22
22
Name: vim
23
23
Version: %{baseversion}.%{patchlevel}
24
- Release: 2%{?dist}
24
+ Release: 1%{?dist}
25
25
License: Vim
26
26
Group: Applications/Editors
27
27
Source0: ftp://ftp.vim.org/pub/vim/unix/vim-%{baseversion}-%{patchlevel}.tar.bz2
@@ -64,7 +64,6 @@ Patch3012: vim-7.4-licensemacro-1151450.patch
64
64
Patch3013: vim-7.4-globalsyntax.patch
65
65
Patch3014: vim-7.4-releasestring-1318991.patch
66
66
Patch3015: vim-8.0-copy-paste.patch
67
- Patch3016: vim-8.0-gtk3-render.patch
68
67
69
68
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
70
69
BuildRequires: python-devel python3-devel ncurses-devel gettext perl-devel
@@ -219,7 +218,6 @@ perl -pi -e "s,bin/nawk,bin/awk,g" runtime/tools/mve.awk
219
218
%patch3013 -p1
220
219
%patch3014 -p1
221
220
%patch3015 -p1
222
- %patch3016 -p1
223
221
224
222
%build
225
223
cp -f %{SOURCE6} .
@@ -765,6 +763,9 @@ rm -rf %{buildroot}
765
763
%{_datadir}/icons/locolor/*/apps/*
766
764
767
765
%changelog
766
+ * Fri Feb 24 2017 Karsten Hopp <karsten@redhat.com> 8.0.363-1
767
+ - patchlevel 363
768
+
768
769
* Wed Feb 22 2017 Karsten Hopp <karsten@redhat.com> 8.0.347-1
769
770
- patchlevel 347
770
771
- 1405234 - Gvim fails to properly render after Openbox desktop switch