1efb73 Fix conflicts in vim-crypto-warning.patch

Authored and Committed by Zdenek Dohnal 3 years ago
    Fix conflicts in vim-crypto-warning.patch
    
        
file modified
+9 -9
vim-crypto-warning.patch CHANGED
@@ -1,7 +1,7 @@
1
1
diff -up vim82/src/config.h.in.fips-warning vim82/src/config.h.in
2
- --- vim82/src/config.h.in.fips-warning 2021-03-01 12:20:20.887162181 +0100
3
- +++ vim82/src/config.h.in 2021-03-01 12:20:42.520977438 +0100
4
- @@ -499,3 +499,12 @@
2
+ --- vim82/src/config.h.in.fips-warning 2021-06-23 11:46:55.000000000 +0200
3
+ +++ vim82/src/config.h.in 2021-06-23 11:55:03.165480970 +0200
4
+ @@ -501,3 +501,12 @@
5
5
6
6
/* Define if _SC_SIGSTKSZ is available via sysconf() */
7
7
#undef HAVE_SYSCONF_SIGSTKSZ
@@ -15,8 +15,8 @@ diff -up vim82/src/config.h.in.fips-warning vim82/src/config.h.in
15
15
+/* Link to fips_enabled file */
16
16
+#undef FIPS_ENABLED_FILE_LINK
17
17
diff -up vim82/src/configure.ac.fips-warning vim82/src/configure.ac
18
- --- vim82/src/configure.ac.fips-warning 2021-03-01 12:20:20.885162198 +0100
19
- +++ vim82/src/configure.ac 2021-03-01 12:20:20.888162173 +0100
18
+ --- vim82/src/configure.ac.fips-warning 2021-06-23 11:55:03.163480985 +0200
19
+ +++ vim82/src/configure.ac 2021-06-23 11:55:03.166480962 +0200
20
20
@@ -541,6 +541,38 @@ else
21
21
AC_MSG_RESULT(yes)
22
22
fi
@@ -57,9 +57,9 @@ diff -up vim82/src/configure.ac.fips-warning vim82/src/configure.ac
57
57
AC_MSG_CHECKING(--enable-luainterp argument)
58
58
AC_ARG_ENABLE(luainterp,
59
59
diff -up vim82/src/crypt.c.fips-warning vim82/src/crypt.c
60
- --- vim82/src/crypt.c.fips-warning 2021-03-01 12:13:11.000000000 +0100
61
- +++ vim82/src/crypt.c 2021-03-01 12:20:20.888162173 +0100
62
- @@ -523,6 +523,21 @@ crypt_check_method(int method)
60
+ --- vim82/src/crypt.c.fips-warning 2021-06-23 11:55:03.166480962 +0200
61
+ +++ vim82/src/crypt.c 2021-06-23 12:36:22.295488425 +0200
62
+ @@ -603,6 +603,21 @@ crypt_check_method(int method)
63
63
msg_scroll = TRUE;
64
64
msg(_("Warning: Using a weak encryption method; see :help 'cm'"));
65
65
}
@@ -80,4 +80,4 @@ diff -up vim82/src/crypt.c.fips-warning vim82/src/crypt.c
80
80
+#endif
81
81
}
82
82
83
- void
83
+ #ifdef FEAT_SODIUM