18b3b4 - patchlevel 311

Authored and Committed by Zdenek Dohnal 8 years ago
    - patchlevel 311
    
        
file modified
+1 -0
.gitignore CHANGED
@@ -30,3 +30,4 @@
30
30
/vim-8.0-273.tar.bz2
31
31
/vim-8.0-275.tar.bz2
32
32
/vim-8.0-297.tar.bz2
33
+ /vim-8.0-311.tar.bz2
file modified
+137 -0
README.patches CHANGED
@@ -1,3 +1,140 @@
1
+ commit 544d3bc9f0e494cb712a33b61558b8e8e12b1e0b
2
+ Author: Bram Moolenaar <Bram@vim.org>
3
+ Date: Sun Feb 5 21:14:50 2017 +0100
4
+
5
+ patch 8.0.0311: linebreak tests are old style
6
+
7
+ Problem: Linebreak tests are old style.
8
+ Solution: Turn the tests into new style. Share utility functions. (Ozaki
9
+ Kiichi, closes #1444)
10
+
11
+ commit 13c724fb3a630257b736a1c91643b396fee917c1
12
+ Author: Bram Moolenaar <Bram@vim.org>
13
+ Date: Sun Feb 5 20:54:26 2017 +0100
14
+
15
+ patch 8.0.0310: not enough testing for GUI functionality
16
+
17
+ Problem: Not enough testing for GUI functionality.
18
+ Solution: Add tests for v:windowid and getwinpos[xy](). (Kazunobu Kuriyama)
19
+
20
+ commit 059b7482a2d9d4cebbf4c01b2b2ea6f1e783cc20
21
+ Author: Bram Moolenaar <Bram@vim.org>
22
+ Date: Sun Feb 5 16:34:43 2017 +0100
23
+
24
+ patch 8.0.0309: cannot use an empty key in json
25
+
26
+ Problem: Cannot use an empty key in json.
27
+ Solution: Allow for using an empty key.
28
+
29
+ commit 2f9e575583c2ad3978ee3d0f790eeff7df56bd6c
30
+ Author: Bram Moolenaar <Bram@vim.org>
31
+ Date: Sun Feb 5 16:07:54 2017 +0100
32
+
33
+ patch 8.0.0308: 'runtimepath' not update correctly when using symbolic link
34
+
35
+ Problem: When using a symbolic link, the package path will not be inserted
36
+ at the right position in 'runtimepath'. (Dugan Chen, Norio Takagi)
37
+ Solution: Resolve symbolic links when finding the right position in
38
+ 'runtimepath'. (Hirohito Higashi)
39
+
40
+ commit 955f198fc546cc30a34361932d3f454a61df0efa
41
+ Author: Bram Moolenaar <Bram@vim.org>
42
+ Date: Sun Feb 5 15:10:51 2017 +0100
43
+
44
+ patch 8.0.0307: asan detects a memory error when EXITFREE is defined
45
+
46
+ Problem: Asan detects a memory error when EXITFREE is defined. (Dominique
47
+ Pelle)
48
+ Solution: In getvcol() check for ml_get_buf() returning an empty string.
49
+ Also skip adjusting the scroll position. Set "exiting" in
50
+ mch_exit() for all systems.
51
+
52
+ commit e971df39a5aac5d9b7e8033247dc18b12daa0eb8
53
+ Author: Bram Moolenaar <Bram@vim.org>
54
+ Date: Sun Feb 5 14:15:29 2017 +0100
55
+
56
+ patch 8.0.0306: mode() not sufficiently tested
57
+
58
+ Problem: mode() not sufficiently tested.
59
+ Solution: Add more tests. (Yegappan Lakshmanan)
60
+
61
+ commit aaaf57d8a936efe420190c077e4a74041cc6c72e
62
+ Author: Bram Moolenaar <Bram@vim.org>
63
+ Date: Sun Feb 5 14:13:20 2017 +0100
64
+
65
+ patch 8.0.0305: invalid memory access when option has duplicate flag
66
+
67
+ Problem: Invalid memory access when option has duplicate flag.
68
+ Solution: Correct pointer computation. (Dominique Pelle, closes #1442)
69
+
70
+ commit 1fb0d49803b4f57025ed6a43b1f5b9eb91524645
71
+ Author: Bram Moolenaar <Bram@vim.org>
72
+ Date: Sat Feb 4 21:50:19 2017 +0100
73
+
74
+ patch 8.0.0304: assign test fails in the GUI
75
+
76
+ Problem: Assign test fails in the GUI.
77
+ Solution: Skip the test for setting t_k1.
78
+
79
+ commit a1891848d970452cd775d35a4bccfdd9758a690a
80
+ Author: Bram Moolenaar <Bram@vim.org>
81
+ Date: Sat Feb 4 21:34:31 2017 +0100
82
+
83
+ patch 8.0.0303: bracketed paste does not work in Visual mode
84
+
85
+ Problem: Bracketed paste does not work in Visual mode.
86
+ Solution: Delete the text before pasting
87
+
88
+ commit e353c402e63b9b0a0bc06acf390e352d9e7eeaeb
89
+ Author: Bram Moolenaar <Bram@vim.org>
90
+ Date: Sat Feb 4 19:49:16 2017 +0100
91
+
92
+ patch 8.0.0302: cannot set terminal key codes with :let
93
+
94
+ Problem: Cannot set terminal key codes with :let.
95
+ Solution: Make it work.
96
+
97
+ commit 698f8b207bbfefa1cbbd7361caf5412cb3416534
98
+ Author: Bram Moolenaar <Bram@vim.org>
99
+ Date: Sat Feb 4 15:53:32 2017 +0100
100
+
101
+ patch 8.0.0301: not enough testing for setting options
102
+
103
+ Problem: No tests for ":set completion" and various errors of the :set
104
+ command.
105
+ Solution: Add more :set tests. (Dominique Pelle, closes #1440)
106
+
107
+ commit 25ea0544587dd45088512fec9d7a685e35fea679
108
+ Author: Bram Moolenaar <Bram@vim.org>
109
+ Date: Fri Feb 3 23:16:28 2017 +0100
110
+
111
+ patch 8.0.0300: cannot stop diffing hidden buffers
112
+
113
+ Problem: Cannot stop diffing hidden buffers. (Daniel Hahler)
114
+ Solution: When using :diffoff! make the whole list if diffed buffers empty.
115
+ (closes #736)
116
+
117
+ commit 6b40f303291be6b2fe524b5708e089773048c269
118
+ Author: Bram Moolenaar <Bram@vim.org>
119
+ Date: Fri Feb 3 22:01:47 2017 +0100
120
+
121
+ patch 8.0.0299: a window resize is sometimes not taking effect
122
+
123
+ Problem: When the GUI window is resized Vim does not always take over the
124
+ new size. (Luchr)
125
+ Solution: Reset new_p_guifont in gui_resize_shell(). Call
126
+ gui_may_resize_shell() in the main loop.
127
+
128
+ commit cbf20fbcd3e9bb006f694bcc35da859930fb12a2
129
+ Author: Bram Moolenaar <Bram@vim.org>
130
+ Date: Fri Feb 3 21:19:04 2017 +0100
131
+
132
+ patch 8.0.0298: Ex command range with repeated search does not work
133
+
134
+ Problem: Ex command range with repeated search does not work. (Bruce
135
+ DeVisser)
136
+ Solution: Skip over \/, \? and \&.
137
+
1
138
commit 03ff9bcbc968f7d306e4a4e334e226fdde62ca82
2
139
Author: Bram Moolenaar <Bram@vim.org>
3
140
Date: Thu Feb 2 22:59:27 2017 +0100
file modified
+1 -1
sources CHANGED
@@ -1 +1 @@
1
- SHA512 (vim-8.0-297.tar.bz2) = de618eebce6a20ed839d4cb8199ca05a1658a1fe8ca1c0854f32c7aa29929ce547114bbb7f71a3b8be99c46c6923895e9a66daa9d7f41e42cba4bcff62e3444d
1
+ SHA512 (vim-8.0-311.tar.bz2) = 0198a342b0c212b6c9c119d76791e4de5cd5fa6e42ff97c3d26fff1e5afa66aa2bf594ec9e6c556425ea0098982af94160c32cc83723fe5bdb58ecf73da847f1
file modified
+4 -1
vim.spec CHANGED
@@ -1,4 +1,4 @@
1
- %define patchlevel 297
1
+ %define patchlevel 311
2
2
%if %{?WITH_SELINUX:0}%{!?WITH_SELINUX:1}
3
3
%define WITH_SELINUX 1
4
4
%endif
@@ -756,6 +756,9 @@ rm -rf %{buildroot}
756
756
%{_datadir}/icons/locolor/*/apps/*
757
757
758
758
%changelog
759
+ * Mon Feb 06 2017 Karsten Hopp <karsten@redhat.com> 8.0.311-1
760
+ - patchlevel 311
761
+
759
762
* Fri Feb 03 2017 Karsten Hopp <karsten@redhat.com> 8.0.297-1
760
763
- patchlevel 297
761
764