122395 Initial import (#1369720).

Authored and Committed by Yunying Sun 8 years ago
    Initial import (#1369720).
    
        
file added
+60
tpm2-tools.spec ADDED
@@ -0,0 +1,60 @@
1
+ Name: tpm2-tools
2
+ Version: 1.1.0
3
+ Release: 2%{?dist}
4
+ Summary: A TPM2.0 testing tool build upon TPM2.0-TSS
5
+
6
+ %global pkg_prefix tpm2.0-tools
7
+
8
+ License: BSD
9
+ URL: https://github.com/01org/tpm2.0-tools
10
+ Source0: https://github.com/01org/tpm2.0-tools/archive/v%{version}.tar.gz#/%{pkg_prefix}-%{version}.tar.gz
11
+
12
+ BuildRequires: gcc
13
+ BuildRequires: gcc-c++
14
+ BuildRequires: libtool
15
+ BuildRequires: autoconf-archive
16
+ BuildRequires: pkgconfig(cmocka)
17
+ BuildRequires: pkgconfig(libcurl)
18
+ BuildRequires: pkgconfig(openssl)
19
+ # tpm2-tss-devel-1.0-2 provides sapi/tcti-device/tcti-socket
20
+ BuildRequires: pkgconfig(sapi)
21
+ BuildRequires: pkgconfig(tcti-device)
22
+ BuildRequires: pkgconfig(tcti-socket)
23
+
24
+ # this package does not support big endian arch so far,
25
+ # and has been verified only on Intel platforms.
26
+ ExclusiveArch: %{ix86} x86_64
27
+
28
+ # tpm2-tools is heavily depending on TPM2.0-TSS project, matched tss is required
29
+ Requires: tpm2-tss = 1.0-2
30
+
31
+ %description
32
+ tpm2-tools is a batch of testing tools for tpm2.0. It is based on tpm2-tss.
33
+
34
+ %prep
35
+ %autosetup -n %{pkg_prefix}-%{version}
36
+ ./bootstrap
37
+
38
+ %build
39
+ %configure --prefix=/usr --disable-static --disable-silent-rules
40
+ %make_build
41
+
42
+ %install
43
+ %make_install
44
+
45
+ %files
46
+ %doc README.md CHANGELOG
47
+ %license LICENSE
48
+ %{_sbindir}/tpm2_*
49
+
50
+ %changelog
51
+ * Wed Dec 21 2016 Sun Yunying <yunying.sun@intel.com> - 1.1.0-2
52
+ - Remove pkg_version to avoid dupliate use of version
53
+ - Remove redundant BuildRequires for autoconf/automake/pkgconfig
54
+ - Add comments for BuildRequires of sapi/tcti-device/tcti-socket
55
+ - Use ExclusiveArch instead of ExcludeArch
56
+ - Requires tpm2-tss version updated to 1.0-2
57
+ - Updated release version and changelog
58
+
59
+ * Fri Dec 2 2016 Sun Yunying <yunying.sun@intel.com> - 1.1.0-1
60
+ - Initial version of the package
empty file added