65221f Increase timeout in another test

Authored and Committed by Zbigniew Jędrzejewski-Szmek 4 years ago
    Increase timeout in another test
    
        
0001-test-ndisc-rs-increase-timeouts.patch ADDED
@@ -0,0 +1,58 @@
1
+ From ea21882c9a18f2fc422c9090cd262a64cb452ee9 Mon Sep 17 00:00:00 2001
2
+ From: =?UTF-8?q?Zbigniew=20J=C4=99drzejewski-Szmek?= <zbyszek@in.waw.pl>
3
+ Date: Mon, 27 Jul 2020 16:09:22 +0200
4
+ Subject: [PATCH] test-ndisc-rs: increase timeouts
5
+
6
+ Timestamp: Mon 2020-07-27 13:50:50 UTC
7
+ Monotonic: 985702942708
8
+ Hop limit: 64
9
+ Flags: <|MANAGED>
10
+ Preference: medium
11
+ Lifetime: 180
12
+ No MTU set
13
+ >> Option 3
14
+ Valid Lifetime: 500
15
+ Preferred Lifetime: 440
16
+ Flags: <ONLINK|AUTO>
17
+ Prefix Length: 64
18
+ Prefix: 2001:db8:dead:beef::
19
+ >> Option 25
20
+ DNS: 2001:db8:dead:beef::1
21
+ Lifetime: 60
22
+ >> Option 31
23
+ Domain: lab.intra
24
+ Lifetime: 60
25
+ >> Option 1
26
+ Address: 782bcbb36d53
27
+ NDISC: Started IPv6 Router Solicitation client
28
+ backoff timeout interval 1 3.600s <= 3.987s <= 4.400s
29
+ NDISC: Sent Router Solicitation, next solicitation in 3s
30
+ backoff timeout interval 2 7.576s <= 8.114s <= 8.374s
31
+ NDISC: Sent Router Solicitation, next solicitation in 8s
32
+ Assertion 'false' failed at src/libsystemd-network/test-ndisc-rs.c:172, function test_rs_hangcheck(). Aborting.
33
+ ---
34
+ src/libsystemd-network/test-ndisc-rs.c | 4 ++--
35
+ 1 file changed, 2 insertions(+), 2 deletions(-)
36
+
37
+ diff --git a/src/libsystemd-network/test-ndisc-rs.c b/src/libsystemd-network/test-ndisc-rs.c
38
+ index 5d1e66fcdc..1bc3499d07 100644
39
+ --- a/src/libsystemd-network/test-ndisc-rs.c
40
+ +++ b/src/libsystemd-network/test-ndisc-rs.c
41
+ @@ -291,7 +291,7 @@ static void test_rs(void) {
42
+ assert_se(sd_ndisc_set_callback(nd, test_callback, e) >= 0);
43
+
44
+ assert_se(sd_event_add_time(e, &test_hangcheck, clock_boottime_or_monotonic(),
45
+ - time_now + 2 *USEC_PER_SEC, 0,
46
+ + time_now + 30 * USEC_PER_SEC, 0,
47
+ test_rs_hangcheck, NULL) >= 0);
48
+
49
+ assert_se(sd_ndisc_stop(nd) >= 0);
50
+ @@ -393,7 +393,7 @@ static void test_timeout(void) {
51
+ assert_se(sd_ndisc_set_mac(nd, &mac_addr) >= 0);
52
+
53
+ assert_se(sd_event_add_time(e, &test_hangcheck, clock_boottime_or_monotonic(),
54
+ - time_now + 2U * USEC_PER_SEC, 0,
55
+ + time_now + 30 * USEC_PER_SEC, 0,
56
+ test_rs_hangcheck, NULL) >= 0);
57
+
58
+ assert_se(sd_ndisc_start(nd) >= 0);
file modified
+1 -0
systemd.spec CHANGED
@@ -73,6 +73,7 @@ Patch0001: use-bfq-scheduler.patch
73
73
Patch0002: 0001-Bump-tmp-size-back-to-50-of-RAM.patch
74
74
Patch0003: 0001-test-fs-util-do-not-assume-dev-is-always-real.patch
75
75
Patch0004: 0001-test-path-increase-timeout.patch
76
+ Patch0005: 0001-test-ndisc-rs-increase-timeouts.patch
76
77
77
78
%ifarch %{ix86} x86_64 aarch64
78
79
%global have_gnu_efi 1