0b51ec Version 252-rc1

Authored and Committed by Zbigniew Jędrzejewski-Szmek 2 years ago
    Version 252-rc1
    
    ... (for details see https://raw.githubusercontent.com/systemd/systemd/v252-rc1/NEWS)
    
    systemd-pcrphase and systemd-measure and initrd-* units are moved to systemd-udev.
    systemd-udev should be part of the initrd, and those tools don't make much sense
    in systems without hardware (i.e. containers). (systemd-measure could possibly be
    useful, but we can always move it back if there's a good reason.)
    
        
0002-test-mountpoint-util-support-running-on-a-mount-name.patch DELETED
@@ -1,64 +0,0 @@
1
- From b13268dc09eed68426c2e68a402c96b93f8b0fff Mon Sep 17 00:00:00 2001
2
- From: Yu Watanabe <watanabe.yu+github@gmail.com>
3
- Date: Mon, 12 Sep 2022 04:57:17 +0900
4
- Subject: [PATCH] test-mountpoint-util: support running on a mount namespace
5
- with another mount on /proc
6
-
7
- Fixes #11505.
8
- ---
9
- src/test/test-mountpoint-util.c | 30 +++++++++++++++++++++---------
10
- 1 file changed, 21 insertions(+), 9 deletions(-)
11
-
12
- diff --git a/src/test/test-mountpoint-util.c b/src/test/test-mountpoint-util.c
13
- index 92eed0be62..391e1c97ba 100644
14
- --- a/src/test/test-mountpoint-util.c
15
- +++ b/src/test/test-mountpoint-util.c
16
- @@ -83,24 +83,36 @@ TEST(mnt_id) {
17
-
18
- HASHMAP_FOREACH_KEY(p, k, h) {
19
- int mnt_id = PTR_TO_INT(k), mnt_id2;
20
- + const char *q;
21
-
22
- r = path_get_mnt_id(p, &mnt_id2);
23
- if (r < 0) {
24
- - log_debug_errno(r, "Failed to get the mnt id of %s: %m\n", p);
25
- + log_debug_errno(r, "Failed to get the mnt id of %s: %m", p);
26
- continue;
27
- }
28
-
29
- if (mnt_id == mnt_id2) {
30
- - log_debug("mnt ids of %s is %i\n", p, mnt_id);
31
- + log_debug("mnt ids of %s is %i.", p, mnt_id);
32
- continue;
33
- } else
34
- - log_debug("mnt ids of %s are %i, %i\n", p, mnt_id, mnt_id2);
35
- -
36
- - /* The ids don't match? If so, then there are two mounts on the same path, let's check if
37
- - * that's really the case */
38
- - char *t = hashmap_get(h, INT_TO_PTR(mnt_id2));
39
- - log_debug("the other path for mnt id %i is %s\n", mnt_id2, t);
40
- - assert_se(path_equal(p, t));
41
- + log_debug("mnt ids of %s are %i (from /proc/self/mountinfo), %i (from path_get_mnt_id()).", p, mnt_id, mnt_id2);
42
- +
43
- + /* The ids don't match? This can easily happen e.g. running with "unshare --mount-proc".
44
- + * See #11505. */
45
- + assert_se(q = hashmap_get(h, INT_TO_PTR(mnt_id2)));
46
- +
47
- + assert_se((r = path_is_mount_point(p, NULL, 0)) >= 0);
48
- + if (r == 0) {
49
- + /* If the path is not a mount point anymore, then it must be a sub directory of
50
- + * the path corresponds to mnt_id2. */
51
- + log_debug("The path %s for mnt id %i is not a mount point.", p, mnt_id2);
52
- + assert_se(!isempty(path_startswith(p, q)));
53
- + } else {
54
- + /* If the path is still a mount point, then it must be equivalent to the path
55
- + * corresponds to mnt_id2 */
56
- + log_debug("There are multiple mounts on the same path %s.", p);
57
- + assert_se(path_equal(p, q));
58
- + }
59
- }
60
- }
61
-
62
- --
63
- 2.37.2
64
-
file modified
+1 -1
sources CHANGED
@@ -1 +1 @@
1
- SHA512 (systemd-251.5.tar.gz) = 2c645a694d45a2670920115529c5f34001153dafe26e5c4e65f8d1a37922a351569d056fc002f1af72dfc173988f93e11893460f64b497e3d5fc339083dcb2fa
1
+ SHA512 (systemd-252-rc1.tar.gz) = e249eb39da41aca1bc371c9e2b61f135227b0653e4e175c4c6453b0ca4e1cd50894c005d4ef267b5122af4f339cd9b5a4b90a98c4f84f998f96a7ca1ed637d28
file modified
+2 -0
split-files.py CHANGED
@@ -129,6 +129,8 @@ for file in files(buildroot):
129
129
integritysetup|
130
130
integritytab|
131
131
remount-fs|
132
+ /initrd|
133
+ systemd-pcrphase|
132
134
/boot$|
133
135
/boot/efi|
134
136
/kernel/|
file modified
+2 -4
systemd.spec CHANGED
@@ -1,7 +1,7 @@
1
1
#global commit c4b843473a75fb38ed5bf54e9d3cfb1cb3719efa
2
2
%{?commit:%global shortcommit %(c=%{commit}; echo ${c:0:7})}
3
3
4
- %global stable 1
4
+ #global stable 1
5
5
6
6
# We ship a .pc file but don't want to have a dep on pkg-config. We
7
7
# strip the automatically generated dep here and instead co-own the
@@ -30,7 +30,7 @@
30
30
Name: systemd
31
31
Url: https://www.freedesktop.org/wiki/Software/systemd
32
32
%if %{without inplace}
33
- Version: 251.5
33
+ Version: 252~rc1
34
34
%else
35
35
# determine the build information from local checkout
36
36
Version: %(tools/meson-vcs-tag.sh . error | sed -r 's/-([0-9])/.^\1/; s/-g/_g/')
@@ -89,8 +89,6 @@ GIT_DIR=../../src/systemd/.git git diffab -M v233..master@{2017-06-15} -- hwdb/[
89
89
# than in the next section. Packit CI will drop any patches in this range before
90
90
# applying upstream pull requests.
91
91
92
- # PR https://github.com/systemd/systemd/pull/24639
93
- Patch0002: 0002-test-mountpoint-util-support-running-on-a-mount-name.patch
94
92
95
93
# Those are downstream-only patches, but we don't want them in packit builds:
96
94
# https://bugzilla.redhat.com/show_bug.cgi?id=1738828