fcbbff - Add support for MIPS platform

Authored and Committed by Florian Festi 9 years ago
    - Add support for MIPS platform
    - Resolves: #1242786
    
        
rpm-4.12.0-add-mips.patch ADDED
@@ -0,0 +1,148 @@
1
+ diff -urp rpm-4.12.0.1/installplatform r/installplatform
2
+ --- rpm-4.12.0.1/installplatform 2014-06-30 10:47:13.954503637 +0200
3
+ +++ r/installplatform 2015-07-14 09:34:15.917109096 +0200
4
+ @@ -114,6 +114,30 @@ for ARCH in noarch `grep ^arch_canon $RP
5
+ CANONARCH=aarch64
6
+ CANONCOLOR=3
7
+ ;;
8
+ + mips)
9
+ + ISANAME=mips
10
+ + ISABITS=32
11
+ + CANONARCH=mips
12
+ + CANONCOLOR=0
13
+ + ;;
14
+ + mipsel)
15
+ + ISANAME=mips
16
+ + ISABITS=32
17
+ + CANONARCH=mipsel
18
+ + CANONCOLOR=0
19
+ + ;;
20
+ + mips64)
21
+ + ISANAME=mips
22
+ + ISABITS=64
23
+ + CANONARCH=mips64
24
+ + CANONCOLOR=3
25
+ + ;;
26
+ + mips64el)
27
+ + ISANAME=mips
28
+ + ISABITS=64
29
+ + CANONARCH=mips64el
30
+ + CANONCOLOR=3
31
+ + ;;
32
+ m68k)
33
+ ISANAME=m68k
34
+ ISABITS=32
35
+ diff -urp rpm-4.12.0.1/lib/rpmrc.c r/lib/rpmrc.c
36
+ --- rpm-4.12.0.1/lib/rpmrc.c 2014-07-03 17:11:48.572096075 +0200
37
+ +++ r/lib/rpmrc.c 2015-07-14 09:34:15.918109105 +0200
38
+ @@ -1053,10 +1053,22 @@ static void defaultMachine(rpmrcCtx ctx,
39
+
40
+ # if defined(__MIPSEL__) || defined(__MIPSEL) || defined(_MIPSEL)
41
+ /* little endian */
42
+ - strcpy(un.machine, "mipsel");
43
+ +# if defined(__LP64__) || defined(_LP64)
44
+ + /* 64-bit */
45
+ + strcpy(un.machine, "mips64el");
46
+ +# else
47
+ + /* 32-bit */
48
+ + strcpy(un.machine, "mipsel");
49
+ +# endif
50
+ # elif defined(__MIPSEB__) || defined(__MIPSEB) || defined(_MIPSEB)
51
+ /* big endian */
52
+ - strcpy(un.machine, "mips");
53
+ +# if defined(__LP64__) || defined(_LP64)
54
+ + /* 64-bit */
55
+ + strcpy(un.machine, "mips64");
56
+ +# else
57
+ + /* 32-bit */
58
+ + strcpy(un.machine, "mips");
59
+ +# endif
60
+ # endif
61
+
62
+ # if defined(__hpux) && defined(_SC_CPU_VERSION)
63
+ diff -urp rpm-4.12.0.1/macros.in r/macros.in
64
+ --- rpm-4.12.0.1/macros.in 2015-07-14 09:33:34.422697268 +0200
65
+ +++ r/macros.in 2015-07-14 09:34:15.918109105 +0200
66
+ @@ -1011,6 +1011,10 @@ done \
67
+ %arm armv3l armv4b armv4l armv4tl armv5tel armv5tejl armv6l armv6hl armv7l armv7hl armv7hnl
68
+
69
+ #------------------------------------------------------------------------------
70
+ +# arch macro for all supported MIPS processors
71
+ +%mips mips mipsel mips64 mips64el
72
+ +
73
+ +#------------------------------------------------------------------------------
74
+ # arch macro for all supported Sparc processors
75
+ %sparc sparc sparcv8 sparcv9 sparcv9v sparc64 sparc64v
76
+
77
+ diff -urp rpm-4.12.0.1/rpmrc.in r/rpmrc.in
78
+ --- rpm-4.12.0.1/rpmrc.in 2015-07-14 09:33:34.413697179 +0200
79
+ +++ r/rpmrc.in 2015-07-14 09:34:47.557423122 +0200
80
+ @@ -59,6 +59,8 @@ optflags: hppa2.0 -O2 -g -mpa-risc-1-0
81
+
82
+ optflags: mips -O2 -g
83
+ optflags: mipsel -O2 -g
84
+ +optflags: mips64 -O2 -g
85
+ +optflags: mips64el -O2 -g
86
+
87
+ optflags: armv3l -O2 -g -march=armv3
88
+ optflags: armv4b -O2 -g -march=armv4
89
+ @@ -114,6 +116,11 @@ archcolor: armv5tejl 1
90
+ archcolor: armv6l 1
91
+ archcolor: armv7l 1
92
+
93
+ +archcolor: mips 1
94
+ +archcolor: mipsel 1
95
+ +archcolor: mips64 2
96
+ +archcolor: mips64el 2
97
+ +
98
+ archcolor: m68k 1
99
+
100
+ archcolor: m68kmint 1
101
+ @@ -167,6 +174,7 @@ arch_canon: sparcv9: sparcv9 3
102
+ arch_canon: sparcv9v: sparcv9v 3
103
+ # This is really a place holder for MIPS.
104
+ arch_canon: mips: mips 4
105
+ +arch_canon: mipsel: mipsel 4
106
+
107
+ arch_canon: ppc: ppc 5
108
+ arch_canon: ppc8260: ppc8260 5
109
+ @@ -180,7 +188,8 @@ arch_canon: IP: sgi 7
110
+ arch_canon: rs6000: rs6000 8
111
+ arch_canon: ia64: ia64 9
112
+
113
+ -arch_canon: mipsel: mipsel 11
114
+ +arch_canon: mips64: mips64 11
115
+ +arch_canon: mips64el: mips64el 11
116
+
117
+ arch_canon: armv3l: armv3l 12
118
+ arch_canon: armv4b: armv4b 12
119
+ @@ -309,6 +318,11 @@ buildarchtranslate: armv7l: armv7l
120
+ buildarchtranslate: armv7hl: armv7hl
121
+ buildarchtranslate: armv7hnl: armv7hnl
122
+
123
+ +buildarchtranslate: mips: mips
124
+ +buildarchtranslate: mipsel: mipsel
125
+ +buildarchtranslate: mips64: mips64
126
+ +buildarchtranslate: mips64el: mips64el
127
+ +
128
+ buildarchtranslate: m68k: m68k
129
+
130
+ buildarchtranslate: atarist: m68kmint
131
+ @@ -387,6 +401,8 @@ arch_compat: sparc: noarch
132
+
133
+ arch_compat: mips: noarch
134
+ arch_compat: mipsel: noarch
135
+ +arch_compat: mips64: mips
136
+ +arch_compat: mips64el: mipsel
137
+
138
+ arch_compat: hppa2.0: hppa1.2
139
+ arch_compat: hppa1.2: hppa1.1
140
+ @@ -508,6 +524,8 @@ buildarch_compat: ppc64p7: ppc64
141
+
142
+ buildarch_compat: mips: noarch
143
+ buildarch_compat: mipsel: noarch
144
+ +buildarch_compat: mips64: noarch
145
+ +buildarch_compat: mips64el: noarch
146
+
147
+ buildarch_compat: armv4b: noarch
148
+ buildarch_compat: armv7l: armv6l
file modified
+6 -1
rpm.spec CHANGED
@@ -27,7 +27,7 @@
27
27
Summary: The RPM package management system
28
28
Name: rpm
29
29
Version: %{rpmver}
30
- Release: %{?snapver:0.%{snapver}.}17%{?dist}
30
+ Release: %{?snapver:0.%{snapver}.}18%{?dist}
31
31
Group: System Environment/Base
32
32
Url: http://www.rpm.org/
33
33
Source0: http://rpm.org/releases/rpm-4.12.x/%{name}-%{srcver}.tar.bz2
@@ -84,6 +84,8 @@ Patch307: rpm-4.11.1-sepdebugcrcfix.patch
84
84
Patch308: rpm-4.12.0.x-CVE-2013-6435.patch
85
85
# Add check against malicious CPIO file name size
86
86
Patch309: rpm-4.12.0.x-CVE-2014-8118.patch
87
+ # Add support for MIPS platform
88
+ Patch310: rpm-4.12.0-add-mips.patch
87
89
88
90
# Partially GPL/LGPL dual-licensed and some bits with BSD
89
91
# SourceLicense: (GPLv2+ and LGPLv2+ with exceptions) and BSD
@@ -553,6 +555,9 @@ exit 0
553
555
%doc doc/librpm/html/*
554
556
555
557
%changelog
558
+ * Tue Jul 14 2015 Michal Toman <mtoman@fedoraproject.org> - 4.12.0.1-18
559
+ - Add support for MIPS platform
560
+
556
561
* Mon Jun 29 2015 Florian Festi <ffesti@rpm.org> - 4.12.0.1-17
557
562
- Fix Python import directive for more strict Python3 search rules (#1236493)
558
563