e8efcc - switch back to smaller BDB cache default (#752897)

Authored and Committed by Panu Matilainen 12 years ago
    - switch back to smaller BDB cache default (#752897)
    
        
rpm-4.9.x-mpsize.patch ADDED
@@ -0,0 +1,28 @@
1
+ commit d8cd36058b528f56bd579204426143be1e1eac6d
2
+ Author: Panu Matilainen <pmatilai@redhat.com>
3
+ Date: Wed Feb 8 10:56:09 2012 +0200
4
+
5
+ Switch back to former, much smaller BDB memory pool size (RhBug:752897)
6
+
7
+ - A larger cache is beneficial in various scenarios, but triggers
8
+ horrible worst-case performance under memory pressure (or so my
9
+ current theory goes, there might be other factors too). The
10
+ worst-case degration is orders of magnitude bigger than the best-case
11
+ improvements from the larger cache and for many use-cases doesn't
12
+ make a whole lot difference. We could/should tune the cache with
13
+ priorizing indexes and all, and perhaps dynamically select the
14
+ cache size but for now, the 1Mb cache size is known to "just work".
15
+
16
+ diff --git a/macros.in b/macros.in
17
+ index f835fec..6034721 100644
18
+ --- a/macros.in
19
+ +++ b/macros.in
20
+ @@ -535,7 +535,7 @@ print (t)\
21
+ #
22
+
23
+ # Misc BDB tuning options
24
+ -%__dbi_other mp_mmapsize=128Mb mp_size=64Mb
25
+ +%__dbi_other mp_mmapsize=128Mb mp_size=1Mb
26
+
27
+ %_dbi_config %{?__dbi_other}
28
+
file modified
+6 -1
rpm.spec CHANGED
@@ -21,7 +21,7 @@
21
21
Summary: The RPM package management system
22
22
Name: rpm
23
23
Version: %{rpmver}
24
- Release: %{?snapver:0.%{snapver}.}11%{?dist}
24
+ Release: %{?snapver:0.%{snapver}.}12%{?dist}
25
25
Group: System Environment/Base
26
26
Url: http://www.rpm.org/
27
27
Source0: http://rpm.org/releases/rpm-4.9.x/%{name}-%{srcver}.tar.bz2
@@ -46,6 +46,7 @@ Patch6: rpm-4.9.0-armhfp-logic.patch
46
46
Patch100: rpm-4.9.x-fontattr.patch
47
47
Patch101: rpm-4.9.x-elfattr.patch
48
48
Patch102: rpm-4.9.1.2-perl-python-attr.patch
49
+ Patch103: rpm-4.9.x-mpsize.patch
49
50
50
51
# These are not yet upstream
51
52
Patch301: rpm-4.6.0-niagara.patch
@@ -226,6 +227,7 @@ packages on a system.
226
227
%patch100 -p1 -b .fontattr
227
228
%patch101 -p1 -b .elfattr
228
229
%patch102 -p1 -b .perl-python-attr
230
+ %patch103 -p1 -b .mpsize
229
231
230
232
%patch301 -p1 -b .niagara
231
233
%patch302 -p1 -b .geode
@@ -455,6 +457,9 @@ exit 0
455
457
%doc COPYING doc/librpm/html/*
456
458
457
459
%changelog
460
+ * Thu Feb 09 2012 Panu Matilainen <pmatilai@redhat.com> - 4.9.1.2-12
461
+ - switch back to smaller BDB cache default (#752897)
462
+
458
463
* Sun Jan 15 2012 Dennis Gilmore <dennis@ausil.us> - 4.9.1.2-11
459
464
- always apply arm hfp macros, conditionally apply the logic to detect hfp
460
465