dd1fdd - fix pkg-config provide generation when pc's depend on each other

Authored and Committed by Panu Matilainen 16 years ago
    - fix pkg-config provide generation when pc's depend on each other
        (#473814)
    
        
rpm-4.6.0-rc2-pkgconfig-provides.patch ADDED
@@ -0,0 +1,13 @@
1
+ diff --git a/scripts/pkgconfigdeps.sh b/scripts/pkgconfigdeps.sh
2
+ index 882d195..6baa0f1 100755
3
+ --- a/scripts/pkgconfigdeps.sh
4
+ +++ b/scripts/pkgconfigdeps.sh
5
+ @@ -17,6 +17,8 @@ case $1 in
6
+ case "${filename}" in
7
+ *.pc)
8
+ # Query the dependencies of the package.
9
+ + DIR="`dirname ${filename}`"
10
+ + export PKG_CONFIG_PATH="$DIR:$DIR/../../share/pkgconfig"
11
+ $pkgconfig --print-provides "$filename" 2> /dev/null | while read n r v ; do
12
+ # We have a dependency. Make a note that we need the pkgconfig
13
+ # tool for this package.
file modified
+6 -1
rpm.spec CHANGED
@@ -18,7 +18,7 @@
18
18
Summary: The RPM package management system
19
19
Name: rpm
20
20
Version: %{rpmver}
21
- Release: 0.%{snapver}.5
21
+ Release: 0.%{snapver}.6
22
22
Group: System Environment/Base
23
23
Url: http://www.rpm.org/
24
24
Source0: http://rpm.org/releases/testing/%{name}-%{srcver}.tar.bz2
@@ -30,6 +30,7 @@ Patch0: rpm-4.5.90-devel-autodep.patch
30
30
Patch1: rpm-4.5.90-pkgconfig-path.patch
31
31
Patch2: rpm-4.5.90-gstreamer-provides.patch
32
32
Patch3: rpm-4.5.90-rpmfileutil.patch
33
+ Patch4: rpm-4.6.0-rc2-pkgconfig-provides.patch
33
34
34
35
# Patches already in upstream
35
36
@@ -164,6 +165,7 @@ that will manipulate RPM packages and databases.
164
165
%patch1 -p1 -b .pkgconfig-path
165
166
%patch2 -p1 -b .gstreamer-prov
166
167
%patch3 -p1 -b .rpmfileutil
168
+ %patch4 -p1 -b .pkgconfig-provides
167
169
168
170
# needs a bit of upstream love first...
169
171
#%patch300 -p1 -b .posttrans
@@ -354,6 +356,9 @@ exit 0
354
356
%doc doc/librpm/html/*
355
357
356
358
%changelog
359
+ * Tue Dec 02 2008 Panu Matilainen <pmatilai@redhat.com>
360
+ - fix pkg-config provide generation when pc's depend on each other (#473814)
361
+
357
362
* Mon Dec 01 2008 Jindrich Novy <jnovy@redhat.com>
358
363
- include rpmfileutil.h from rpmmacro.h, unbreaks
359
364
net-snmp (#473420)