ca3040 - add patch to fix segfault with non-merged hdlists

Authored and Committed by Jeremy Katz 19 years ago
    - add patch to fix segfault with non-merged hdlists
    
        
rpm-4.4.1-nonmerged.patch ADDED
@@ -0,0 +1,11 @@
1
+ --- rpm-4.4.1/lib/rpmal.c~ 2005-04-26 16:29:57.000000000 -0400
2
+ +++ rpm-4.4.1/lib/rpmal.c 2005-04-27 00:01:59.000000000 -0400
3
+ @@ -744,7 +744,7 @@
4
+
5
+ /*@-branchstate@*/ /* FIX: ret is a problem */
6
+ for (found = 0, ret = NULL;
7
+ - die <= al->dirs + al->numDirs && dieCompare(die, dieNeedle) == 0;
8
+ + die < al->dirs + al->numDirs && dieCompare(die, dieNeedle) == 0;
9
+ die++)
10
+ {
11
+
file modified
+6 -1
rpm.spec CHANGED
@@ -20,7 +20,7 @@ Name: rpm
20
20
%define version 4.4.1
21
21
Version: %{version}
22
22
%{expand: %%define rpm_version %{version}}
23
- Release: 9
23
+ Release: 10
24
24
Group: System Environment/Base
25
25
Source: ftp://jbj.org/pub/rpm-devel/rpm-%{rpm_version}.tar.gz
26
26
Patch0: rpm-4.4.1-posttrans.patch
@@ -29,6 +29,7 @@ Patch2: rpm-4.4.1-hkp-disable.patch
29
29
Patch3: rpm-4.4.1-read-macro.patch
30
30
Patch4: rpm-4.4.1-fileconflicts.patch
31
31
Patch5: rpm-4.4.1-prereq.patch
32
+ Patch6: rpm-4.4.1-nonmerged.patch
32
33
License: GPL
33
34
Conflicts: patch < 2.5
34
35
%ifos linux
@@ -143,6 +144,7 @@ shell-like rules.
143
144
%patch3 -p1
144
145
%patch4 -p1 -b .fileconflicts
145
146
%patch5 -p1 -b .prereq
147
+ %patch6 -p1
146
148
147
149
%build
148
150
@@ -513,6 +515,9 @@ exit 0
513
515
%{__includedir}/popt.h
514
516
515
517
%changelog
518
+ * Wed Apr 27 2005 Jeremy Katz <katzj@redhat.com> - 4.4.1-10
519
+ - add patch to fix segfault with non-merged hdlists
520
+
516
521
* Thu Mar 31 2005 Thomas Woerner <twoerner@redhat.com> 4.4.1-9
517
522
- enabled prereqs again
518
523