ba1a13 - with the fd leak gone, let libmagic look into compressed files again

Authored and Committed by Panu Matilainen 15 years ago
    - with the fd leak gone, let libmagic look into compressed files again
        (#491596)
    
        
rpm-4.7.0-extra-provides.patch CHANGED
@@ -54,7 +54,7 @@ diff -up rpm-4.7.0-beta1/build/rpmfc.c.extra-prov rpm-4.7.0-beta1/build/rpmfc.c
54
54
int fcolor;
55
55
int xx;
56
56
- int msflags = MAGIC_CHECK; /* XXX MAGIC_COMPRESS flag? */
57
- + int msflags = MAGIC_CHECK; /* add MAGIC_COMPRESS eventually */
57
+ + int msflags = MAGIC_CHECK | MAGIC_COMPRESS;
58
58
magic_t ms = NULL;
59
59
60
60
if (fc == NULL || argv == NULL)
file modified
+4 -1
rpm.spec CHANGED
@@ -25,7 +25,7 @@
25
25
Summary: The RPM package management system
26
26
Name: rpm
27
27
Version: %{rpmver}
28
- Release: 0.%{snapver}.5%{?dist}
28
+ Release: 0.%{snapver}.6%{?dist}
29
29
Group: System Environment/Base
30
30
Url: http://www.rpm.org/
31
31
Source0: http://rpm.org/releases/testing/%{name}-%{srcver}.tar.bz2
@@ -400,6 +400,9 @@ exit 0
400
400
%doc doc/librpm/html/*
401
401
402
402
%changelog
403
+ * Mon Mar 23 2009 Panu Matilainen <pmatilai@redhat.com> - 4.7.0-0.beta1.6
404
+ - with the fd leak gone, let libmagic look into compressed files again (#491596)
405
+
403
406
* Mon Mar 23 2009 Panu Matilainen <pmatilai@redhat.com> - 4.7.0-0.beta1.5
404
407
- fix font provide generation on filenames with whitespace (#491510)
405
408