a19af6 Detect and provide a requirement for DT_GNU_HASH

Authored and Committed by Paul Nasrat 18 years ago
    Detect and provide a requirement for DT_GNU_HASH
    
        
rpm-4.4.2-gnuhash.patch ADDED
@@ -0,0 +1,53 @@
1
+ --- rpm-4.4.2/build/rpmfc.c.gnuhash 2006-07-11 07:05:43.000000000 -0400
2
+ +++ rpm-4.4.2/build/rpmfc.c 2006-07-11 07:09:08.000000000 -0400
3
+ @@ -879,6 +879,8 @@
4
+ int isDSO;
5
+ int gotSONAME = 0;
6
+ int gotDEBUG = 0;
7
+ + int gotHASH = 0;
8
+ + int gotGNUHASH = 0;
9
+ static int filter_GLIBC_PRIVATE = 0;
10
+ static int oneshot = 0;
11
+
12
+ @@ -1051,6 +1053,12 @@
13
+ default:
14
+ /*@innercontinue@*/ continue;
15
+ /*@notreached@*/ /*@switchbreak@*/ break;
16
+ + case DT_HASH:
17
+ + gotHASH= 1;
18
+ + /*@innercontinue@*/ continue;
19
+ + case DT_GNU_HASH:
20
+ + gotGNUHASH= 1;
21
+ + /*@innercontinue@*/ continue;
22
+ case DT_DEBUG:
23
+ gotDEBUG = 1;
24
+ /*@innercontinue@*/ continue;
25
+ @@ -1107,6 +1115,16 @@
26
+ }
27
+ /*@=branchstate =uniondef @*/
28
+
29
+ + /* For DSOs which use the .gnu_hash section and don't have a .hash
30
+ + * section, we need to ensure that we have a new enough glibc. */
31
+ + if (gotGNUHASH && !gotHASH) {
32
+ + ds = rpmdsSingle(RPMTAG_REQUIRENAME, "rtld(GNU_HASH)", "",
33
+ + RPMSENSE_FIND_REQUIRES);
34
+ + rpmdsMerge(&fc->requires, ds);
35
+ + rpmfcSaveArg(&fc->ddict, rpmfcFileDep(t, fc->ix, ds));
36
+ + ds = rpmdsFree(ds);
37
+ + }
38
+ +
39
+ /* For DSO's, provide the basename of the file if DT_SONAME not found. */
40
+ if (!fc->skipProv && isDSO && !gotDEBUG && !gotSONAME) {
41
+ depsp = &fc->provides;
42
+ --- rpm-4.4.2/rpmdb/legacy.c.gnuhash 2006-07-11 07:07:18.000000000 -0400
43
+ +++ rpm-4.4.2/rpmdb/legacy.c 2006-07-11 07:07:44.000000000 -0400
44
+ @@ -14,6 +14,9 @@
45
+ #if !defined(DT_GNU_LIBLIST)
46
+ #define DT_GNU_LIBLIST 0x6ffffef9
47
+ #endif
48
+ +#if !defined(DT_GNU_HASH)
49
+ +#define DT_GNU_HASH 0x6ffffef5
50
+ +#endif
51
+
52
+ #endif
53
+
file modified
+6 -1
rpm.spec CHANGED
@@ -20,7 +20,7 @@ Name: rpm
20
20
%define version 4.4.2
21
21
Version: %{version}
22
22
%{expand: %%define rpm_version %{version}}
23
- Release: 27
23
+ Release: 28
24
24
Group: System Environment/Base
25
25
Source: ftp://wraptastic.org/pub/rpm-4.4.x/rpm-%{rpm_version}.tar.gz
26
26
Source1: mono-find-provides
@@ -55,6 +55,7 @@ Patch26: rpm-4.4.2-rpmfc-skip.patch
55
55
Patch27: rpm-4.4.2-noselinux-verify.patch
56
56
Patch28: rpm-4.4.2-python-aslist.patch
57
57
Patch29: rpm-4.4.2-rpmio-ipv6.patch
58
+ Patch30: rpm-4.4.2-gnuhash.patch
58
59
License: GPL
59
60
Conflicts: patch < 2.5
60
61
%ifos linux
@@ -195,6 +196,7 @@ shell-like rules.
195
196
#patch6 -p1 -b .matchpathcon
196
197
%patch28 -p1 -b .aslist
197
198
%patch29 -p1 -b .ipv6
199
+ %patch30 -p1 -b .gnuhash
198
200
199
201
# rebuild configure for ipv6
200
202
autoconf
@@ -591,6 +593,9 @@ exit 0
591
593
%{__includedir}/popt.h
592
594
593
595
%changelog
596
+ * Tue Jul 11 2006 Paul Nasrat <pnasrat@redhat.com> - 4.4.2-28
597
+ - Detect and provide a requirement for DT_GNU_HASH
598
+
594
599
* Wed Jul 05 2006 Paul Nasrat <pnasrat@redhat.com> - 4.4.2-27
595
600
- IPv4/6 and EPSV support by Arkadiusz Miskiewicz <misiek@pld.org.pl>
596
601