9eb5b2
auto-import changelog data from rpm-4.0.2-7x.src.rpm
@@ -1 +1 @@
|
|
1
|
-
rpm-4.0.tar.gz
|
1
|
+
rpm-4.0.2.tar.gz
|
@@ -1,3 +1,8 @@
|
|
1
|
+
%define with_python_subpackage 1
|
2
|
+
%define with_bzip2 1
|
3
|
+
%define with_apidocs 1
|
4
|
+
%define strip_binaries 1
|
5
|
+
|
1
6
|
# XXX legacy requires './' payload prefix to be omitted from rpm packages.
|
2
7
|
%define _noPayloadPrefix 1
|
3
8
|
|
@@ -6,17 +11,20 @@
|
|
6
11
|
|
7
12
|
Summary: The Red Hat package management system.
|
8
13
|
Name: rpm
|
9
|
-
%define version 4.0
|
14
|
+
%define version 4.0.2
|
10
15
|
Version: %{version}
|
11
|
-
Release:
|
16
|
+
Release: 7x
|
12
17
|
Group: System Environment/Base
|
13
18
|
Source: ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.0.x/rpm-%{version}.tar.gz
|
14
19
|
Copyright: GPL
|
15
20
|
Conflicts: patch < 2.5
|
16
21
|
%ifos linux
|
17
|
-
|
18
|
-
|
19
|
-
|
22
|
+
Prereq: gawk fileutils textutils mktemp
|
23
|
+
Requires: popt
|
24
|
+
%endif
|
25
|
+
|
26
|
+
BuildRequires: db3-devel
|
27
|
+
|
20
28
|
# XXX glibc-2.1.92 has incompatible locale changes that affect statically
|
21
29
|
# XXX linked binaries like /bin/rpm.
|
22
30
|
%ifnarch ia64
|
@@ -24,10 +32,15 @@ Requires: glibc >= 2.1.92
|
|
24
32
|
# XXX needed to avoid libdb.so.2 satisfied by compat/libc5 provides.
|
25
33
|
Requires: db1 = 1.85
|
26
34
|
%endif
|
27
|
-
|
35
|
+
|
36
|
+
# XXX Red Hat 5.2 has not bzip2 or python
|
37
|
+
%if %{with_bzip2}
|
28
38
|
BuildRequires: bzip2 >= 0.9.0c-2
|
39
|
+
%endif
|
40
|
+
%if %{with_python_subpackage}
|
29
41
|
BuildRequires: python-devel >= 1.5.2
|
30
42
|
%endif
|
43
|
+
|
31
44
|
BuildRoot: %{_tmppath}/%{name}-root
|
32
45
|
|
33
46
|
%description
|
@@ -62,11 +75,12 @@ Requires: rpm = %{version}
|
|
62
75
|
This package contains scripts and executable programs that are used to
|
63
76
|
build packages using RPM.
|
64
77
|
|
65
|
-
%
|
78
|
+
%if %{with_python_subpackage}
|
66
79
|
%package python
|
67
80
|
Summary: Python bindings for apps which will manipulate RPM packages.
|
68
81
|
Group: Development/Libraries
|
69
82
|
BuildRequires: popt >= 1.5
|
83
|
+
Requires: rpm = %{version}
|
70
84
|
Requires: popt >= 1.5
|
71
85
|
Requires: python >= 1.5.2
|
72
86
|
|
@@ -82,7 +96,7 @@ programs that will manipulate RPM packages and databases.
|
|
82
96
|
%package -n popt
|
83
97
|
Summary: A C library for parsing command line parameters.
|
84
98
|
Group: Development/Libraries
|
85
|
-
Version: 1.6
|
99
|
+
Version: 1.6.2
|
86
100
|
|
87
101
|
%description -n popt
|
88
102
|
Popt is a C library for parsing command line parameters. Popt was
|
@@ -99,7 +113,6 @@ capabilities.
|
|
99
113
|
|
100
114
|
%prep
|
101
115
|
%setup -q
|
102
|
-
%patch -p1
|
103
116
|
|
104
117
|
%build
|
105
118
|
%ifos linux
|
@@ -110,42 +123,60 @@ CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=%{__prefix}
|
|
110
123
|
|
111
124
|
make
|
112
125
|
|
113
|
-
%ifos linux
|
114
|
-
make -C python
|
115
|
-
%endif
|
116
|
-
|
117
126
|
%install
|
118
127
|
rm -rf $RPM_BUILD_ROOT
|
119
128
|
|
120
129
|
make DESTDIR="$RPM_BUILD_ROOT" install
|
121
|
-
|
130
|
+
|
122
|
-
make DESTDIR="$RPM_BUILD_ROOT" install -C python
|
123
|
-
%endif
|
124
131
|
mkdir -p $RPM_BUILD_ROOT/etc/rpm
|
132
|
+
cat << E_O_F > $RPM_BUILD_ROOT/etc/rpm/macros.db1
|
133
|
+
%%_dbapi 1
|
134
|
+
E_O_F
|
125
135
|
|
136
|
+
%if %{with_apidocs}
|
137
|
+
gzip -9n apidocs/man/man*/* || :
|
138
|
+
%endif
|
139
|
+
|
140
|
+
%if %{strip_binaries}
|
126
141
|
{ cd $RPM_BUILD_ROOT
|
127
142
|
strip ./bin/rpm
|
128
143
|
strip .%{__prefix}/bin/rpm2cpio
|
129
|
-
strip .%{__prefix}/lib/rpm/rpmputtext .%{__prefix}/lib/rpm/rpmgettext
|
130
144
|
}
|
145
|
+
%endif
|
131
146
|
|
132
147
|
%clean
|
133
148
|
rm -rf $RPM_BUILD_ROOT
|
134
149
|
|
150
|
+
%pre
|
151
|
+
if [ -f /var/lib/rpm/Packages -a -f /var/lib/rpm/packages.rpm ]; then
|
152
|
+
# echo "
|
153
|
+
#You have both
|
154
|
+
# /var/lib/rpm/packages.rpm db1 format installed package headers
|
155
|
+
# /var/lib/rpm/Packages db3 format installed package headers
|
156
|
+
#Please remove (or at least rename) one of those files, and re-install.
|
157
|
+
#"
|
158
|
+
exit 1
|
159
|
+
fi
|
160
|
+
exit 0
|
161
|
+
|
135
162
|
%post
|
136
|
-
/sbin/ldconfig
|
137
163
|
%ifos linux
|
138
|
-
|
164
|
+
/sbin/ldconfig
|
139
|
-
then
|
140
|
-
sh %{__prefix}/lib/rpm/convertrpmrc.sh > /dev/null 2>&1
|
141
|
-
fi
|
142
|
-
%else
|
143
|
-
/bin/rpm --initdb
|
144
165
|
%endif
|
166
|
+
if [ -f /var/lib/rpm/packages.rpm ]; then
|
167
|
+
: # do nothing
|
168
|
+
elif [ -f /var/lib/rpm/Packages ]; then
|
169
|
+
# undo db1 configuration
|
170
|
+
rm -f /etc/rpm/macros.db1
|
171
|
+
else
|
172
|
+
# initialize db3 database
|
173
|
+
rm -f /etc/rpm/macros.db1
|
174
|
+
/bin/rpm --initdb
|
175
|
+
fi
|
145
176
|
|
177
|
+
%ifos linux
|
146
178
|
%postun -p /sbin/ldconfig
|
147
179
|
|
148
|
-
%ifos linux
|
149
180
|
%post devel -p /sbin/ldconfig
|
150
181
|
%postun devel -p /sbin/ldconfig
|
151
182
|
|
@@ -153,7 +184,7 @@ fi
|
|
153
184
|
%postun -n popt -p /sbin/ldconfig
|
154
185
|
%endif
|
155
186
|
|
156
|
-
%
|
187
|
+
%if %{with_python_subpackage}
|
157
188
|
%post python -p /sbin/ldconfig
|
158
189
|
%postun python -p /sbin/ldconfig
|
159
190
|
%endif
|
@@ -162,7 +193,8 @@ fi
|
|
162
193
|
%defattr(-,root,root)
|
163
194
|
%doc RPM-PGP-KEY RPM-GPG-KEY CHANGES GROUPS doc/manual/[a-z]*
|
164
195
|
/bin/rpm
|
165
|
-
%dir
|
196
|
+
%dir /etc/rpm
|
197
|
+
%config(missingok) /etc/rpm/macros.db1
|
166
198
|
%{__prefix}/bin/rpm2cpio
|
167
199
|
%{__prefix}/bin/gendiff
|
168
200
|
%{__prefix}/bin/rpmdb
|
@@ -199,7 +231,36 @@ fi
|
|
199
231
|
%ifarch powerpc ppc
|
200
232
|
%{__prefix}/lib/rpm/ppc*
|
201
233
|
%endif
|
234
|
+
%ifarch armv3l armv4l
|
235
|
+
%{__prefix}/lib/rpm/armv[34][lb]*
|
236
|
+
%endif
|
237
|
+
|
238
|
+
%lang(cs) %{__prefix}/*/locale/cs/LC_MESSAGES/rpm.mo
|
239
|
+
%lang(da) %{__prefix}/*/locale/da/LC_MESSAGES/rpm.mo
|
240
|
+
%lang(de) %{__prefix}/*/locale/de/LC_MESSAGES/rpm.mo
|
241
|
+
%lang(fi) %{__prefix}/*/locale/fi/LC_MESSAGES/rpm.mo
|
242
|
+
%lang(fr) %{__prefix}/*/locale/fr/LC_MESSAGES/rpm.mo
|
243
|
+
%lang(is) %{__prefix}/*/locale/is/LC_MESSAGES/rpm.mo
|
244
|
+
%lang(ja) %{__prefix}/*/locale/ja/LC_MESSAGES/rpm.mo
|
245
|
+
%lang(no) %{__prefix}/*/locale/no/LC_MESSAGES/rpm.mo
|
246
|
+
%lang(pl) %{__prefix}/*/locale/pl/LC_MESSAGES/rpm.mo
|
247
|
+
%lang(pt) %{__prefix}/*/locale/pt/LC_MESSAGES/rpm.mo
|
248
|
+
%lang(pt_BR) %{__prefix}/*/locale/pt_BR/LC_MESSAGES/rpm.mo
|
249
|
+
%lang(ro) %{__prefix}/*/locale/ro/LC_MESSAGES/rpm.mo
|
250
|
+
%lang(ru) %{__prefix}/*/locale/ru/LC_MESSAGES/rpm.mo
|
251
|
+
%lang(sk) %{__prefix}/*/locale/sk/LC_MESSAGES/rpm.mo
|
252
|
+
%lang(sl) %{__prefix}/*/locale/sl/LC_MESSAGES/rpm.mo
|
253
|
+
%lang(sr) %{__prefix}/*/locale/sr/LC_MESSAGES/rpm.mo
|
254
|
+
%lang(sv) %{__prefix}/*/locale/sv/LC_MESSAGES/rpm.mo
|
255
|
+
%lang(tr) %{__prefix}/*/locale/tr/LC_MESSAGES/rpm.mo
|
256
|
+
|
257
|
+
%{__prefix}%{__share}/man/man[18]/*.[18]*
|
258
|
+
%lang(pl) %{__prefix}%{__share}/man/pl/man[18]/*.[18]*
|
259
|
+
%lang(ru) %{__prefix}%{__share}/man/ru/man[18]/*.[18]*
|
260
|
+
%lang(sk) %{__prefix}%{__share}/man/sk/man[18]/*.[18]*
|
202
261
|
|
262
|
+
%files build
|
263
|
+
%defattr(-,root,root)
|
203
264
|
%dir %{__prefix}/src/redhat
|
204
265
|
%dir %{__prefix}/src/redhat/BUILD
|
205
266
|
%dir %{__prefix}/src/redhat/SPECS
|
@@ -207,14 +268,6 @@ fi
|
|
207
268
|
%dir %{__prefix}/src/redhat/SRPMS
|
208
269
|
%dir %{__prefix}/src/redhat/RPMS
|
209
270
|
%{__prefix}/src/redhat/RPMS/*
|
210
|
-
%{__prefix}/*/locale/*/LC_MESSAGES/rpm.mo
|
211
|
-
%{__prefix}%{__share}/man/man[18]/*.[18]*
|
212
|
-
%lang(pl) %{__prefix}%{__share}/man/pl/man[18]/*.[18]*
|
213
|
-
%lang(ru) %{__prefix}%{__share}/man/ru/man[18]/*.[18]*
|
214
|
-
%lang(sk) %{__prefix}%{__share}/man/sk/man[18]/*.[18]*
|
215
|
-
|
216
|
-
%files build
|
217
|
-
%defattr(-,root,root)
|
218
271
|
%{__prefix}/bin/rpmbuild
|
219
272
|
%{__prefix}/lib/rpm/brp-*
|
220
273
|
%{__prefix}/lib/rpm/check-prereqs
|
@@ -229,6 +282,7 @@ fi
|
|
229
282
|
%{__prefix}/lib/rpm/get_magic.pl
|
230
283
|
%{__prefix}/lib/rpm/getpo.sh
|
231
284
|
%{__prefix}/lib/rpm/http.req
|
285
|
+
%{__prefix}/lib/rpm/javadeps
|
232
286
|
%{__prefix}/lib/rpm/magic.prov
|
233
287
|
%{__prefix}/lib/rpm/magic.req
|
234
288
|
%{__prefix}/lib/rpm/perl.prov
|
@@ -236,13 +290,11 @@ fi
|
|
236
290
|
%{__prefix}/lib/rpm/rpm[bt]
|
237
291
|
%{__prefix}/lib/rpm/rpmdiff
|
238
292
|
%{__prefix}/lib/rpm/rpmdiff.cgi
|
239
|
-
%{__prefix}/lib/rpm/rpmgettext
|
240
|
-
%{__prefix}/lib/rpm/rpmputtext
|
241
293
|
%{__prefix}/lib/rpm/u_pkg.sh
|
242
294
|
%{__prefix}/lib/rpm/vpkg-provides.sh
|
243
295
|
%{__prefix}/lib/rpm/vpkg-provides2.sh
|
244
296
|
|
245
|
-
%
|
297
|
+
%if %{with_python_subpackage}
|
246
298
|
%files python
|
247
299
|
%defattr(-,root,root)
|
248
300
|
%{__prefix}/lib/python1.5/site-packages/rpmmodule.so
|
@@ -250,6 +302,9 @@ fi
|
|
250
302
|
|
251
303
|
%files devel
|
252
304
|
%defattr(-,root,root)
|
305
|
+
%if %{with_apidocs}
|
306
|
+
%doc apidocs
|
307
|
+
%endif
|
253
308
|
%{__prefix}/include/rpm
|
254
309
|
%{__prefix}/lib/librpm.a
|
255
310
|
%{__prefix}/lib/librpm.la
|
@@ -264,8 +319,23 @@ fi
|
|
264
319
|
%files -n popt
|
265
320
|
%defattr(-,root,root)
|
266
321
|
%{__prefix}/lib/libpopt.so.*
|
267
|
-
%{__prefix}/*/locale/*/LC_MESSAGES/popt.mo
|
268
322
|
%{__prefix}%{__share}/man/man3/popt.3*
|
323
|
+
%lang(cs) %{__prefix}/*/locale/cs/LC_MESSAGES/popt.mo
|
324
|
+
%lang(da) %{__prefix}/*/locale/da/LC_MESSAGES/popt.mo
|
325
|
+
%lang(gl) %{__prefix}/*/locale/gl/LC_MESSAGES/popt.mo
|
326
|
+
%lang(hu) %{__prefix}/*/locale/hu/LC_MESSAGES/popt.mo
|
327
|
+
%lang(is) %{__prefix}/*/locale/is/LC_MESSAGES/popt.mo
|
328
|
+
%lang(no) %{__prefix}/*/locale/no/LC_MESSAGES/popt.mo
|
329
|
+
%lang(pt) %{__prefix}/*/locale/pt/LC_MESSAGES/popt.mo
|
330
|
+
%lang(ro) %{__prefix}/*/locale/ro/LC_MESSAGES/popt.mo
|
331
|
+
%lang(ru) %{__prefix}/*/locale/ru/LC_MESSAGES/popt.mo
|
332
|
+
%lang(sk) %{__prefix}/*/locale/sk/LC_MESSAGES/popt.mo
|
333
|
+
%lang(sl) %{__prefix}/*/locale/sl/LC_MESSAGES/popt.mo
|
334
|
+
%lang(sv) %{__prefix}/*/locale/sv/LC_MESSAGES/popt.mo
|
335
|
+
%lang(tr) %{__prefix}/*/locale/tr/LC_MESSAGES/popt.mo
|
336
|
+
%lang(uk) %{__prefix}/*/locale/uk/LC_MESSAGES/popt.mo
|
337
|
+
%lang(wa) %{__prefix}/*/locale/wa/LC_MESSAGES/popt.mo
|
338
|
+
%lang(zh_CN) %{__prefix}/*/locale/zh_CN.GB2312/LC_MESSAGES/popt.mo
|
269
339
|
|
270
340
|
# XXX These may end up in popt-devel but it hardly seems worth the effort now.
|
271
341
|
%{__prefix}/lib/libpopt.a
|
@@ -274,276 +344,250 @@ fi
|
|
274
344
|
%{__prefix}/include/popt.h
|
275
345
|
|
276
346
|
%changelog
|
277
|
-
*
|
278
|
-
-
|
279
|
-
|
347
|
+
* Tue Mar 13 2001 Jeff Johnson <jbj@redhat.com>
|
348
|
+
- map i686-like (i.e. w/o CMOV) platforms to better alternatives.
|
349
|
+
|
350
|
+
* Mon Mar 12 2001 Jeff Johnson <jbj@redhat.com>
|
351
|
+
- fix: adjust for libio breakage in Red Hat 5.x with glibc-2.0.7-29.4.
|
352
|
+
|
353
|
+
* Wed Mar 7 2001 Jeff Johnson <jbj@redhat.com>
|
354
|
+
- remove mozilla dependency white out, no longer needed.
|
355
|
+
|
356
|
+
* Fri Feb 23 2001 Jeff Johnson <jbj@redhat.com>
|
357
|
+
- (sparc) disable MD5 sum checks during install.
|
358
|
+
- (db1) plug largish memory leak in simulated interface for falloc.c.
|
359
|
+
|
360
|
+
* Thu Feb 22 2001 Jeff Johnson <jbj@redhat.com>
|
361
|
+
- portability changes from Joe Orton <jorton@redhat.com> et al.
|
362
|
+
- (alpha): rip out ALPHA_LOSSAGE now that gcc-2.96-76 has fix (#28509).
|
363
|
+
- (popt): use sprintf rather than snprintf for portability.
|
364
|
+
|
365
|
+
* Mon Feb 19 2001 Jeff Johnson <jbj@redhat.com>
|
366
|
+
- rpm-4.0.2 release candidate.
|
367
|
+
|
368
|
+
* Wed Feb 14 2001 Jeff Johnson <jbj@redhat.com>
|
369
|
+
- fix: permit packages to differ by 0 or 32 bytes (#26373).
|
370
|
+
- fix: permit HEADER_IMMUTABLE tag queries.
|
371
|
+
- split db configuration into separate file.
|
372
|
+
|
373
|
+
* Tue Feb 13 2001 Jeff Johnson <jbj@redhat.com>
|
374
|
+
- fix: remove fixed size buffer on output path (#26987,#26332).
|
375
|
+
- resurrect rpmErrorCode in the API for Perl-RPM.
|
376
|
+
|
377
|
+
* Sat Feb 10 2001 Jeff Johnson <jbj@redhat.com>
|
378
|
+
- fix: diddle exit code for attempted installs of non-packages (#26850).
|
379
|
+
- python binding diddles to reduce installer memory footprint by
|
380
|
+
delayed loading of file info.
|
381
|
+
|
382
|
+
* Fri Feb 9 2001 Jeff Johnson <jbj@redhat.com>
|
383
|
+
- fix: make a copy of retrieved header before loading.
|
384
|
+
|
385
|
+
* Sun Jan 21 2001 Jeff Johnson <jbj@redhat.com>
|
386
|
+
- fix: check waitpid return code.
|
387
|
+
|
388
|
+
* Fri Jan 19 2001 Jeff Johnson <jbj@redhat.com>
|
389
|
+
- ewt's cpio.c hack.
|
390
|
+
- ewt's cpio.c hack reverted.
|
391
|
+
- rebuild with i18n from rpm-4_0 branch.
|
392
|
+
- rpmlint conformance.
|
393
|
+
|
394
|
+
* Thu Jan 18 2001 Matt Wilson <msw@redhat.com>
|
395
|
+
- fix: exit 0 at the end of %pre
|
280
396
|
|
281
|
-
*
|
282
|
-
-
|
397
|
+
* Thu Jan 18 2001 Jeff Johnson <jbj@redhat.com>
|
398
|
+
- fix: insure that %lang scopes over hard links correctly.
|
399
|
+
- fix: rpmCleanPath was nibbling at .. in macrofiles incorrectly.
|
283
400
|
|
284
|
-
* Wed
|
285
|
-
-
|
286
|
-
|
287
|
-
|
288
|
-
|
289
|
-
|
290
|
-
|
291
|
-
|
292
|
-
|
293
|
-
-
|
294
|
-
|
295
|
-
*
|
296
|
-
-
|
297
|
-
|
298
|
-
*
|
299
|
-
-
|
300
|
-
|
301
|
-
|
302
|
-
|
303
|
-
-
|
304
|
-
|
305
|
-
|
306
|
-
|
307
|
-
|
308
|
-
|
309
|
-
|
310
|
-
|
311
|
-
- fix:
|
312
|
-
|
313
|
-
* Mon
|
314
|
-
-
|
315
|
-
-
|
316
|
-
|
317
|
-
*
|
318
|
-
- fix:
|
319
|
-
|
320
|
-
*
|
321
|
-
- fix:
|
322
|
-
-
|
323
|
-
|
324
|
-
|
325
|
-
|
326
|
-
|
327
|
-
|
328
|
-
|
329
|
-
|
330
|
-
- popt
|
331
|
-
|
332
|
-
*
|
333
|
-
-
|
334
|
-
-
|
335
|
-
-
|
336
|
-
|
337
|
-
|
338
|
-
|
339
|
-
|
340
|
-
|
341
|
-
|
342
|
-
|
343
|
-
|
344
|
-
-
|
345
|
-
|
346
|
-
*
|
347
|
-
-
|
348
|
-
|
349
|
-
*
|
350
|
-
-
|
351
|
-
|
352
|
-
|
353
|
-
|
354
|
-
-
|
355
|
-
|
356
|
-
*
|
357
|
-
-
|
358
|
-
-
|
359
|
-
|
360
|
-
|
361
|
-
-
|
362
|
-
|
363
|
-
|
364
|
-
-
|
365
|
-
|
366
|
-
|
367
|
-
-
|
368
|
-
-
|
369
|
-
|
370
|
-
|
371
|
-
|
372
|
-
|
373
|
-
|
374
|
-
- fix:
|
375
|
-
- fix:
|
376
|
-
-
|
377
|
-
|
378
|
-
|
379
|
-
|
380
|
-
-
|
381
|
-
-
|
382
|
-
|
383
|
-
|
384
|
-
|
385
|
-
- add
|
386
|
-
-
|
387
|
-
|
388
|
-
|
389
|
-
-
|
390
|
-
-
|
391
|
-
- fix:
|
392
|
-
|
393
|
-
|
394
|
-
|
395
|
-
|
396
|
-
-
|
397
|
-
-
|
398
|
-
|
399
|
-
|
400
|
-
-
|
401
|
-
|
402
|
-
|
403
|
-
-
|
404
|
-
-
|
405
|
-
-
|
406
|
-
|
407
|
-
|
408
|
-
|
409
|
-
|
410
|
-
-
|
411
|
-
-
|
412
|
-
-
|
413
|
-
|
414
|
-
|
415
|
-
|
416
|
-
-
|
417
|
-
-
|
418
|
-
-
|
419
|
-
-
|
420
|
-
-
|
421
|
-
-
|
422
|
-
|
423
|
-
|
424
|
-
|
425
|
-
-
|
426
|
-
|
427
|
-
|
428
|
-
-
|
429
|
-
|
430
|
-
|
431
|
-
-
|
432
|
-
|
433
|
-
|
434
|
-
-
|
435
|
-
|
436
|
-
|
437
|
-
|
438
|
-
-
|
439
|
-
|
440
|
-
|
441
|
-
-
|
442
|
-
-
|
443
|
-
|
444
|
-
|
445
|
-
-
|
446
|
-
|
447
|
-
*
|
448
|
-
-
|
449
|
-
|
450
|
-
*
|
451
|
-
-
|
452
|
-
|
453
|
-
|
454
|
-
|
455
|
-
-
|
456
|
-
|
457
|
-
|
458
|
-
-
|
459
|
-
-
|
460
|
-
|
461
|
-
* Wed
|
462
|
-
-
|
463
|
-
|
464
|
-
|
465
|
-
|
466
|
-
|
467
|
-
|
468
|
-
|
469
|
-
|
470
|
-
|
471
|
-
|
472
|
-
|
473
|
-
-
|
474
|
-
|
475
|
-
*
|
476
|
-
-
|
401
|
+
* Wed Jan 17 2001 Jeff Johnson <jbj@redhat.com>
|
402
|
+
- 1st crack at Mandrake specific per-platform macros.
|
403
|
+
|
404
|
+
* Tue Jan 16 2001 Jeff Johnson <jbj@redhat.com>
|
405
|
+
- tsort prefers presentation order.
|
406
|
+
|
407
|
+
* Mon Jan 15 2001 Jeff Johnson <jbj@redhat.com>
|
408
|
+
- fix: extra newline in many error messages (#23947).
|
409
|
+
- fix: rpm -Va with db1 needs per-iterator, not per-index, offset.
|
410
|
+
- add install/remove transaction id tags.
|
411
|
+
|
412
|
+
* Sat Jan 13 2001 Jeff Johnson <jbj@redhat.com>
|
413
|
+
- fix the hack.
|
414
|
+
|
415
|
+
* Fri Jan 12 2001 Jeff Johnson <jbj@redhat.com>
|
416
|
+
- hack: permit installer to determine package ordering using 1000003 tag.
|
417
|
+
|
418
|
+
* Thu Jan 11 2001 Jeff Johnson <jbj@redhat.com>
|
419
|
+
- fix: don't hang on build error.
|
420
|
+
- fix: remove "error: " prefix from signature verification message.
|
421
|
+
|
422
|
+
* Wed Jan 10 2001 Jeff Johnson <jbj@redhat.com>
|
423
|
+
- successors from tsort are processed in presentation order.
|
424
|
+
- fix: find-requires.perl needed update (#23450).
|
425
|
+
|
426
|
+
* Tue Jan 9 2001 Jeff Johnson <jbj@redhat.com>
|
427
|
+
- fix: digests on input FD_t dinna work.
|
428
|
+
- fix: remove rebuilddb debugging leakage.
|
429
|
+
|
430
|
+
* Mon Jan 8 2001 Jeff Johnson <jbj@redhat.com>
|
431
|
+
- tsorted packages processed in successor count order.
|
432
|
+
- fix: resurrect --excludepath (#19666).
|
433
|
+
|
434
|
+
* Fri Jan 5 2001 Jeff Johnson <jbj@redhat.com>
|
435
|
+
- fix: 3 packages from Red Hat 5.2 had bogus %verifyscript tag.
|
436
|
+
|
437
|
+
* Wed Jan 3 2001 Jeff Johnson <jbj@redhat.com>
|
438
|
+
- fix: avoid locale issues with strcasecmp/strncasecmp (#23199).
|
439
|
+
- remove almost all explicit uses of stderr in rpmlib using rpmError().
|
440
|
+
- fix: pass scriptlet args, as in %post -p "/sbin/ldconfig -n /lib".
|
441
|
+
(Rodrigo Barbosa)
|
442
|
+
|
443
|
+
* Tue Jan 2 2001 Jeff Johnson <jbj@redhat.com>
|
444
|
+
- fix apidocs.
|
445
|
+
|
446
|
+
* Mon Jan 1 2001 Jeff Johnson <jbj@redhat.com>
|
447
|
+
- use popt autohelp for rpm helper binaries.
|
448
|
+
|
449
|
+
* Sun Dec 31 2000 Jeff Johnson <jbj@redhat.com>
|
450
|
+
- (popt): fix float/double handling (#19701).
|
451
|
+
- (popt): non-linux needs <float.h> (#22732).
|
452
|
+
- (popt): add POPT_ARGFLAG_OPTIONAL for long options with optional arg.
|
453
|
+
- (popt): diddle auto-help to include type of arg expected.
|
454
|
+
|
455
|
+
* Sat Dec 30 2000 Jeff Johnson <jbj@redhat.com>
|
456
|
+
- (non-linux): move stubs.c to rpmio (#21132).
|
457
|
+
- (python): bind initdb (#20988).
|
458
|
+
|
459
|
+
* Fri Dec 29 2000 Jeff Johnson <jbj@redhat.com>
|
460
|
+
- fix: hack around alpha mis-compilation signature problems.
|
461
|
+
- rpmmodule.c(handleDbResult): return empty list when nothing matches.
|
462
|
+
|
463
|
+
* Thu Dec 28 2000 Jeff Johnson <jbj@redhat.com>
|
464
|
+
- fix: avoid FAT and other brain-dead file systems that have not inodes.
|
465
|
+
|
466
|
+
* Wed Dec 27 2000 Jeff Johnson <jbj@redhat.com>
|
467
|
+
- use malloc'ed buffer for large queries.
|
468
|
+
|
469
|
+
* Tue Dec 26 2000 Jeff Johnson <jbj@redhat.com>
|
470
|
+
- send query/verify output through rpmlog().
|
471
|
+
- resurrect rpmErrorSetCallback() and rpmErrorString().
|
472
|
+
|
473
|
+
* Thu Dec 21 2000 Jeff Johnson <jbj@redhat.com>
|
474
|
+
- immutable headers, once installed by rpm3, need to lose immutablity.
|
475
|
+
- fix: removed headers from db need a headerCopy().
|
476
|
+
|
477
|
+
* Wed Dec 20 2000 Jeff Johnson <jbj@redhat.com>
|
478
|
+
- whiteout mozilla loop for 7.1.
|
479
|
+
|
480
|
+
* Tue Dec 19 2000 Jeff Johnson <jbj@redhat.com>
|
481
|
+
- gendiff: generate ChangeLog patches more intelligently (#22356).
|
482
|
+
- identify install scriptlet failures with the name of the scriptlet.
|
483
|
+
- handle install chroot's identically throughout the install process.
|
484
|
+
- add rpmlib(HeaderLoadSortsTags) for tracking header regions "just in case".
|
485
|
+
- create _tmppath on the fly if not present.
|
486
|
+
- remove /etc/rpm/macros.db1 configuration file if db3 rebuilt.
|
487
|
+
|
488
|
+
* Wed Dec 13 2000 Jeff Johnson <jbj@redhat.com>
|
489
|
+
- bump popt version.
|
490
|
+
- fix: (transaction.c) assume file state normal if tag is missing.
|
491
|
+
- fix: failed signature read headerFree segfault.
|
492
|
+
- fix: revert ALPHA_LOSSAGE, breaks 6.2/i386.
|
493
|
+
- fix: segfault on build path, ignore deleted drips.
|
494
|
+
- fix: synthesized callbacks for removed packages have not a pkgkey.
|
495
|
+
|
496
|
+
* Tue Dec 12 2000 Jeff Johnson <jbj@redhat.com>
|
497
|
+
- bail on header regions.
|
498
|
+
- change dependency loop message to RPMMESS_WARNING to use stderr, not stdout.
|
499
|
+
|
500
|
+
* Sun Dec 10 2000 Jeff Johnson <jbj@redhat.com>
|
501
|
+
- handle added dirtoken tags (mostly) correctly with header regions.
|
502
|
+
- add FHS doc/man/info dirs, diddle autoconf goo.
|
503
|
+
- fix: headerUnload handles headers w/o regions correctly on rebuilddb.
|
504
|
+
|
505
|
+
* Thu Dec 7 2000 Jeff Johnson <jbj@redhat.com>
|
506
|
+
- add rpmtransGetKeys() to retrieve transaction keys in tsort'ed order.
|
507
|
+
- python bindings for rpmtransGetKeys().
|
508
|
+
- fix: include alignment in count when swabbing header region.
|
509
|
+
|
510
|
+
* Wed Dec 6 2000 Jeff Johnson <jbj@redhat.com>
|
511
|
+
- improved find-{requires,provides} for aix4/hpux/irix6/osf.
|
512
|
+
Tim Mooney<mooney@dogbert.cc.ndsu.NoDak.edu>
|
513
|
+
- portability: remove use of GNU make subst in lib/Makefile (Joe Orton).
|
514
|
+
- python: bind package removal (#21274).
|
515
|
+
- autoconfigure building python bindings.
|
516
|
+
- autoconfigure generating rpm API doco rpm-devel package.
|
517
|
+
- fix: don't fdFree in rpmVerifyScript, rpmtransFree does already.
|
518
|
+
- unify rpmError and rpmMessge interfaces through rpmlog.
|
519
|
+
- collect and display rpm build error messages at end of build.
|
520
|
+
- use package version 3 if --nodirtokens is specified.
|
521
|
+
- add package names to problem sets early, don't save removed header.
|
522
|
+
- make sure that replaced tags in region are counted in headerSizeof().
|
523
|
+
- support for dmalloc debugging.
|
524
|
+
- filter region tags in headerNextIterator, exit throut headerReload.
|
525
|
+
|
526
|
+
* Thu Nov 30 2000 Jeff Johnson <jbj@redhat.com>
|
527
|
+
- add missing headerFree for legacy signature header.
|
528
|
+
- fix: removed packages leaked DIRINDEXES tag data.
|
529
|
+
- reload tags added during install when loading header from rpmdb.
|
530
|
+
- avoid brp-compress hang with both compressed/uncompressed man pages.
|
531
|
+
|
532
|
+
* Tue Nov 21 2000 Jeff Johnson <jbj@redhat.com>
|
533
|
+
- add brp-strip-shared script <rodrigob@conectiva.com.br>.
|
534
|
+
- better item/task progress bars <rodrigob@conectiva.com.br>.
|
535
|
+
- load headers as single contiguous region.
|
536
|
+
- add region marker as RPM_BIN_TYPE in packages and database.
|
537
|
+
- fix: don't headerCopy() relocateable packages if not relocating.
|
538
|
+
- merge signatures into header after reading from package.
|
539
|
+
|
540
|
+
* Mon Nov 20 2000 Jeff Johnson <jbj@redhat.com>
|
541
|
+
- add doxygen and lclint annotations most everywhere.
|
542
|
+
- consistent return for all signature verification.
|
543
|
+
- use enums for almost all rpmlib #define's.
|
544
|
+
- API: change rpmProblem typedef to pass by reference, not value.
|
545
|
+
- don't trim leading ./ in rpmCleanPath() (#14961).
|
546
|
+
- detect (still need to test) rdonly linux file systems.
|
547
|
+
- check available inodes as well as blocks on mounted file systems.
|
548
|
+
- pass rpmTransactionSet, not elements, to installBinaryPackage et al.
|
549
|
+
- add cscope/ctags (Rodrigo Barbosa<rodrigob@conectiva.com.br>).
|
550
|
+
- remove getMacroBody() from rpmio API.
|
551
|
+
- add support for unzip <rodrigob@conectiva.com.br>
|
552
|
+
|
553
|
+
* Thu Nov 16 2000 Jeff Johnson <jbj@redhat.com>
|
554
|
+
- don't verify src rpm MD5 sums (yet).
|
555
|
+
- md5 sums are little endian (no swap) so big endian needs the swap.
|
556
|
+
|
557
|
+
* Wed Nov 15 2000 Jeff Johnson <jbj@redhat.com>
|
558
|
+
- fix: segfault on exit of "rpm -qp --qf '%{#fsnames}' pkg" (#20595).
|
559
|
+
- hpux w/o -D_OPEN_SOURCE has not h_errno.
|
560
|
+
- verify MD5 sums of payload files when unpacking archive.
|
561
|
+
- hide libio lossage in prototype, not API.
|
562
|
+
- add support for SHA1 as well as MD5 message digests.
|
563
|
+
|
564
|
+
* Mon Nov 13 2000 Jeff Johnson <jbj@redhat.com>
|
565
|
+
- fix: work around for (mis-compilation?!) segfaults on signature paths.
|
566
|
+
|
567
|
+
* Sun Nov 12 2000 Jeff Johnson <jbj@redhat.com>
|
568
|
+
- fix: duplicate headerFree() on instalBinaryPackage() error return.
|
569
|
+
|
570
|
+
* Sat Nov 11 2000 Jeff Johnson <jbj@redhat.com>
|
571
|
+
- fix: runTriggers was not adding countCorrection.
|
572
|
+
- add rpmGetRpmlibProvides() to retrieve rpmlib(...) provides
|
573
|
+
"Pawel A. Gajda" <mis@k2.net.pl>.
|
574
|
+
- syntax to specify source of Requires: (PreReq: now legacy).
|
575
|
+
- rip out rpm{get,put}text, use getpo.sh and specspo instead.
|
576
|
+
- fine-grained Requires, remove install PreReq's from Requires db.
|
577
|
+
|
578
|
+
* Wed Oct 11 2000 Jeff Johnson <jbj@redhat.com>
|
579
|
+
- fix: rpm2cpio error check wrong on non-libio platforms.
|
580
|
+
|
581
|
+
* Fri Sep 29 2000 Jeff Johnson <jbj@redhat.com>
|
582
|
+
- fix: more (possible) xstrdup side effects.
|
583
|
+
|
584
|
+
* Wed Sep 27 2000 Jeff Johnson <jbj@redhat.com>
|
585
|
+
- bump popt version to 1.6.1.
|
586
|
+
|
587
|
+
* Tue Sep 26 2000 Jeff Johnson <jbj@redhat.com>
|
588
|
+
- fix: avoid calling getpass twice as side effect of xstrdup macro (#17672).
|
589
|
+
- order packages using tsort, clipping PreReq:'s in dependency loops.
|
590
|
+
- handle possible db3 dependency on -lpthread more gracefully.
|
591
|
+
|
592
|
+
* Thu Sep 14 2000 Jeff Johnson <jbj@redhat.com>
|
593
|
+
- start rpm-4.0.1.
|
477
|
-
- simplify --last popt alias, date like -qi (bjerrick@easystreet.com).
|
478
|
-
- fix: alloca'd memory used outside of scope (alpha segfault).
|
479
|
-
|
480
|
-
* Mon May 8 2000 Jeff Johnson <jbj@redhat.com>
|
481
|
-
- FreeBSD fixes (bero@redhat.com).
|
482
|
-
|
483
|
-
* Sat May 6 2000 Jeff Johnson <jbj@redhat.com>
|
484
|
-
- finish db1 and db3 cleanup.
|
485
|
-
|
486
|
-
* Tue May 2 2000 Jeff Johnson <jbj@redhat.com>
|
487
|
-
- first try at db1 -> db3 stability.
|
488
|
-
|
489
|
-
* Mon May 1 2000 Jeff Johnson <jbj@redhat.com>
|
490
|
-
- Rename db0.c to db1.c, resurrect db2.c (from db3.c).
|
491
|
-
- Add ia64 and sparc64 changes.
|
492
|
-
- rpm.spec: add per-platform sub-directories.
|
493
|
-
|
494
|
-
* Fri Apr 28 2000 Jeff Johnson <jbj@redhat.com>
|
495
|
-
- Filter DB_INCOMPLETE on db->sync, it's usually harmless.
|
496
|
-
- Add per-transaction cache of resolved dependencies (aka Depends).
|
497
|
-
- Do lazy dbi{Open,Close} throughout.
|
498
|
-
- Attempt fine grained dbi cursors throughout.
|
499
|
-
- fix: free iterator *after* loop, not during.
|
500
|
-
- fix: Depends needed keylen in dbiPut, rpmdbFreeIterator after use.
|
501
|
-
|
502
|
-
* Thu Apr 27 2000 Jeff Johnson <jbj@redhat.com>
|
503
|
-
- API: replace rpmdbUpdateRecord with rpmdbSetIteratorModified.
|
504
|
-
- API: replace rpmdbFindByLabel with RPMDBI_LABEL iteration.
|
505
|
-
- API: replace rpmdbGetRecord with iterators.
|
506
|
-
- API: replace findMatches with iterators.
|
507
|
-
|
508
|
-
* Tue Apr 25 2000 Jeff Johnson <jbj@redhat.com>
|
509
|
-
- rebuild to check autoconf configuration in dist-7.0.
|
510
|
-
|
511
|
-
* Sun Apr 23 2000 Jeff Johnson <jbj@redhat.com>
|
512
|
-
- fix: cpio.c: pre-, not post-, decrement the link count.
|
513
|
-
- make db indices as lightweight as possible, with per-dbi config.
|
514
|
-
- db1.c will never be needed, eliminate.
|
515
|
-
- API: merge rebuilddb.c into rpmdb.c.
|
516
|
-
|
517
|
-
* Thu Apr 13 2000 Jeff Johnson <jbj@redhat.com>
|
518
|
-
- API: pass *SearchIndex() length of key (0 will use strlen(key)).
|
519
|
-
- API: remove rpmdb{First,Next}RecNum routines.
|
520
|
-
- drop rpm-python subpackage until bindings are fixed.
|
521
|
-
- add explcit "Provides: name = [epoch:]version-release" to headers.
|
522
|
-
|
523
|
-
* Tue Apr 11 2000 Jeff Johnson <jbj@redhat.com>
|
524
|
-
- solaris2.6: avoid bsearch with empty dir list (Ric Klaren - klaren@cs.utwente.nl)
|
525
|
-
- db3: save join keys in endian neutral binary format.
|
526
|
-
- treat legacy falloc.c as "special" db[01] index for package headers.
|
527
|
-
|
528
|
-
* Thu Apr 6 2000 Jeff Johnson <jbj@redhat.com>
|
529
|
-
- use hashed access for package headers.
|
530
|
-
|
531
|
-
* Tue Apr 4 2000 Jeff Johnson <jbj@redhat.com>
|
532
|
-
- create dbi from template rather than passed args.
|
533
|
-
|
534
|
-
* Mon Apr 3 2000 Jeff Johnson <jbj@redhat.com>
|
535
|
-
- prefer db3 as default.
|
536
|
-
- permit db3 configuration using macros.
|
537
|
-
|
538
|
-
* Fri Mar 31 2000 Jeff Johnson <jbj@redhat.com>
|
539
|
-
- try for db3 DB_INIT_CDB model.
|
540
|
-
|
541
|
-
* Fri Mar 24 2000 Jeff Johnson <jbj@redhat.com>
|
542
|
-
- use DIRNAMES/BASENAMES/DIRINDICES not FILENAMES in packages and db.
|
543
|
-
- configure.in fiddles for BSD systems (Patrick Schoo).
|
544
|
-
- API: change dbi to pass by reference, not value.
|
545
|
-
- cram all of db1, db_185, and db2 interfaces into rpmlib.
|
546
|
-
- convert db1 -> db2 on-disk format using --rebuilddb.
|
547
|
-
|
548
|
-
* Mon Mar 13 2000 Jeff Johnson <jbj@redhat.com>
|
549
|
-
- start rpm-3.1 development.
|
@@ -1 +1 @@
|
|
1
|
-
|
1
|
+
7b247d7fb7a0042fc81df935a7d21aac rpm-4.0.2.tar.gz
|