98655b auto-import changelog data from rpm-4.3.2-2.src.rpm

Authored and Committed by cvsdist 20 years ago
    auto-import changelog data from rpm-4.3.2-2.src.rpm
    Sat Sep 04 2004 Jeff Johnson <jbj@redhat.com> 4.3.2-2
    - ia64: make sure that autorelocated file dependencies are satisfied.
    - ia64: relocate all scriptlet interpreters.
    - ia64: don't bother trying to preload autorelocated modules.
    - fix: filesystem package needs mail/lock w/o getgrnam.
    - fix: do getpwnam/getgrnam to load correct modules before chroot.
    - restore file conflict detection traditional behavior.
    
        
file modified
+49 -11
rpm.spec CHANGED
@@ -20,7 +20,7 @@ Name: rpm
20
20
%define version 4.3.2
21
21
Version: %{version}
22
22
%{expand: %%define rpm_version %{version}}
23
- Release: 1
23
+ Release: 2
24
24
Group: System Environment/Base
25
25
Source: ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.0.x/rpm-%{rpm_version}.tar.gz
26
26
License: GPL
@@ -57,10 +57,18 @@ verifying, querying, and updating software packages. Each software
57
57
package consists of an archive of files along with information about
58
58
the package like its version, a description, etc.
59
59
60
+ %package libs
61
+ Summary: Libraries for manipulating RPM packages.
62
+ Group: Development/Libraries
63
+ Requires: rpm = %{rpm_version}-%{release}
64
+
65
+ %description libs
66
+ This package contains the RPM shared libraries.
67
+
60
68
%package devel
61
69
Summary: Development files for manipulating RPM packages.
62
70
Group: Development/Libraries
63
- Requires: rpm = %{rpm_version}
71
+ Requires: rpm = %{rpm_version}-%{release}
64
72
65
73
%description devel
66
74
This package contains the RPM C library and header files. These
@@ -76,7 +84,7 @@ will manipulate RPM packages and databases.
76
84
%package build
77
85
Summary: Scripts and executable programs used to build packages.
78
86
Group: Development/Tools
79
- Requires: rpm = %{rpm_version}, patch >= 2.5, file
87
+ Requires: rpm = %{rpm_version}-%{release}, patch >= 2.5, file
80
88
Provides: rpmbuild(VendorConfig) = 4.1-1
81
89
82
90
%description build
@@ -87,7 +95,7 @@ that are used to build packages using the RPM Package Manager.
87
95
%package python
88
96
Summary: Python bindings for apps which will manipulate RPM packages.
89
97
Group: Development/Libraries
90
- Requires: rpm = %{rpm_version}
98
+ Requires: rpm = %{rpm_version}-%{release}
91
99
Requires: python >= %{with_python_version}
92
100
Requires: elfutils >= 0.55
93
101
@@ -280,11 +288,6 @@ exit 0
280
288
%rpmattr %{__bindir}/rpmquery
281
289
%rpmattr %{__bindir}/rpmverify
282
290
283
- %{__libdir}/librpm-4.3.so
284
- %{__libdir}/librpmdb-4.3.so
285
- %{__libdir}/librpmio-4.3.so
286
- %{__libdir}/librpmbuild-4.3.so
287
-
288
291
%attr(0755, rpm, rpm) %dir %{__prefix}/lib/rpm
289
292
%rpmattr %{__prefix}/lib/rpm/config.guess
290
293
%rpmattr %{__prefix}/lib/rpm/config.sub
@@ -366,6 +369,13 @@ exit 0
366
369
%lang(ru) %{__mandir}/ru/man[18]/*.[18]*
367
370
%lang(sk) %{__mandir}/sk/man[18]/*.[18]*
368
371
372
+ %files libs
373
+ %defattr(-,root,root)
374
+ %{__libdir}/librpm-4.3.so
375
+ %{__libdir}/librpmdb-4.3.so
376
+ %{__libdir}/librpmio-4.3.so
377
+ %{__libdir}/librpmbuild-4.3.so
378
+
369
379
%files build
370
380
%defattr(-,root,root)
371
381
%dir %{__prefix}/src/redhat
@@ -485,8 +495,36 @@ exit 0
485
495
%{__includedir}/popt.h
486
496
487
497
%changelog
488
- * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
489
- - rebuilt
498
+ * Sat Sep 4 2004 Jeff Johnson <jbj@redhat.com> 4.3.2-2
499
+ - ia64: make sure that autorelocated file dependencies are satisfied.
500
+ - ia64: relocate all scriptlet interpreters.
501
+ - ia64: don't bother trying to preload autorelocated modules.
502
+ - fix: filesystem package needs mail/lock w/o getgrnam.
503
+ - fix: do getpwnam/getgrnam to load correct modules before chroot.
504
+ - restore file conflict detection traditional behavior.
505
+
506
+ * Fri Aug 20 2004 Jeff Johnson <jbj@redhat.com> 4.3.2-0.9
507
+ - fix: static glibc/libgcc helpers always installed (#127522).
508
+ - fix: defattr for rpm-libs (#130461).
509
+
510
+ * Thu Aug 19 2004 Jeff Johnson <jbj@jbj.org> 4.3.2-0.7
511
+ - shared libraries in separate rpm-libs package.
512
+ - avoid "can't happen" recursion while retrieving pubkeys.
513
+ - add ppc32dy4 arch.
514
+ - make peace with automake 1.9.1.
515
+
516
+ * Fri Jul 9 2004 Jeff Johnson <jbj@jbj.org> 4.3.2-0.6
517
+ - fix: evaluate rather than default file_contexts path. (#127501).
518
+
519
+ * Mon Jul 5 2004 Jeff Johnson <jbj@jbj.org> 4.3.2-0.5
520
+ - change default behavior to resolve file conflicts as LIFO.
521
+ - add --fileconflicts to recover rpm traditional behavior.
522
+ - prefer elf64 over elf32 files, everywhere and always (#126853).
523
+ - ia64: auto-relocate entire, not partial, directory contents (#126905).
524
+ - ia64: auto-relocate glibc.ix86 interpreter path (#100563).
525
+
526
+ * Wed Jun 16 2004 Jeff Johnson <jbj@jbj.org> 4.3.2-0.4
527
+ - add ppc8[25]60 arches.
490
528
491
529
* Mon Jun 14 2004 Jeff Johnson <jbj@jbj.org> 4.3.2-0.3
492
530
- add 'requires' and 'conflicts' tag aliases.
file modified
+1 -1
sources CHANGED
@@ -1 +1 @@
1
- caf2084922c1dbd1921d60a16f7786bf rpm-4.3.2.tar.gz
1
+ 40826a54267151568ed10f39e603d4a5 rpm-4.3.2.tar.gz