7d7537 Remove direct ldconfig calls, use compat macros instead

Authored and Committed by Panu Matilainen 6 years ago
1 file changed. 8 lines added. 7 lines removed.
    Remove direct ldconfig calls, use compat macros instead
    
        
file modified
+8 -7
rpm.spec CHANGED
@@ -23,7 +23,7 @@
23
23
24
24
%global rpmver 4.14.1
25
25
#global snapver rc2
26
- %global rel 10
26
+ %global rel 11
27
27
28
28
%global srcver %{version}%{?snapver:-%{snapver}}
29
29
%global srcdir %{?snapver:testing}%{!?snapver:%{name}-%(echo %{version} | cut -d'.' -f1-2).x}
@@ -35,7 +35,7 @@
35
35
Summary: The RPM package management system
36
36
Name: rpm
37
37
Version: %{rpmver}
38
- Release: %{?snapver:0.%{snapver}.}%{rel}%{?dist}.1
38
+ Release: %{?snapver:0.%{snapver}.}%{rel}%{?dist}
39
39
Group: System Environment/Base
40
40
Url: http://www.rpm.org/
41
41
Source0: http://ftp.rpm.org/releases/%{srcdir}/%{name}-%{srcver}.tar.bz2
@@ -468,11 +468,9 @@ chmod a-x $RPM_BUILD_ROOT/%{rpmhome}/python-macro-helper
468
468
make check || cat tests/rpmtests.log
469
469
%endif
470
470
471
- %post libs -p /sbin/ldconfig
472
- %postun libs -p /sbin/ldconfig
473
-
471
+ # Fedora < 28 and EPEL-7 builds need these
472
+ %ldconfig_scripts libs
473
+ %ldconfig_scripts build-libs
474
- %post build-libs -p /sbin/ldconfig
475
- %postun build-libs -p /sbin/ldconfig
476
474
477
475
%files -f %{name}.lang
478
476
%license COPYING
@@ -607,6 +605,9 @@ make check || cat tests/rpmtests.log
607
605
%doc doc/librpm/html/*
608
606
609
607
%changelog
608
+ * Fri Jun 29 2018 Panu Matilainen <pmatilai@redhat.com> - 4.14.2-11
609
+ - Remove direct ldconfig calls, use compat macros instead
610
+
610
611
* Fri Jun 15 2018 Miro HronĨok <mhroncok@redhat.com> - 4.14.1-10.1
611
612
- Rebuilt for Python 3.7
612
613