7c8e00 - fix mono dependency extraction (adjust for libmagic string change)

Authored and Committed by Panu Matilainen 16 years ago
    - fix mono dependency extraction (adjust for libmagic string change)
    
        
rpm-4.5.90-mono-magic.patch ADDED
@@ -0,0 +1,22 @@
1
+ commit b3bd21e9f07272a37c2259070f95b167e6301c79
2
+ Author: Panu Matilainen <pmatilai@redhat.com>
3
+ Date: Mon Jul 14 11:53:10 2008 +0300
4
+
5
+ Fix mono dependency extraction
6
+ - use "Mono/.Net assembly" instead of "PE executable" for detection,
7
+ later file reports bitness (eg "PE32 executable"), we just care if its
8
+ mono or not. This is compatible with older libmagic too.
9
+
10
+ diff --git a/build/rpmfc.c b/build/rpmfc.c
11
+ index 3cc2d6d..6f15b2c 100644
12
+ --- a/build/rpmfc.c
13
+ +++ b/build/rpmfc.c
14
+ @@ -490,7 +490,7 @@ static const struct rpmfcTokens_s const rpmfcTokens[] = {
15
+
16
+ /* XXX .NET executables and libraries. file(1) cannot differ from win32
17
+ * executables unfortunately :( */
18
+ - { "PE executable", RPMFC_MONO|RPMFC_INCLUDE },
19
+ + { "Mono/.Net assembly", RPMFC_MONO|RPMFC_INCLUDE },
20
+
21
+ { "current ar archive", RPMFC_STATIC|RPMFC_LIBRARY|RPMFC_ARCHIVE|RPMFC_INCLUDE },
22
+
file modified
+9 -1
rpm.spec CHANGED
@@ -18,7 +18,7 @@
18
18
Summary: The RPM package management system
19
19
Name: rpm
20
20
Version: %{rpmver}
21
- Release: 0.%{snapver}.6
21
+ Release: 0.%{snapver}.7
22
22
Group: System Environment/Base
23
23
Url: http://www.rpm.org/
24
24
Source0: http://rpm.org/releases/testing/%{name}-%{srcver}.tar.bz2
@@ -31,7 +31,9 @@ Patch1: rpm-4.5.90-pkgconfig-path.patch
31
31
# XXX only create provides for pkgconfig and libtool initially
32
32
Patch100: rpm-4.6.x-no-pkgconfig-reqs.patch
33
33
34
+ # These are already upstream, drop on next snapshot update:
34
35
Patch200: rpm-4.5.90-digestlen.patch
36
+ Patch201: rpm-4.5.90-mono-magic.patch
35
37
36
38
# Partially GPL/LGPL dual-licensed and some bits with BSD
37
39
# SourceLicense: (GPLv2+ and LGPLv2+ with exceptions) and BSD
@@ -158,7 +160,9 @@ that will manipulate RPM packages and databases.
158
160
%patch0 -p1 -b .devel-autodep
159
161
%patch1 -p1 -b .pkgconfig-path
160
162
%patch100 -p1 -b .pkgconfig-deps
163
+
161
164
%patch200 -p1 -b .diglen
165
+ %patch201 -p1 -b .mono-magic
162
166
163
167
%if %{with int_bdb}
164
168
ln -s db-%{bdbver} db
@@ -334,6 +338,10 @@ exit 0
334
338
%doc doc/librpm/html/*
335
339
336
340
%changelog
341
+ * Mon Jul 14 2008 Panu Matilainen <pmatilai@redhat.com>
342
+ - 4.5.90-0.git8426.7
343
+ - fix mono dependency extraction (adjust for libmagic string change)
344
+
337
345
* Sat Jul 12 2008 Panu Matilainen <pmatilai@redhat.com>
338
346
- 4.5.90-0.git8426.6
339
347
- fix type mismatch causing funky breakage on ppc64