79f78c Add find-debuginfo-and-macro-docs.patch.

Authored and Committed by Mark Wielaard 7 years ago
    Add find-debuginfo-and-macro-docs.patch.
    
        
find-debuginfo-and-macro-docs.patch ADDED
@@ -0,0 +1,106 @@
1
+ commit 173e5642a97c535f8bdaac5bf88854a103cc125b
2
+ Author: Mark Wielaard <mark@klomp.org>
3
+ Date: Mon Jun 26 13:35:48 2017 +0200
4
+
5
+ Update find-debuginfo.sh options and macros documentation.
6
+
7
+ This adds some missing documentation for rpm macros and find-debuginfo.sh
8
+ options that were recently added (or renamed). -j N, --build-id-seed SEED,
9
+ --unique-debug-suffix SUFFIX and --unique-debug-src-base BASE.
10
+
11
+ Signed-off-by: Mark Wielaard <mark@klomp.org>
12
+
13
+ diff --git a/macros.in b/macros.in
14
+ index b095719..3e9b73f 100644
15
+ --- a/macros.in
16
+ +++ b/macros.in
17
+ @@ -522,8 +522,9 @@ package or when debugging this package.\
18
+
19
+ # Whether build-ids should be made unique between package version/releases
20
+ # when generating debuginfo packages. If set to 1 this will pass
21
+ -# --ver-rel "%{VERSION}-%{RELEASE}" to find-debuginfo.sh which will pass it
22
+ -# onto debugedit --build-id-seed to be used to prime the build-id note hash.
23
+ +# --build-id-seed "%{VERSION}-%{RELEASE}" to find-debuginfo.sh which will
24
+ +# pass it onto debugedit --build-id-seed to be used to prime the build-id
25
+ +# note hash.
26
+ %_unique_build_ids 1
27
+
28
+ # Do not recompute build-ids but keep whatever is in the ELF file already.
29
+ @@ -533,15 +534,16 @@ package or when debugging this package.\
30
+
31
+ # Whether .debug files should be made unique between package version,
32
+ # release and architecture. If set to 1 this will pass
33
+ -# --unique-debug-arch "%{_arch}" to find-debuginfo.sh to create
34
+ -# debuginfo files which end in -<ver>-<rel>.<arch>.debug
35
+ +# --unique-debug-suffix "-%{VERSION}-%{RELEASE}.%{_arch} find-debuginfo.sh
36
+ +# to create debuginfo files which end in -<ver>-<rel>.<arch>.debug
37
+ # Requires _unique_build_ids.
38
+ %_unique_debug_names 1
39
+
40
+ # Whether the /usr/debug/src/<package> directories should be unique between
41
+ # package version, release and architecture. If set to 1 this will pass
42
+ -# --unique-debug-src-base "%{name}" to find-debuginfo.sh to name the
43
+ -# directory under /usr/debug/src as <name>-<ver>-<rel>.<arch>
44
+ +# --unique-debug-src-base "%{name}-%{VERSION}-%{RELEASE}.%{_arch}" to
45
+ +# find-debuginfo.sh to name the directory under /usr/debug/src as
46
+ +# <name>-<ver>-<rel>.<arch>.
47
+ %_unique_debug_srcs 1
48
+
49
+ # Whether rpm should put debug source files into its own subpackage
50
+ diff --git a/scripts/find-debuginfo.sh b/scripts/find-debuginfo.sh
51
+ index 0233d92..85a862f 100755
52
+ --- a/scripts/find-debuginfo.sh
53
+ +++ b/scripts/find-debuginfo.sh
54
+ @@ -3,11 +3,14 @@
55
+ #for inclusion in an rpm spec file.
56
+ #
57
+ # Usage: find-debuginfo.sh [--strict-build-id] [-g] [-r] [-m] [-i] [-n]
58
+ +# [-j N]
59
+ # [-o debugfiles.list]
60
+ # [-S debugsourcefiles.list]
61
+ # [--run-dwz] [--dwz-low-mem-die-limit N]
62
+ # [--dwz-max-die-limit N]
63
+ -# [--build-id-seed VERSION-RELEASE]
64
+ +# [--build-id-seed SEED]
65
+ +# [--unique-debug-suffix SUFFIX]
66
+ +# [--unique-debug-src-base BASE]
67
+ # [[-l filelist]... [-p 'pattern'] -o debuginfo.list]
68
+ # [builddir]
69
+ #
70
+ @@ -19,6 +22,9 @@
71
+ # The -i flag says to include a .gdb_index section in the .debug file.
72
+ # The -n flag says to not recompute the build-id.
73
+ #
74
+ +# The -j N option will spawn N processes to do the debuginfo extraction
75
+ +# in parallel.
76
+ +#
77
+ # A single -o switch before any -l or -p switches simply renames
78
+ # the primary output file from debugfiles.list to something else.
79
+ # A -o switch that follows a -p switch or some -l switches produces
80
+ @@ -31,11 +37,21 @@
81
+ # if available, and --dwz-low-mem-die-limit and --dwz-max-die-limit
82
+ # provide detailed limits. See dwz(1) -l and -L option for details.
83
+ #
84
+ -# If --build-id-seed VERSION-RELEASE is given then debugedit is called to
85
+ -# update the build-ids it finds adding the VERSION-RELEASE string as
86
+ -# seed to recalculate the build-id hash. This makes sure the
87
+ -# build-ids in the ELF files are unique between versions and releases
88
+ -# of the same package.
89
+ +# If --build-id-seed SEED is given then debugedit is called to
90
+ +# update the build-ids it finds adding the SEED as seed to recalculate
91
+ +# the build-id hash. This makes sure the build-ids in the ELF files
92
+ +# are unique between versions and releases of the same package.
93
+ +# (Use --build-id-seed "%{VERSION}-%{RELEASE}".)
94
+ +#
95
+ +# If --unique-debug-suffix SUFFIX is given then the debug files created
96
+ +# for <FILE> will be named <FILE>-<SUFFIX>.debug. This makes sure .debug
97
+ +# are unique between package version, release and architecture.
98
+ +# (Use --unique-debug-suffix "-%{VERSION}-%{RELEASE}.%{_arch}".)
99
+ +#
100
+ +# If --unique-debug-src-base BASE is given then the source directory
101
+ +# will be called /usr/debug/src/<BASE>. This makes sure the debug source
102
+ +# directories are unique between package version, release and architecture.
103
+ +# (Use --unique-debug-src-base "%{name}-%{VERSION}-%{RELEASE}.%{_arch}".)
104
+ #
105
+ # All file names in switches are relative to builddir (. if not given).
106
+ #
file modified
+4 -0
rpm.spec CHANGED
@@ -111,6 +111,9 @@ Patch291: find-debuginfo-filter-built-ins.patch
111
111
# Don't create dwz multi file if there is only one .debug.
112
112
Patch292: find-debuginfo-dwz-multi.patch
113
113
114
+ # Update find-debuginfo.sh options and macros documentation.
115
+ Patch293: find-debuginfo-and-macro-docs.patch
116
+
114
117
# OpenSSL backend
115
118
Patch300: 0001-Add-OpenSSL-support-for-digest-and-signatures.patch
116
119
@@ -624,6 +627,7 @@ exit 0
624
627
- Add debugedit-prefix.patch.
625
628
- Add find-debuginfo-filter-built-ins.patch.
626
629
- Add find-debuginfo-dwz-multi.patch.
630
+ - Add find-debuginfo-and-macro-docs.patch.
627
631
628
632
* Wed Jun 28 2017 Mark Wielaard <mjw@fedoraproject.org> - 4.13.0.1-27
629
633
- Add find-debuginfo-split-traversal-and-extraction-fix.patch (#1465170)