2a1787 - fix font provide generation on filenames with whitespace (#491510)

Authored and Committed by Panu Matilainen 15 years ago
    - fix font provide generation on filenames with whitespace (#491510)
    
        
file modified
+3 -1
fontconfig.prov CHANGED
@@ -16,4 +16,6 @@ fcquery=/usr/bin/fc-query
16
16
17
17
# filter out anything outside main fontconfig path
18
18
grep /usr/share/fonts/ |
19
- xargs $fcquery --format '%{=pkgkit}' 2> /dev/null
19
+ while read fn; do
20
+ $fcquery --format '%{=pkgkit}' "${fn}" 2> /dev/null
21
+ done
file modified
+4 -1
rpm.spec CHANGED
@@ -25,7 +25,7 @@
25
25
Summary: The RPM package management system
26
26
Name: rpm
27
27
Version: %{rpmver}
28
- Release: 0.%{snapver}.4%{?dist}
28
+ Release: 0.%{snapver}.5%{?dist}
29
29
Group: System Environment/Base
30
30
Url: http://www.rpm.org/
31
31
Source0: http://rpm.org/releases/testing/%{name}-%{srcver}.tar.bz2
@@ -400,6 +400,9 @@ exit 0
400
400
%doc doc/librpm/html/*
401
401
402
402
%changelog
403
+ * Mon Mar 23 2009 Panu Matilainen <pmatilai@redhat.com> - 4.7.0-0.beta1.5
404
+ - fix font provide generation on filenames with whitespace (#491510)
405
+
403
406
* Thu Mar 12 2009 Panu Matilainen <pmatilai@redhat.com> - 4.7.0-0.beta1.4
404
407
- handle RSA V4 signatures (#436812)
405
408
- add alpha arch ISA-bits