0d875c - updated fontconfig provide script - fc-query does all the hard work now

Authored and Committed by Panu Matilainen 15 years ago
    - updated fontconfig provide script - fc-query does all the hard work now
    
        
file modified
+1 -19
fontconfig.prov CHANGED
@@ -16,22 +16,4 @@ fcquery=/usr/bin/fc-query
16
16
17
17
# filter out anything outside main fontconfig path
18
18
grep /usr/share/fonts/ |
19
- xargs $fcquery --format '%{family}\n:lang=%{lang}\n' 2> /dev/null |
19
+ xargs $fcquery --format '%{=pkgkit}' 2> /dev/null
20
- while read line; do
21
- case $line in
22
- :lang=*)
23
- langs=${line#:lang=}
24
- OLDIFS=$IFS
25
- IFS='|'
26
- for lang in $langs; do
27
- echo :lang=$lang
28
- done
29
- IFS=$OLDIFS
30
- ;;
31
- *)
32
- echo "$line" | tr 'A-Z_' 'a-z-' | tr -d -c 'a-z0-9-\n'
33
- ;;
34
- esac
35
- done |
36
- sed 's/\(.*\)/Font(\1)/' |
37
- sort -u
file modified
+4 -1
rpm.spec CHANGED
@@ -18,7 +18,7 @@
18
18
Summary: The RPM package management system
19
19
Name: rpm
20
20
Version: %{rpmver}
21
- Release: 2%{?dist}
21
+ Release: 3%{?dist}
22
22
Group: System Environment/Base
23
23
Url: http://www.rpm.org/
24
24
Source0: http://rpm.org/releases/testing/%{name}-%{srcver}.tar.bz2
@@ -373,6 +373,9 @@ exit 0
373
373
%doc doc/librpm/html/*
374
374
375
375
%changelog
376
+ * Mon Feb 16 2009 Panu Matilainen <pmatilai@redhat.com> - 4.6.0-3
377
+ - updated fontconfig provide script - fc-query does all the hard work now
378
+
376
379
* Mon Feb 09 2009 Panu Matilainen <pmatilai@redhat.com> - 4.6.0-2
377
380
- build against db 4.7.x
378
381