%global pkg_name plexus-utils
%{?scl:%scl_package %{pkg_name}}
%{?maven_find_provides_and_requires}
Name: %{?scl_prefix}%{pkg_name}
Version: 3.0.22
Release: 2.2%{?dist}
Summary: Plexus Common Utilities
# ASL 1.1: several files in src/main/java/org/codehaus/plexus/util/
# xpp: src/main/java/org/codehaus/plexus/util/xml/pull directory
# ASL 2.0 and BSD:
# src/main/java/org/codehaus/plexus/util/cli/StreamConsumer
# src/main/java/org/codehaus/plexus/util/cli/StreamPumper
# src/main/java/org/codehaus/plexus/util/cli/Commandline
# Public domain: src/main/java/org/codehaus/plexus/util/TypeFormat.java
# rest is ASL 2.0
License: ASL 1.1 and ASL 2.0 and xpp and BSD and Public Domain
URL: https://github.com/codehaus-plexus/plexus-utils
BuildArch: noarch
Source0: https://github.com/codehaus-plexus/%{pkg_name}/archive/%{pkg_name}-%{version}.tar.gz
Source1: http://apache.org/licenses/LICENSE-2.0.txt
BuildRequires: %{?scl_prefix}maven-local
BuildRequires: %{?scl_prefix}mvn(org.apache.maven.plugins:maven-enforcer-plugin)
%description
The Plexus project seeks to create end-to-end developer tools for
writing applications. At the core is the container, which can be
embedded or for a full scale application server. There are many
reusable components for hibernate, form processing, jndi, i18n,
velocity, etc. Plexus also includes an application server which
is like a J2EE application server, without all the baggage.
%package javadoc
Summary: Javadoc for %{pkg_name}
%description javadoc
Javadoc for %{pkg_name}.
%prep
%setup -q -n %{pkg_name}-%{pkg_name}-%{version}
%{?scl:scl enable %{scl} - <<"EOF"}
set -e -x
cp %{SOURCE1} .
%mvn_file : plexus/utils
%mvn_alias : plexus:plexus-utils
# Generate OSGI info
%pom_xpath_inject "pom:project" "bundle"
%pom_xpath_inject "pom:build/pom:plugins" "
org.apache.felix
maven-bundle-plugin
true
<_nouses>true
org.codehaus.plexus.util.*;org.codehaus.plexus.util.cli.*;org.codehaus.plexus.util.cli.shell.*;org.codehaus.plexus.util.dag.*;org.codehaus.plexus.util.introspection.*;org.codehaus.plexus.util.io.*;org.codehaus.plexus.util.reflection.*;org.codehaus.plexus.util.xml.*;org.codehaus.plexus.util.xml.pull.*
"
%{?scl:EOF}
%build
%{?scl:scl enable %{scl} - <<"EOF"}
set -e -x
%mvn_build -f
%{?scl:EOF}
%install
%{?scl:scl enable %{scl} - <<"EOF"}
set -e -x
%mvn_install
%{?scl:EOF}
%files -f .mfiles
%dir %{_mavenpomdir}/plexus
%dir %{_javadir}/plexus
%doc NOTICE.txt LICENSE-2.0.txt
%files javadoc -f .mfiles-javadoc
%doc NOTICE.txt LICENSE-2.0.txt
%changelog
* Mon Feb 08 2016 Michal Srb - 3.0.22-2.2
- Fix BR on maven-local & co.
* Tue Jan 12 2016 Michal Srb - 3.0.22-2.1
- Prepare spec for SCL build
* Tue Jan 12 2016 Fedora Release Engineering - 3.0.22-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
* Tue Jan 12 2016 Michael Simacek - 3.0.22-1
- Update to upstream version 3.0.22
* Mon Jan 11 2016 Michal Srb - 3.0.9-9.11
- maven33 rebuild #2
* Sat Jan 09 2016 Michal Srb - 3.0.9-9.10
- maven33 rebuild
* Fri Jan 16 2015 Michal Srb - 3.0.9-9.9
- Fix directory ownership
* Tue Jan 13 2015 Michael Simacek - 3.0.9-9.8
- Mass rebuild 2015-01-13
* Tue Jan 06 2015 Michael Simacek - 3.0.9-9.7
- Mass rebuild 2015-01-06
* Mon May 26 2014 Mikolaj Izdebski - 3.0.9-9.6
- Mass rebuild 2014-05-26
* Wed Feb 19 2014 Mikolaj Izdebski - 3.0.9-9.5
- Mass rebuild 2014-02-19
* Tue Feb 18 2014 Mikolaj Izdebski - 3.0.9-9.4
- Mass rebuild 2014-02-18
* Mon Feb 17 2014 Mikolaj Izdebski - 3.0.9-9.3
- SCL-ize build-requires
* Thu Feb 13 2014 Mikolaj Izdebski - 3.0.9-9.2
- Rebuild to regenerate auto-requires
* Tue Feb 11 2014 Mikolaj Izdebski - 3.0.9-9.1
- First maven30 software collection build
* Mon Jan 27 2014 Mikolaj Izdebski - 3.0.9-9
- Backport upstream patch for PLXUTILS-161
- Resolves: rhbz#1009412
* Fri Dec 27 2013 Daniel Mach - 3.0.9-8
- Mass rebuild 2013-12-27
* Thu Aug 22 2013 Michal Srb - 3.0.9-7
- Migrate away from mvn-rpmbuild (Resolves: #997480)
* Fri Jun 28 2013 Mikolaj Izdebski - 3.0.9-6
- Rebuild to regenerate API documentation
- Resolves: CVE-2013-1571
* Thu Feb 14 2013 Fedora Release Engineering - 3.0.9-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
* Wed Feb 06 2013 Java SIG - 3.0.9-4
- Update for https://fedoraproject.org/wiki/Fedora_19_Maven_Rebuild
- Replace maven BuildRequires with maven-local
* Mon Nov 26 2012 Stanislav Ochotnicky - 3.0.9-3
- Add license from one Public Domain class
* Fri Nov 23 2012 Stanislav Ochotnicky - 3.0.9-2
- Fix license tag and ASL 2.0 license text
* Wed Oct 10 2012 Alexander Kurtakov 3.0.9-1
- Update to upstream 3.0.9.
* Sat Jul 21 2012 Fedora Release Engineering - 3.0-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
* Sat Jan 14 2012 Fedora Release Engineering - 3.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
* Wed Sep 7 2011 Alexander Kurtakov 3.0-1
- Update to upstream 3.0.
* Mon Feb 28 2011 Stanislav Ochotnicky - 2.0.6-1
- Update to 2.0.6
- Remove obsolete patches
- Use maven 3 to build
* Wed Feb 09 2011 Fedora Release Engineering - 2.0.5-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
* Thu Dec 16 2010 Stanislav Ochotnicky - 2.0.5-2
- Use versionless jars/javadocs
- Use new maven plugin names
- Add compatibility depmap
* Wed May 5 2010 Mary Ellen Foster 2.0.5-1
- Update to 2.0.5
* Fri Feb 12 2010 Mary Ellen Foster 2.0.1-1
- Update to 2.0.1
- Build with maven
* Wed Aug 19 2009 Andrew Overholt 1.4.5-1.2
- Update to 1.4.5 from JPackage and Deepak Bhole
- Remove gcj bits
* Sun Jul 26 2009 Fedora Release Engineering - 0:1.2-4.2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
* Thu Feb 26 2009 Fedora Release Engineering - 0:1.2-3.2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
* Wed Jul 9 2008 Tom "spot" Callaway - 0:1.2-2.2
- fix license tag
- drop repotag
* Thu Aug 23 2007 Ralph Apel - 0:1.4.5-1jpp
- Upgrade to 1.4.5
- Now build with maven2 by default
* Wed Mar 21 2007 Ralph Apel - 0:1.2-2jpp
- Fix build classpath
- Optionally build with maven2
- Add gcj_support option
* Mon Feb 20 2007 Deepak Bhole - 0:1.2-2jpp.1.fc7
- Fix spec per Fedora guidelines
* Fri Jun 16 2006 Ralph Apel - 0:1.2-1jpp
- Upgrade to 1.2
* Wed Jan 04 2006 Fernando Nasser - 0:1.0.4-2jpp
- First JPP 1.7 build
* Mon Nov 07 2005 Ralph Apel - 0:1.0.4-1jpp
- First JPackage build