eaebe4 Add many more missing BRs for misc QEMU features & enable test suite

1 file Authored by Daniel P. Berrange 13 years ago, Committed by Justin M. Forbes 13 years ago,
1 file changed. 25 lines added. 1 lines removed.
    Add many more missing BRs for misc QEMU features & enable test suite
    
        
file modified
+25 -1
qemu.spec CHANGED
@@ -1,7 +1,7 @@
1
1
Summary: QEMU is a FAST! processor emulator
2
2
Name: qemu
3
3
Version: 1.0
4
- Release: 5%{?dist}
4
+ Release: 6%{?dist}
5
5
# Epoch because we pushed a qemu-1.0 package
6
6
Epoch: 2
7
7
License: GPLv2+ and LGPLv2+ and BSD
@@ -115,6 +115,24 @@ BuildRequires: ceph-devel
115
115
# We need both because the 'stap' binary is probed for by configure
116
116
BuildRequires: systemtap
117
117
BuildRequires: systemtap-sdt-devel
118
+ # For smartcard NSS support
119
+ BuildRequires: nss-devel
120
+ # For XFS discard support in raw-posix.c
121
+ BuildRequires: xfsprogs-devel
122
+ # For VNC JPEG support
123
+ BuildRequires: libjpeg-devel
124
+ # For VNC PNG support
125
+ BuildRequires: libpng-devel
126
+ # For uuid generation
127
+ BuildRequires: libuuid-devel
128
+ # For BlueZ device support
129
+ BuildRequires: bluez-libs-devel
130
+ # For Braille device support
131
+ BuildRequires: brlapi-devel
132
+ # For FDT device tree support
133
+ BuildRequires: libfdt-devel
134
+ # For test suite
135
+ BuildRequires: check-devel
118
136
Requires: %{name}-user = %{epoch}:%{version}-%{release}
119
137
Requires: %{name}-system-x86 = %{epoch}:%{version}-%{release}
120
138
Requires: %{name}-system-arm = %{epoch}:%{version}-%{release}
@@ -558,6 +576,8 @@ mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d
558
576
install -m 0644 %{SOURCE10} $RPM_BUILD_ROOT%{_unitdir}
559
577
install -m 0644 %{SOURCE11} $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d
560
578
579
+ %check
580
+ make check
561
581
562
582
%clean
563
583
rm -rf $RPM_BUILD_ROOT
@@ -748,6 +768,10 @@ fi
748
768
%{_mandir}/man1/qemu-img.1*
749
769
750
770
%changelog
771
+ * Mon Feb 13 2012 Daniel P. Berrange <berrange@redhat.com> - 2:1.0-6
772
+ - Add many more missing BRs for misc QEMU features
773
+ - Enable running of test suite during build
774
+
751
775
* Tue Feb 07 2012 Justin M. Forbes <jforbes@redhat.com> - 2:1.0-5
752
776
- Add support for virtio-scsi
753
777