c8a79a add libcacard, -25

Authored and Committed by Alon Levy 12 years ago
    add libcacard, -25
    
    Conflicts:
    	qemu.spec
    
        
1001-libcacard-fix-missing-symbols-in-libcacard.so.patch ADDED
@@ -0,0 +1,25 @@
1
+ From 3bf390b736e7befd0fbcd252ef5ac6dffd26cf03 Mon Sep 17 00:00:00 2001
2
+ From: Alon Levy <alevy@redhat.com>
3
+ Date: Wed, 28 Nov 2012 16:38:43 +0200
4
+ Subject: [PATCH] libcacard: fix missing symbols in libcacard.so
5
+
6
+ ---
7
+ libcacard/Makefile | 2 +-
8
+ 1 file changed, 1 insertion(+), 1 deletion(-)
9
+
10
+ diff --git a/libcacard/Makefile b/libcacard/Makefile
11
+ index 63990b7..58e5731 100644
12
+ --- a/libcacard/Makefile
13
+ +++ b/libcacard/Makefile
14
+ @@ -7,7 +7,7 @@ libcacard_includedir=$(includedir)/cacard
15
+ $(call set-vpath, $(SRC_PATH))
16
+
17
+ # objects linked into a shared library, built with libtool with -fPIC if required
18
+ -QEMU_OBJS=$(oslib-obj-y) qemu-timer-common.o $(trace-obj-y)
19
+ +QEMU_OBJS=$(oslib-obj-y) qemu-timer-common.o iov.o cutils.o qemu-user.o $(trace-obj-y)
20
+ QEMU_OBJS_LIB=$(patsubst %.o,%.lo,$(QEMU_OBJS))
21
+
22
+ QEMU_CFLAGS+=-I../
23
+ --
24
+ 1.8.0
25
+
1002-configure-move-vscclient-binary-under-libcacard.patch ADDED
@@ -0,0 +1,93 @@
1
+ From 373d00412f13f280619fd161e780cd5da5dfc1a3 Mon Sep 17 00:00:00 2001
2
+ From: Alon Levy <alevy@redhat.com>
3
+ Date: Thu, 29 Nov 2012 14:11:19 +0200
4
+ Subject: [PATCH] configure: move vscclient binary under libcacard
5
+
6
+ build rule is in top level Makefile like other tools.
7
+
8
+ build rule also exists in libcacard for installation purposes. This was
9
+ fixed in a better way in 1.3.0-rc2
10
+ ---
11
+ Makefile | 4 ++--
12
+ Makefile.objs | 11 ++++++-----
13
+ configure | 2 +-
14
+ libcacard/Makefile | 6 +++++-
15
+ 4 files changed, 14 insertions(+), 9 deletions(-)
16
+
17
+ diff --git a/Makefile b/Makefile
18
+ index dd11e3c..13c1693 100644
19
+ --- a/Makefile
20
+ +++ b/Makefile
21
+ @@ -168,8 +168,8 @@ qemu-io$(EXESUF): qemu-io.o cmd.o $(tools-obj-y) $(block-obj-y)
22
+
23
+ qemu-bridge-helper$(EXESUF): qemu-bridge-helper.o
24
+
25
+ -vscclient$(EXESUF): $(libcacard-y) $(oslib-obj-y) $(trace-obj-y) $(tools-obj-y) qemu-timer-common.o libcacard/vscclient.o
26
+ - $(call quiet-command,$(CC) $(LDFLAGS) -o $@ $^ $(libcacard_libs) $(LIBS)," LINK $@")
27
+ +libcacard/vscclient$(EXESUF): $(libcacard-y) $(oslib-obj-y) $(trace-obj-y) qemu-timer-common.o iov.o cutils.o qemu-user.o libcacard/vscclient.o
28
+ +libcacard/vscclient$(EXESUF): LIBS += $(libcacard_libs)
29
+
30
+ fsdev/virtfs-proxy-helper$(EXESUF): fsdev/virtfs-proxy-helper.o fsdev/virtio-9p-marshal.o oslib-posix.o $(trace-obj-y)
31
+ fsdev/virtfs-proxy-helper$(EXESUF): LIBS += -lcap
32
+ diff --git a/Makefile.objs b/Makefile.objs
33
+ index 4412757..92d6b4a 100644
34
+ --- a/Makefile.objs
35
+ +++ b/Makefile.objs
36
+ @@ -206,11 +206,12 @@ $(trace-obj-y): $(GENERATED_HEADERS)
37
+ ######################################################################
38
+ # smartcard
39
+
40
+ -libcacard-y += libcacard/cac.o libcacard/event.o
41
+ -libcacard-y += libcacard/vcard.o libcacard/vreader.o
42
+ -libcacard-y += libcacard/vcard_emul_nss.o
43
+ -libcacard-y += libcacard/vcard_emul_type.o
44
+ -libcacard-y += libcacard/card_7816.o
45
+ +libcacard-base-y += cac.o event.o
46
+ +libcacard-base-y += vcard.o vreader.o
47
+ +libcacard-base-y += vcard_emul_nss.o
48
+ +libcacard-base-y += vcard_emul_type.o
49
+ +libcacard-base-y += card_7816.o
50
+ +libcacard-y = $(addprefix libcacard/,$(libcacard-base-y))
51
+
52
+ common-obj-$(CONFIG_SMARTCARD_NSS) += $(libcacard-y)
53
+
54
+ diff --git a/configure b/configure
55
+ index 950912a..64b8aa7 100755
56
+ --- a/configure
57
+ +++ b/configure
58
+ @@ -3073,7 +3073,7 @@ if test "$softmmu" = yes ; then
59
+ fi
60
+ fi
61
+ if test "$smartcard_nss" = "yes" ; then
62
+ - tools="vscclient\$(EXESUF) $tools"
63
+ + tools="libcacard/vscclient\$(EXESUF) $tools"
64
+ fi
65
+ fi
66
+
67
+ diff --git a/libcacard/Makefile b/libcacard/Makefile
68
+ index 9ce3117..88ed064 100644
69
+ --- a/libcacard/Makefile
70
+ +++ b/libcacard/Makefile
71
+ @@ -44,6 +44,10 @@ libcacard.pc: $(libcacard_srcpath)/libcacard.pc.in
72
+ < $(libcacard_srcpath)/libcacard.pc.in > libcacard.pc,\
73
+ " GEN $@")
74
+
75
+ +VSCCLIENT_QEMU_OBJS=$(addprefix ../,$(oslib-obj-y) $(trace-obj-y) qemu-timer-common.o iov.o cutils.o qemu-user.o)
76
+ +vscclient$(EXESUF): $(VSCCLIENT_QEMU_OBJS) $(libcacard-base-y) vscclient.o
77
+ +vscclient$(EXESUF): LIBS += $(libcacard_libs)
78
+ +
79
+ .PHONY: install-libcacard
80
+
81
+ install-libcacard: libcacard.pc libcacard.la vscclient
82
+ @@ -51,7 +55,7 @@ install-libcacard: libcacard.pc libcacard.la vscclient
83
+ $(INSTALL_DIR) "$(DESTDIR)$(libdir)/pkgconfig"
84
+ $(INSTALL_DIR) "$(DESTDIR)$(libcacard_includedir)"
85
+ $(INSTALL_DIR) "$(DESTDIR)$(bindir)"
86
+ - $(LIBTOOL) --mode=install $(INSTALL_PROG) vscclient "$(DESTDIR)$(bindir)"
87
+ + $(LIBTOOL) --mode=install $(INSTALL_PROG) vscclient$(EXESUF) "$(DESTDIR)$(bindir)"
88
+ $(LIBTOOL) --mode=install $(INSTALL_DATA) libcacard.la "$(DESTDIR)$(libdir)"
89
+ $(LIBTOOL) --mode=install $(INSTALL_DATA) libcacard.pc "$(DESTDIR)$(libdir)/pkgconfig"
90
+ for inc in *.h; do \
91
+ --
92
+ 1.8.0.1
93
+
file modified
+56 -2
qemu.spec CHANGED
@@ -120,7 +120,7 @@
120
120
Summary: QEMU is a FAST! processor emulator
121
121
Name: qemu
122
122
Version: 1.2.0
123
- Release: 24%{?dist}
123
+ Release: 25%{?dist}
124
124
# Epoch because we pushed a qemu-1.0 package. AIUI this can't ever be dropped
125
125
Epoch: 2
126
126
License: GPLv2+ and LGPLv2+ and BSD
@@ -493,6 +493,10 @@ Patch804: 0804-wip-hw-qxl-inject-interrupts-in-any-state.patch
493
493
# 38f419f (configure: Fix CONFIG_QEMU_HELPERDIR generation, 2012-10-17)
494
494
Patch805: 0805-configure-Fix-CONFIG_QEMU_HELPERDIR-generation.patch
495
495
496
+ # libcacard
497
+ Patch1001: 1001-libcacard-fix-missing-symbols-in-libcacard.so.patch
498
+ Patch1002: 1002-configure-move-vscclient-binary-under-libcacard.patch
499
+
496
500
BuildRequires: SDL-devel
497
501
BuildRequires: zlib-devel
498
502
BuildRequires: which
@@ -914,6 +918,29 @@ This package contains some diagnostics and debugging tools for KVM,
914
918
such as kvm_stat.
915
919
%endif
916
920
921
+ %package -n libcacard
922
+ Summary: Common Access Card (CAC) Emulation
923
+ Group: Development/Libraries
924
+
925
+ %description -n libcacard
926
+ Common Access Card (CAC) emulation library.
927
+
928
+ %package -n libcacard-tools
929
+ Summary: CAC Emulation tools
930
+ Group: Development/Libraries
931
+ Requires: libcacard = %{epoch}:%{version}-%{release}
932
+
933
+ %description -n libcacard-tools
934
+ CAC emulation tools.
935
+
936
+ %package -n libcacard-devel
937
+ Summary: CAC Emulation devel
938
+ Group: Development/Libraries
939
+ Requires: libcacard = %{epoch}:%{version}-%{release}
940
+
941
+ %description -n libcacard-devel
942
+ CAC emulation development files.
943
+
917
944
%prep
918
945
%setup -q -n qemu-kvm-%{version}
919
946
@@ -1239,6 +1266,10 @@ such as kvm_stat.
1239
1266
%patch804 -p1
1240
1267
%patch805 -p1
1241
1268
1269
+ # libcacard
1270
+ %patch1001 -p1
1271
+ %patch1002 -p1
1272
+
1242
1273
%build
1243
1274
%if %{with kvmonly}
1244
1275
buildarch="%{kvm_target}-softmmu"
@@ -1272,6 +1303,7 @@ sed -i.debug 's/"-g $CFLAGS"/"$CFLAGS"/g' configure
1272
1303
dobuild() {
1273
1304
./configure \
1274
1305
--prefix=%{_prefix} \
1306
+ --libdir=%{_libdir} \
1275
1307
--sysconfdir=%{_sysconfdir} \
1276
1308
--interp-prefix=%{_prefix}/qemu-%%M \
1277
1309
--audio-drv-list=pa,sdl,alsa,oss \
@@ -1305,6 +1337,8 @@ dobuild() {
1305
1337
echo "==="
1306
1338
1307
1339
make V=1 %{?_smp_mflags} $buildldflags
1340
+ make V=1 %{?_smp_mflags} $buildldflags libcacard.la
1341
+ make V=1 %{?_smp_mflags} $buildldflags libcacard/vscclient
1308
1342
}
1309
1343
1310
1344
# This is kind of confusing. We run ./configure + make twice here to
@@ -1511,6 +1545,9 @@ rm $RPM_BUILD_ROOT%{_bindir}/qemu-ga
1511
1545
rm $RPM_BUILD_ROOT%{_unitdir}/qemu-guest-agent.service
1512
1546
rm $RPM_BUILD_ROOT%{_udevdir}/99-qemu-guest-agent.rules
1513
1547
%endif
1548
+ make %{?_smp_mflags} $buildldflags DESTDIR=$RPM_BUILD_ROOT install-libcacard
1549
+ find $RPM_BUILD_ROOT -name '*.la' -or -name '*.a' | xargs rm -f
1550
+ find $RPM_BUILD_ROOT -name "libcacard.so*" -exec chmod +x \{\} \;
1514
1551
1515
1552
%check
1516
1553
make check
@@ -1596,7 +1633,6 @@ fi
1596
1633
%doc %{qemudocdir}/LICENSE
1597
1634
%dir %{_datadir}/%{name}/
1598
1635
%{_datadir}/%{name}/keymaps/
1599
- %{_bindir}/vscclient
1600
1636
%{_mandir}/man1/qemu.1*
1601
1637
%{_mandir}/man1/virtfs-proxy-helper.1*
1602
1638
%{_bindir}/virtfs-proxy-helper
@@ -1855,7 +1891,25 @@ fi
1855
1891
%{_mandir}/man8/qemu-nbd.8*
1856
1892
%endif
1857
1893
1894
+
1895
+ %files -n libcacard
1896
+ %defattr(-,root,root,-)
1897
+ %{_libdir}/libcacard.so.*
1898
+
1899
+ %files -n libcacard-tools
1900
+ %defattr(-,root,root,-)
1901
+ %{_bindir}/vscclient
1902
+
1903
+ %files -n libcacard-devel
1904
+ %defattr(-,root,root,-)
1905
+ %{_includedir}/cacard
1906
+ %{_libdir}/libcacard.so
1907
+ %{_libdir}/pkgconfig/libcacard.pc
1908
+
1858
1909
%changelog
1910
+ * Wed Nov 28 2012 Alon Levy <alevy@redhat.com> - 2:1.2.0-25
1911
+ * Merge libcacard into qemu, since they both use the same sources now.
1912
+
1859
1913
* Thu Nov 22 2012 Paolo Bonzini <pbonzini@redhat.com> - 2:1.2.0-24
1860
1914
- Move vscclient to qemu-common, qemu-nbd to qemu-img
1861
1915