bc9e71 Re-enable cris and sparc

Authored and Committed by Justin M. Forbes 14 years ago
    Re-enable cris and sparc
    
        
qemu-fix-non-PCI-target-build.patch ADDED
@@ -0,0 +1,53 @@
1
+ commit 1a8364456c2f3946b4feb8fc78eaf00d974f4c03
2
+ Author: Jan Kiszka <jan.kiszka@siemens.com>
3
+ Date: Wed Feb 23 09:28:53 2011 +0100
4
+
5
+ qemu-kvm: Fix non-PCI target build
6
+
7
+ Replace obsolete qemu-kvm.h with kvm.h in pci.c and build that module
8
+ just like upstream does. This fixes non-x86 targets which have no PCI
9
+ support.
10
+
11
+ Signed-off-by: Jan Kiszka <jan.kiszka@siemens.com>
12
+ Signed-off-by: Avi Kivity <avi@redhat.com>
13
+
14
+ diff --git a/Makefile.objs b/Makefile.objs
15
+ index f5702eb..3ec7121 100644
16
+ --- a/Makefile.objs
17
+ +++ b/Makefile.objs
18
+ @@ -170,7 +170,7 @@ hw-obj-y =
19
+ hw-obj-y += loader.o
20
+ hw-obj-$(CONFIG_VIRTIO) += virtio.o virtio-console.o
21
+ hw-obj-y += fw_cfg.o
22
+ -hw-obj-$(CONFIG_PCI) += pci_bridge.o
23
+ +hw-obj-$(CONFIG_PCI) += pci.o pci_bridge.o
24
+ hw-obj-$(CONFIG_PCI) += msix.o msi.o
25
+ hw-obj-$(CONFIG_PCI) += pci_host.o pcie_host.o
26
+ hw-obj-$(CONFIG_PCI) += ioh3420.o xio3130_upstream.o xio3130_downstream.o
27
+ diff --git a/Makefile.target b/Makefile.target
28
+ index 6e9a024..23367eb 100644
29
+ --- a/Makefile.target
30
+ +++ b/Makefile.target
31
+ @@ -195,7 +195,7 @@ endif #CONFIG_BSD_USER
32
+ # System emulator target
33
+ ifdef CONFIG_SOFTMMU
34
+
35
+ -obj-y = arch_init.o cpus.o monitor.o pci.o machine.o gdbstub.o vl.o balloon.o
36
+ +obj-y = arch_init.o cpus.o monitor.o machine.o gdbstub.o vl.o balloon.o
37
+ # virtio has to be here due to weird dependency between PCI and virtio-net.
38
+ # need to fix this properly
39
+ obj-$(CONFIG_NO_PCI) += pci-stub.o
40
+ diff --git a/hw/pci.c b/hw/pci.c
41
+ index 0c44939..1f6cebe 100644
42
+ --- a/hw/pci.c
43
+ +++ b/hw/pci.c
44
+ @@ -29,8 +29,8 @@
45
+ #include "net.h"
46
+ #include "sysemu.h"
47
+ #include "loader.h"
48
+ -#include "qemu-kvm.h"
49
+ #include "hw/pc.h"
50
+ +#include "kvm.h"
51
+ #include "device-assignment.h"
52
+ #include "qemu-objects.h"
53
+ #include "range.h"
file modified
+22 -16
qemu.spec CHANGED
@@ -1,7 +1,7 @@
1
1
Summary: QEMU is a FAST! processor emulator
2
2
Name: qemu
3
3
Version: 0.14.0
4
- Release: 1%{?dist}
4
+ Release: 2%{?dist}
5
5
# Epoch because we pushed a qemu-1.0 package
6
6
Epoch: 2
7
7
License: GPLv2+ and LGPLv2+ and BSD
@@ -37,6 +37,8 @@ Source8: ksmtuned.conf
37
37
# with F-13/
38
38
Patch00: pc-add-a-Fedora-13-machine-type-for-backward-compat.patch
39
39
40
+ Patch01: qemu-fix-non-PCI-target-build.patch
41
+
40
42
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
41
43
BuildRequires: SDL-devel zlib-devel which texi2html gnutls-devel cyrus-sasl-devel
42
44
BuildRequires: libaio-devel
@@ -53,7 +55,7 @@ Requires: %{name}-user = %{epoch}:%{version}-%{release}
53
55
Requires: %{name}-system-x86 = %{epoch}:%{version}-%{release}
54
56
Requires: %{name}-system-sparc = %{epoch}:%{version}-%{release}
55
57
Requires: %{name}-system-arm = %{epoch}:%{version}-%{release}
56
- # Requires: %{name}-system-cris = %{epoch}:%{version}-%{release}
58
+ Requires: %{name}-system-cris = %{epoch}:%{version}-%{release}
57
59
Requires: %{name}-system-sh4 = %{epoch}:%{version}-%{release}
58
60
Requires: %{name}-system-m68k = %{epoch}:%{version}-%{release}
59
61
Requires: %{name}-system-mips = %{epoch}:%{version}-%{release}
@@ -188,15 +190,15 @@ emulation speed by using dynamic translation.
188
190
189
191
This package provides the system emulator for mips
190
192
191
- # %package system-cris
192
- # Summary: QEMU system emulator for cris
193
- # Group: Development/Tools
194
- # Requires: %{name}-common = %{epoch}:%{version}-%{release}
195
- # %description system-cris
196
- # QEMU is a generic and open source processor emulator which achieves a good
197
- # emulation speed by using dynamic translation.
193
+ %package system-cris
194
+ Summary: QEMU system emulator for cris
195
+ Group: Development/Tools
196
+ Requires: %{name}-common = %{epoch}:%{version}-%{release}
197
+ %description system-cris
198
+ QEMU is a generic and open source processor emulator which achieves a good
199
+ emulation speed by using dynamic translation.
198
200
199
- # This package provides the system emulator for cris
201
+ This package provides the system emulator for cris
200
202
201
203
%package system-m68k
202
204
Summary: QEMU system emulator for m68k
@@ -233,6 +235,7 @@ such as kvm_stat.
233
235
%setup -q -n qemu-kvm-%{version}
234
236
235
237
%patch00 -p1
238
+ %patch01 -p1
236
239
237
240
%build
238
241
# By default we build everything, but allow x86 to build a minimal version
@@ -240,9 +243,9 @@ such as kvm_stat.
240
243
%if %{with_x86only}
241
244
buildarch="i386-softmmu x86_64-softmmu i386-linux-user x86_64-linux-user"
242
245
%else
243
- buildarch="i386-softmmu x86_64-softmmu arm-softmmu m68k-softmmu \
246
+ buildarch="i386-softmmu x86_64-softmmu arm-softmmu cris-softmmu m68k-softmmu \
244
247
mips-softmmu mipsel-softmmu mips64-softmmu mips64el-softmmu ppc-softmmu \
245
- ppcemb-softmmu ppc64-softmmu sh4-softmmu sh4eb-softmmu \
248
+ ppcemb-softmmu ppc64-softmmu sh4-softmmu sh4eb-softmmu sparc-softmmu \
246
249
i386-linux-user x86_64-linux-user alpha-linux-user arm-linux-user \
247
250
armeb-linux-user cris-linux-user m68k-linux-user mips-linux-user \
248
251
mipsel-linux-user ppc-linux-user ppc64-linux-user ppc64abi32-linux-user \
@@ -521,7 +524,7 @@ fi
521
524
522
525
%files system-sparc
523
526
%defattr(-,root,root)
524
- # %{_bindir}/qemu-system-sparc
527
+ %{_bindir}/qemu-system-sparc
525
528
%{_datadir}/%{name}/openbios-sparc32
526
529
%{_datadir}/%{name}/openbios-sparc64
527
530
@@ -545,9 +548,9 @@ fi
545
548
%{_datadir}/%{name}/bamboo.dtb
546
549
%{_datadir}/%{name}/ppc_rom.bin
547
550
548
- # %files system-cris
549
- # %defattr(-,root,root)
550
- # %{_bindir}/qemu-system-cris
551
+ %files system-cris
552
+ %defattr(-,root,root)
553
+ %{_bindir}/qemu-system-cris
551
554
552
555
%files system-m68k
553
556
%defattr(-,root,root)
@@ -567,6 +570,9 @@ fi
567
570
%{_mandir}/man1/qemu-img.1*
568
571
569
572
%changelog
573
+ * Wed Mar 02 2011 Justin M. Forbes <jforbes@redhat.com> - 2:0.14.0-2
574
+ - Re-enable sparc and cris builds
575
+
570
576
* Thu Feb 24 2011 Justin M. Forbes <jforbes@redhat.com> - 2:0.14.0-1
571
577
- Update to 0.14.0 release
572
578