b51ebd Merge branch 'master' of ssh://pkgs.fedoraproject.org/qemu

Merged and Committed by Justin M. Forbes 13 years ago
    Merge branch 'master' of ssh://pkgs.fedoraproject.org/qemu
    
    Conflicts:
    	qemu.spec
    
        
qemu-kvm-default-accelerator.patch ADDED
@@ -0,0 +1,18 @@
1
+ diff --git a/vl.c b/vl.c
2
+ index 7ae549e..28fd2f3 100644
3
+ --- a/vl.c
4
+ +++ b/vl.c
5
+ @@ -1953,8 +1953,13 @@ static int configure_accelerator(void)
6
+ }
7
+
8
+ if (p == NULL) {
9
+ +#ifdef CONFIG_KVM
10
+ /* Use the default "accelerator", kvm */
11
+ p = "kvm";
12
+ +#else
13
+ + /* Use the default "accelerator", tcg */
14
+ + p = "tcg";
15
+ +#endif
16
+ }
17
+
18
+ while (!accel_initalised && *p != '\0') {
file modified
+8 -0
qemu.spec CHANGED
@@ -67,6 +67,9 @@ Patch23: 0023-qxl-add-QXL_IO_FLUSH_-SURFACES-RELEASE-for-guest-S3-.patch
67
67
Patch24: 0024-qxl-bump-pci-rev.patch
68
68
Patch25: 0025-virtio-serial-bus-replay-guest_open-on-migration.patch
69
69
70
+ # Fix for default accelerator in non-KVM builds
71
+ Patch100: qemu-kvm-default-accelerator.patch
72
+
70
73
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
71
74
BuildRequires: SDL-devel zlib-devel which texi2html gnutls-devel cyrus-sasl-devel
72
75
BuildRequires: libaio-devel
@@ -265,6 +268,8 @@ such as kvm_stat.
265
268
%patch24 -p1
266
269
%patch25 -p1
267
270
271
+ %patch100 -p1
272
+
268
273
%build
269
274
# By default we build everything, but allow x86 to build a minimal version
270
275
# with only similar arch target support
@@ -577,6 +582,9 @@ fi
577
582
* Thu Aug 04 2011 Justin M. Forbes <jforbes@redhat.com> - 2:0.15.0-0.3.201108040af4922
578
583
- Update to 0.15.0-rc1 as we prepare for 0.15.0 release
579
584
585
+ * Thu Aug 4 2011 Daniel P. Berrange <berrange@redhat.com> - 2:0.15.0-0.3.2011072859fadcc
586
+ - Fix default accelerator for non-KVM builds (rhbz #724814)
587
+
580
588
* Thu Jul 28 2011 Justin M. Forbes <jforbes@redhat.com> - 2:0.15.0-0.1.2011072859fadcc
581
589
- Update to 0.15.0-rc0 as we prepare for 0.15.0 release
582
590