990c3a Updates from upstream towards 0.13 stable, fix deps

Authored and Committed by Justin M. Forbes 14 years ago
    Updates from upstream towards 0.13 stable, fix deps
    
        
file modified
+1 -0
.gitignore CHANGED
@@ -1 +1,2 @@
1
1
qemu-kvm-0.13.0-b81fe95.tar.gz
2
+ qemu-kvm-0.13.0-25fdf4a.tar.gz
file modified
+14 -15
qemu.spec CHANGED
@@ -1,9 +1,9 @@
1
- %define githead b81fe95
1
+ %define githead 25fdf4a
2
2
3
3
Summary: QEMU is a FAST! processor emulator
4
4
Name: qemu
5
5
Version: 0.13.0
6
- Release: 0.2.20100727git%{githead}%{?dist}
6
+ Release: 0.3.20100809git%{githead}%{?dist}
7
7
# Epoch because we pushed a qemu-1.0 package
8
8
Epoch: 2
9
9
License: GPLv2+ and LGPLv2+ and BSD
@@ -39,8 +39,6 @@ Source6: ksmtuned.init
39
39
Source7: ksmtuned
40
40
Source8: ksmtuned.conf
41
41
42
- Patch57: avoid-llseek.patch
43
-
44
42
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
45
43
BuildRequires: SDL-devel zlib-devel which texi2html gnutls-devel cyrus-sasl-devel
46
44
BuildRequires: libaio-devel
@@ -49,6 +47,7 @@ BuildRequires: pciutils-devel
49
47
BuildRequires: pulseaudio-libs-devel
50
48
BuildRequires: ncurses-devel
51
49
BuildRequires: texinfo
50
+ BuildRequires: spice-protocol spice-server-devel
52
51
Requires: %{name}-user = %{epoch}:%{version}-%{release}
53
52
Requires: %{name}-system-x86 = %{epoch}:%{version}-%{release}
54
53
Requires: %{name}-system-sparc = %{epoch}:%{version}-%{release}
@@ -132,7 +131,7 @@ Provides: kvm = 85
132
131
Obsoletes: kvm < 85
133
132
Requires: vgabios
134
133
Requires: seabios-bin
135
- Requires: /usr/share/gpxe/e1000-0x100e.rom
134
+ Requires: /usr/share/gpxe/8086100e.rom.rom
136
135
Requires: /usr/share/gpxe/rtl8029.rom
137
136
Requires: /usr/share/gpxe/pcnet32.rom
138
137
Requires: /usr/share/gpxe/rtl8139.rom
@@ -226,7 +225,7 @@ Group: Development/Tools
226
225
227
226
%description kvm-tools
228
227
This package contains some diagnostics and debugging tools for KVM,
229
- such as kvmtrace and kvm_stat.
228
+ such as kvm_stat.
230
229
%endif
231
230
232
231
%prep
@@ -264,6 +263,7 @@ buildldflags="VL_LDFLAGS=-Wl,--build-id"
264
263
--disable-strip \
265
264
--extra-ldflags=$extraldflags \
266
265
--extra-cflags="$RPM_OPT_FLAGS" \
266
+ --enable-spice \
267
267
--disable-xen
268
268
269
269
echo "config-host.mak contents:"
@@ -275,10 +275,6 @@ make V=1 %{?_smp_mflags} $buildldflags
275
275
cp -a x86_64-softmmu/qemu-system-x86_64 qemu-kvm
276
276
make clean
277
277
278
- cd kvm/test
279
- ./configure --prefix=%{_prefix} --kerneldir=$(pwd)/../kernel/
280
- make kvmtrace
281
- cd ../../
282
278
%endif
283
279
284
280
./configure \
@@ -292,6 +288,7 @@ cd ../../
292
288
--extra-ldflags=$extraldflags \
293
289
--extra-cflags="$RPM_OPT_FLAGS" \
294
290
--disable-xen \
291
+ --enable-spice \
295
292
--disable-werror
296
293
297
294
echo "config-host.mak contents:"
@@ -318,8 +315,6 @@ mkdir -p $RPM_BUILD_ROOT%{_datadir}/%{name}
318
315
mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d
319
316
320
317
install -m 0755 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/modules/kvm.modules
321
- install -m 0755 kvm/test/kvmtrace $RPM_BUILD_ROOT%{_bindir}/
322
- install -m 0755 kvm/test/kvmtrace_format $RPM_BUILD_ROOT%{_bindir}/
323
318
install -m 0755 kvm/kvm_stat $RPM_BUILD_ROOT%{_bindir}/
324
319
install -m 0755 qemu-kvm $RPM_BUILD_ROOT%{_bindir}/
325
320
install -m 0644 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d
@@ -360,7 +355,7 @@ pxe_link() {
360
355
ln -s ../gpxe/$2.rom %{buildroot}%{_datadir}/%{name}/pxe-$1.bin
361
356
}
362
357
363
- pxe_link e1000 e1000-0x100e
358
+ pxe_link e1000 8086100e
364
359
pxe_link ne2k_pci rtl8029
365
360
pxe_link pcnet pcnet32
366
361
pxe_link rtl8139 rtl8139
@@ -494,8 +489,6 @@ fi
494
489
%{_sysconfdir}/qemu/target-*
495
490
%files kvm-tools
496
491
%defattr(-,root,root,-)
497
- %{_bindir}/kvmtrace
498
- %{_bindir}/kvmtrace_format
499
492
%{_bindir}/kvm_stat
500
493
%endif
501
494
%if !%{with_x86only}
@@ -541,6 +534,12 @@ fi
541
534
%{_mandir}/man1/qemu-img.1*
542
535
543
536
%changelog
537
+ * Mon Aug 9 2010 Justin M. Forbes <jforbes@redhat.com> - 2:0.13.0-0.3.20100809git25fdf4a
538
+ - Updates from upstream towards 0.13 stable
539
+ - Fix requires on gpxe
540
+ - enable spice now that buildreqs are in the repository.
541
+ - ksmtrace has moved to a separate upstream package
542
+
544
543
* Tue Jul 27 2010 Justin M. Forbes <jforbes@redhat.com> - 2:0.13.0-0.2.20100727gitb81fe95
545
544
- add texinfo buildreq for manpages.
546
545
file modified
+1 -1
sources CHANGED
@@ -1 +1 @@
1
- 940a1af9eafdebcf7c746b837fee3613 qemu-kvm-0.13.0-b81fe95.tar.gz
1
+ 7f083a69c98b6b57bb2a4d52a7b50a72 qemu-kvm-0.13.0-25fdf4a.tar.gz