467b99 Add some test fixes

Authored and Committed by crobinso 2 years ago
    Add some test fixes
    
    Signed-off-by: Cole Robinson <crobinso@redhat.com>
    
        
0008-Disable-flakey-dbus-display-test.patch ADDED
@@ -0,0 +1,36 @@
1
+ From: Cole Robinson <crobinso@redhat.com>
2
+ Date: Sat, 4 Jun 2022 20:28:58 -0400
3
+ Subject: [PATCH] Disable flakey dbus-display-test
4
+ Content-type: text/plain
5
+
6
+ Signed-off-by: Cole Robinson <crobinso@redhat.com>
7
+ ---
8
+ tests/qtest/meson.build | 8 --------
9
+ 1 file changed, 8 deletions(-)
10
+
11
+ diff --git a/tests/qtest/meson.build b/tests/qtest/meson.build
12
+ index d25f82bb5a..d085604727 100644
13
+ --- a/tests/qtest/meson.build
14
+ +++ b/tests/qtest/meson.build
15
+ @@ -94,10 +94,6 @@ qtests_i386 = \
16
+ 'test-filter-redirector'
17
+ ]
18
+
19
+ -if dbus_display
20
+ - qtests_i386 += ['dbus-display-test']
21
+ -endif
22
+ -
23
+ dbus_daemon = find_program('dbus-daemon', required: false)
24
+ if dbus_daemon.found() and config_host.has_key('GDBUS_CODEGEN')
25
+ # Temporarily disabled due to Patchew failures:
26
+ @@ -298,10 +294,6 @@ qtests = {
27
+ 'vmgenid-test': files('boot-sector.c', 'acpi-utils.c'),
28
+ }
29
+
30
+ -if dbus_display
31
+ -qtests += {'dbus-display-test': [dbus_display1, gio]}
32
+ -endif
33
+ -
34
+ qtest_executables = {}
35
+ foreach dir : target_dirs
36
+ if not dir.endswith('-softmmu')
0009-Fix-iotests-with-modules-and-qemu-system-s390x.patch ADDED
@@ -0,0 +1,32 @@
1
+ From: Cole Robinson <crobinso@redhat.com>
2
+ Date: Sat, 4 Jun 2022 20:29:46 -0400
3
+ Subject: [PATCH] Fix iotests with modules and qemu-system-s390x
4
+ Content-type: text/plain
5
+
6
+ Signed-off-by: Cole Robinson <crobinso@redhat.com>
7
+ ---
8
+ tests/qemu-iotests/common.rc | 4 ++--
9
+ 2 files changed, 3 insertions(+), 3 deletions(-)
10
+
11
+ diff --git a/tests/qemu-iotests/common.rc b/tests/qemu-iotests/common.rc
12
+ index 227e0a5be9..97f8e0a15f 100644
13
+ --- a/tests/qemu-iotests/common.rc
14
+ +++ b/tests/qemu-iotests/common.rc
15
+ @@ -975,7 +975,7 @@ _require_large_file()
16
+ #
17
+ _require_devices()
18
+ {
19
+ - available=$($QEMU -M none -device help | \
20
+ + available=$($QEMU -M none -device help 2> /dev/null | \
21
+ grep ^name | sed -e 's/^name "//' -e 's/".*$//')
22
+ for device
23
+ do
24
+ @@ -987,7 +987,7 @@ _require_devices()
25
+
26
+ _require_one_device_of()
27
+ {
28
+ - available=$($QEMU -M none -device help | \
29
+ + available=$($QEMU -M none -device help 2> /dev/null | \
30
+ grep ^name | sed -e 's/^name "//' -e 's/".*$//')
31
+ for device
32
+ do
file modified
+2 -0
qemu.spec CHANGED
@@ -354,6 +354,8 @@ Patch0004: 0004-virtio-scsi-clean-up-virtio_scsi_handle_event_vq.patch
354
354
Patch0005: 0005-virtio-scsi-clean-up-virtio_scsi_handle_ctrl_vq.patch
355
355
Patch0006: 0006-virtio-scsi-clean-up-virtio_scsi_handle_cmd_vq.patch
356
356
Patch0007: 0007-virtio-scsi-move-request-related-items-from-.h-to-.c.patch
357
+ Patch0008: 0008-Disable-flakey-dbus-display-test.patch
358
+ Patch0009: 0009-Fix-iotests-with-modules-and-qemu-system-s390x.patch
357
359
358
360
BuildRequires: meson >= %{meson_version}
359
361
BuildRequires: zlib-devel