f84b6a import python-rpm-generators-5-8.el8

Authored and Committed by centosrcm 2 years ago
    import python-rpm-generators-5-8.el8
    
        
file modified
+2 -2
SOURCES/pythondeps.sh CHANGED
@@ -23,8 +23,8 @@ case $1 in
23
23
# /PATH/OF/BUILDROOT/usr/lib64/pythonMAJOR.MINOR/
24
24
# generating (uniqely) lines of the form:
25
25
# python(abi) = MAJOR.MINOR
26
- grep "/usr/lib[^/]*/python.\../.*" \
27
- | sed -e "s|.*/usr/lib[^/]*/python\(.\..\)/.*|python(abi) = \1|g" \
26
+ grep -E "/usr/lib[^/]*/python[[:digit:]]+\.[[:digit:]]+/.*" \
27
+ | sed -Ee "s|.*/usr/lib[^/]*/python([[:digit:]]+\.[[:digit:]]+)/.*|python(abi) = \1|g" \
28
28
| sort | uniq
29
29
;;
30
30
esac
file modified
+1 -1
SOURCES/pythondistdeps.py CHANGED
@@ -125,7 +125,7 @@ for f in files:
125
125
# Try to parse the Python version from the path the metadata
126
126
# resides at (e.g. /usr/lib/pythonX.Y/site-packages/...)
127
127
import re
128
- res = re.search(r"/python(?P<pyver>\d+\.\d)/", path_item)
128
+ res = re.search(r"/python(?P<pyver>\d+\.\d+)/", path_item)
129
129
if res:
130
130
dist.py_version = res.group('pyver')
131
131
else:
SPECS/python-rpm-generators.spec CHANGED
@@ -5,7 +5,7 @@
5
5
Name: python-rpm-generators
6
6
Summary: Dependency generators for Python RPMs
7
7
Version: 5
8
- Release: 7%{?dist}
8
+ Release: 8%{?dist}
9
9
10
10
# Originally all those files were part of RPM, so license is kept here
11
11
License: GPLv2+
@@ -53,6 +53,10 @@ install -Dpm0755 -t %{buildroot}%{_rpmconfigdir} pythondeps.sh pythondistdeps.py
53
53
%{_rpmconfigdir}/pythondistdeps.py
54
54
55
55
%changelog
56
+ * Mon Nov 14 2022 Charalampos Stratakis <cstratak@redhat.com> - 5-8
57
+ - Fix the pythondeps.sh and pythondistdeps.py scripts for multiple digits python versions
58
+ - Resolves: rhbz#2143990
59
+
56
60
* Tue Jun 15 2021 Tomas Orsava <torsava@redhat.com> - 5-7
57
61
- Do not parse nested dist/egg-info metadata
58
62
- Resolves: rhbz#1916172