153bb5 import openjpeg2-2.3.1-6.el8

Authored and Committed by centosrcm 4 years ago
    import openjpeg2-2.3.1-6.el8
    
        
SOURCES/openjpeg2_CVE-2020-6851.patch ADDED
@@ -0,0 +1,32 @@
1
+ From 36dc8ffca8c085423149bb028da5688936c88c68 Mon Sep 17 00:00:00 2001
2
+ From: Even Rouault <even.rouault@spatialys.com>
3
+ Date: Sat, 11 Jan 2020 01:51:19 +0100
4
+ Subject: [PATCH] opj_j2k_update_image_dimensions(): reject images whose
5
+ coordinates are beyond INT_MAX (fixes #1228)
6
+
7
+ ---
8
+ src/lib/openjp2/j2k.c | 8 ++++++++
9
+ 1 file changed, 8 insertions(+)
10
+
11
+ diff --git a/src/lib/openjp2/j2k.c b/src/lib/openjp2/j2k.c
12
+ index 4169cd6..9e9a30f 100644
13
+ --- a/src/lib/openjp2/j2k.c
14
+ +++ b/src/lib/openjp2/j2k.c
15
+ @@ -9236,6 +9236,14 @@ static OPJ_BOOL opj_j2k_update_image_dimensions(opj_image_t* p_image,
16
+ l_img_comp = p_image->comps;
17
+ for (it_comp = 0; it_comp < p_image->numcomps; ++it_comp) {
18
+ OPJ_INT32 l_h, l_w;
19
+ + if (p_image->x0 > (OPJ_UINT32)INT_MAX ||
20
+ + p_image->y0 > (OPJ_UINT32)INT_MAX ||
21
+ + p_image->x1 > (OPJ_UINT32)INT_MAX ||
22
+ + p_image->y1 > (OPJ_UINT32)INT_MAX) {
23
+ + opj_event_msg(p_manager, EVT_ERROR,
24
+ + "Image coordinates above INT_MAX are not supported\n");
25
+ + return OPJ_FALSE;
26
+ + }
27
+
28
+ l_img_comp->x0 = (OPJ_UINT32)opj_int_ceildiv((OPJ_INT32)p_image->x0,
29
+ (OPJ_INT32)l_img_comp->dx);
30
+ --
31
+ 2.21.1
32
+
SOURCES/openjpeg2_CVE-2020-8112.patch ADDED
@@ -0,0 +1,46 @@
1
+ From dc315cbd2d8582498c885a55ea73ecc84634168b Mon Sep 17 00:00:00 2001
2
+ From: Even Rouault <even.rouault@spatialys.com>
3
+ Date: Thu, 30 Jan 2020 00:59:57 +0100
4
+ Subject: [PATCH] opj_tcd_init_tile(): avoid integer overflow
5
+
6
+ That could lead to later assertion failures.
7
+
8
+ Fixes #1231 / CVE-2020-8112
9
+ ---
10
+ src/lib/openjp2/tcd.c | 20 ++++++++++++++++++--
11
+ 1 file changed, 18 insertions(+), 2 deletions(-)
12
+
13
+ diff --git a/src/lib/openjp2/tcd.c b/src/lib/openjp2/tcd.c
14
+ index be3b843..647991c 100644
15
+ --- a/src/lib/openjp2/tcd.c
16
+ +++ b/src/lib/openjp2/tcd.c
17
+ @@ -905,8 +905,24 @@ static INLINE OPJ_BOOL opj_tcd_init_tile(opj_tcd_t *p_tcd, OPJ_UINT32 p_tile_no,
18
+ /* p. 64, B.6, ISO/IEC FDIS15444-1 : 2000 (18 august 2000) */
19
+ l_tl_prc_x_start = opj_int_floordivpow2(l_res->x0, (OPJ_INT32)l_pdx) << l_pdx;
20
+ l_tl_prc_y_start = opj_int_floordivpow2(l_res->y0, (OPJ_INT32)l_pdy) << l_pdy;
21
+ - l_br_prc_x_end = opj_int_ceildivpow2(l_res->x1, (OPJ_INT32)l_pdx) << l_pdx;
22
+ - l_br_prc_y_end = opj_int_ceildivpow2(l_res->y1, (OPJ_INT32)l_pdy) << l_pdy;
23
+ + {
24
+ + OPJ_UINT32 tmp = ((OPJ_UINT32)opj_int_ceildivpow2(l_res->x1,
25
+ + (OPJ_INT32)l_pdx)) << l_pdx;
26
+ + if (tmp > (OPJ_UINT32)INT_MAX) {
27
+ + opj_event_msg(manager, EVT_ERROR, "Integer overflow\n");
28
+ + return OPJ_FALSE;
29
+ + }
30
+ + l_br_prc_x_end = (OPJ_INT32)tmp;
31
+ + }
32
+ + {
33
+ + OPJ_UINT32 tmp = ((OPJ_UINT32)opj_int_ceildivpow2(l_res->y1,
34
+ + (OPJ_INT32)l_pdy)) << l_pdy;
35
+ + if (tmp > (OPJ_UINT32)INT_MAX) {
36
+ + opj_event_msg(manager, EVT_ERROR, "Integer overflow\n");
37
+ + return OPJ_FALSE;
38
+ + }
39
+ + l_br_prc_y_end = (OPJ_INT32)tmp;
40
+ + }
41
+ /*fprintf(stderr, "\t\t\tprc_x_start=%d, prc_y_start=%d, br_prc_x_end=%d, br_prc_y_end=%d \n", l_tl_prc_x_start, l_tl_prc_y_start, l_br_prc_x_end ,l_br_prc_y_end );*/
42
+
43
+ l_res->pw = (l_res->x0 == l_res->x1) ? 0U : (OPJ_UINT32)((
44
+ --
45
+ 2.21.1
46
+
file modified
+13 -1
SPECS/openjpeg2.spec CHANGED
@@ -5,7 +5,7 @@
5
5
6
6
Name: openjpeg2
7
7
Version: 2.3.1
8
- Release: 4%{?dist}
8
+ Release: 6%{?dist}
9
9
Summary: C-Library for JPEG 2000
10
10
11
11
# windirent.h is MIT, the rest is BSD
@@ -23,6 +23,12 @@ Patch0: openjpeg2_opj2.patch
23
23
# Fix Coverity issues
24
24
Patch1: openjpeg2_coverity.patch
25
25
26
+ # Fix for CVE-2020-6851
27
+ Patch2: openjpeg2_CVE-2020-6851.patch
28
+
29
+ # Fix for CVE-2020-8112
30
+ Patch3: openjpeg2_CVE-2020-8112.patch
31
+
26
32
BuildRequires: cmake
27
33
BuildRequires: gcc
28
34
BuildRequires: make
@@ -326,6 +332,12 @@ make test -C %{_target_platform}
326
332
327
333
328
334
%changelog
335
+ * Mon Feb 10 2020 Nikola Forró <nforro@redhat.com> - 2.3.1-6
336
+ - Fix CVE-2020-8112 (#1801034)
337
+
338
+ * Tue Jan 14 2020 Nikola Forró <nforro@redhat.com> - 2.3.1-5
339
+ - Fix CVE-2020-6851 (#1790590)
340
+
329
341
* Wed Dec 04 2019 Nikola Forró <nforro@redhat.com> - 2.3.1-4
330
342
- Add upstream test suite and enable it in gating
331
343