031e79 Update numactl to the latest upstream stable source (version 2.0.5)

Authored and Committed by nhorman 14 years ago
    Update numactl to the latest upstream stable source (version 2.0.5)
    
        
file modified
+1 -0
.gitignore CHANGED
@@ -1,3 +1,4 @@
1
1
numactl-2.0.2.tar.gz
2
2
numactl-2.0.3-rc3.tar.gz
3
3
numactl-2.0.3.tar.gz
4
+ /numactl-2.0.5.tar.gz
numactl-2.0.2-remove-warning.patch DELETED
@@ -1,13 +0,0 @@
1
- diff -up numactl-2.0.2/libnuma.c.orig numactl-2.0.2/libnuma.c
2
- --- numactl-2.0.2/libnuma.c.orig 2009-02-09 15:26:41.000000000 -0500
3
- +++ numactl-2.0.2/libnuma.c 2009-02-09 15:26:45.000000000 -0500
4
- @@ -306,9 +306,6 @@ set_configured_nodes(void)
5
-
6
- d = opendir("/sys/devices/system/node");
7
- if (!d) {
8
- - numa_warn(W_nosysfs,
9
- - "/sys not mounted or no numa system. Assuming one node: %s",
10
- - strerror(errno));
11
- maxconfigurednode = 0;
12
- } else {
13
- while ((de = readdir(d)) != NULL) {
numactl-2.0.3-nodes_allowed_list_obo.patch DELETED
@@ -1,12 +0,0 @@
1
- diff -up numactl-2.0.3/libnuma.c.orig numactl-2.0.3/libnuma.c
2
- --- numactl-2.0.3/libnuma.c.orig 2009-08-10 07:02:12.000000000 -0400
3
- +++ numactl-2.0.3/libnuma.c 2009-08-10 07:02:39.000000000 -0400
4
- @@ -464,7 +464,7 @@ set_thread_constraints(void)
5
- nodes_allowed_list = malloc(strlen(buffer)-18);
6
- strncpy(nodes_allowed_list, buffer + 19,
7
- strlen(buffer) - 19);
8
- - nodes_allowed_list[strlen(nodes_allowed_list)-1] = '\0';
9
- + nodes_allowed_list[strlen(buffer)-19] = '\0';
10
- }
11
- }
12
- fclose(f);
numactl-2.0.3-rc3-distance_parsing.patch DELETED
@@ -1,38 +0,0 @@
1
- diff -up numactl-2.0.3-rc3/distance.c.orig numactl-2.0.3-rc3/distance.c
2
- --- numactl-2.0.3-rc3/distance.c.orig 2009-05-08 10:10:06.000000000 -0400
3
- +++ numactl-2.0.3-rc3/distance.c 2009-05-08 10:13:01.000000000 -0400
4
- @@ -50,6 +50,7 @@ static int read_distance_table(void)
5
- int numnodes = 0;
6
- int *table = NULL;
7
- int err = -1;
8
- + int found_nodes = 0;
9
-
10
- for (nd = 0;; nd++) {
11
- char fn[100];
12
- @@ -57,7 +58,7 @@ static int read_distance_table(void)
13
- sprintf(fn, "/sys/devices/system/node/node%d/distance", nd);
14
- dfh = fopen(fn, "r");
15
- if (!dfh) {
16
- - if (errno == ENOENT && nd > 0)
17
- + if (errno == ENOENT)
18
- err = 0;
19
- if (!err && nd<numa_num_configured_nodes())
20
- continue;
21
- @@ -79,14 +80,15 @@ static int read_distance_table(void)
22
- }
23
-
24
- parse_numbers(line, table + nd * numnodes, numnodes);
25
- + found_nodes++;
26
- }
27
- free(line);
28
- - if (err) {
29
- + if (!found_nodes) {
30
- numa_warn(W_distance,
31
- "Cannot parse distance information in sysfs: %s",
32
- strerror(errno));
33
- free(table);
34
- - return err;
35
- + return -1;
36
- }
37
- /* Update the global table pointer. Race window here with
38
- other threads, but in the worst case we leak one distance
file modified
+5 -8
numactl.spec CHANGED
@@ -1,17 +1,14 @@
1
1
Name: numactl
2
2
Summary: Library for tuning for Non Uniform Memory Access machines
3
- Version: 2.0.3
4
- Release: 8%{dist}
3
+ Version: 2.0.5
4
+ Release: 1%{dist}
5
5
License: LGPLv2/GPLv2
6
6
Group: System Environment/Base
7
7
URL: ftp://oss.sgi.com/www/projects/libnuma/download
8
8
Source0: ftp://oss.sgi.com/www/projects/libnuma/download/numactl-%{version}.tar.gz
9
9
Buildroot: %{_tmppath}/%{name}-buildroot
10
10
11
- Patch0: numactl-2.0.3-rc3-distance_parsing.patch
12
11
Patch1: numactl-2.0.3-rc3-no-nodes-warning.patch
13
- Patch2: numactl-2.0.3-nodes_allowed_list_obo.patch
14
- Patch3: numactl-2.0.3-dso-destructor.patch
15
12
16
13
ExcludeArch: s390 s390x
17
14
@@ -30,10 +27,7 @@ Provides development headers for numa library calls
30
27
31
28
%prep
32
29
%setup -q -n %{name}-%{version}
33
- %patch0 -p1
34
30
%patch1 -p1
35
- %patch2 -p1
36
- %patch3 -p1
37
31
38
32
%build
39
33
make CFLAGS="$RPM_OPT_FLAGS -I."
@@ -75,6 +69,9 @@ rm -rf $RPM_BUILD_ROOT
75
69
%{_mandir}/man3/*.3*
76
70
77
71
%changelog
72
+ * Mon Oct 18 2010 Neil Horman <nhorman@redhat.com> - 2.0.5-1
73
+ - Update to latest stable upstream source
74
+
78
75
* Mon Feb 15 2010 Neil Horman <nhorman@redhat.com> - 2.0.3-8
79
76
- Remove static libs from numactl (bz 556088)
80
77
file modified
+1 -1
sources CHANGED
@@ -1 +1 @@
1
- 8e4fb249e5f719c25d7f433964fb9220 numactl-2.0.3.tar.gz
1
+ 7cafe683095d4677326bcc5e4b3cc541 numactl-2.0.5.tar.gz