From c0b1b2308172b0db383d0839679c9b5814cfa3ac Mon Sep 17 00:00:00 2001
From: CentOS Sources <bugs@centos.org>
Date: Feb 22 2016 14:06:16 +0000
Subject: import nodejs010-nodejs-pause-stream-0.0.11-4.el7


---

diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..d7d533f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+SOURCES/pause-stream-0.0.11.tgz
diff --git a/.nodejs010-nodejs-pause-stream.metadata b/.nodejs010-nodejs-pause-stream.metadata
new file mode 100644
index 0000000..75f335d
--- /dev/null
+++ b/.nodejs010-nodejs-pause-stream.metadata
@@ -0,0 +1 @@
+fe5a34b0cbce12b5aa6a2b403ee2e73b602f1445 SOURCES/pause-stream-0.0.11.tgz
diff --git a/README.md b/README.md
deleted file mode 100644
index 98f42b4..0000000
--- a/README.md
+++ /dev/null
@@ -1,4 +0,0 @@
-The master branch has no content
-
-Look at the c7 branch if you are working with CentOS-7, or the c4/c5/c6 branch for CentOS-4, 5 or 6
-If you find this file in a distro specific branch, it means that no content has been checked in yet
diff --git a/SPECS/nodejs-pause-stream.spec b/SPECS/nodejs-pause-stream.spec
new file mode 100644
index 0000000..ecb3a3d
--- /dev/null
+++ b/SPECS/nodejs-pause-stream.spec
@@ -0,0 +1,67 @@
+%{?scl:%scl_package nodejs-%{module_name}}
+%{!?scl:%global pkg_name %{name}}
+%{?nodejs_find_provides_and_requires}
+
+# BR: for tests are not packaged yet
+%global enable_tests 0
+
+%global module_name pause-stream
+
+Name:           %{?scl_prefix}nodejs-%{module_name}
+Version:        0.0.11
+Release:        4%{?dist}
+Summary:        A ThroughStream that strictly buffers all readable events when paused
+
+License:        MIT and ASL 2.0
+URL:            http://github.com/dominictarr/pause-stream
+Source0:        http://registry.npmjs.org/%{module_name}/-/%{module_name}-%{version}.tgz
+BuildArch:      noarch
+ExclusiveArch:  %{nodejs_arches} noarch
+
+BuildRequires:  nodejs010-runtime
+
+%if 0%{?enable_tests}
+BuildRequires:  %{?scl_prefix}npm(stream-tester)
+BuildRequires:  %{?scl_prefix}npm(stream-spec)
+%endif
+
+%description
+This is a Stream that will strictly buffer when paused. Connect it to anything
+you need buffered.
+
+%prep
+%setup -q -n package
+rm -rf node_modules
+
+%build
+# nothing to build
+
+%install
+mkdir -p %{buildroot}%{nodejs_sitelib}/%{module_name}
+cp -pr package.json index.js %{buildroot}%{nodejs_sitelib}/%{module_name}
+
+%nodejs_symlink_deps
+
+%if 0%{?enable_tests}
+
+%check
+%nodejs_symlink_deps --check
+node test/index.js && node test/pause-end.js
+%endif
+
+%files
+%doc readme.markdown LICENSE
+%{nodejs_sitelib}/%{module_name}
+
+%changelog
+* Thu Jan 14 2016 Tomas Hrcka <thrcka@redhat.com> - 0.0.11-4
+- Enable find provides and requires macro
+
+* Thu Jan 07 2016 Tomas Hrcka <thrcka@redhat.com> - 0.0.11-3
+- Enable scl macros
+
+* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.11-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
+
+* Fri Dec 19 2014 Parag Nemade <pnemade AT redhat DOT com> - 0.0.11-1
+- Initial packaging
\ No newline at end of file