From 1906bf7535cf9faf43461cf1cd02af338ceb5013 Mon Sep 17 00:00:00 2001
From: CentOS Sources <bugs@centos.org>
Date: May 07 2019 11:14:50 +0000
Subject: import neon-0.30.2-6.el8


---

diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..8874a5b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+SOURCES/neon-0.30.2.tar.gz
diff --git a/.neon.metadata b/.neon.metadata
new file mode 100644
index 0000000..05d05b7
--- /dev/null
+++ b/.neon.metadata
@@ -0,0 +1 @@
+d1c020f96731135263476ebaa72b2da07c4727cd SOURCES/neon-0.30.2.tar.gz
diff --git a/SOURCES/neon-0.27.0-multilib.patch b/SOURCES/neon-0.27.0-multilib.patch
new file mode 100644
index 0000000..5f8f86d
--- /dev/null
+++ b/SOURCES/neon-0.27.0-multilib.patch
@@ -0,0 +1,56 @@
+--- neon-0.27.0/neon-config.in.multilib
++++ neon-0.27.0/neon-config.in
+@@ -5,7 +5,11 @@
+ prefix=@prefix@
+ exec_prefix=@exec_prefix@
+ includedir=@includedir@
+-libdir=@libdir@
++
++libdir=`pkg-config --variable=libdir neon`
++CFLAGS=`pkg-config --cflags neon`
++LIBS=`pkg-config --libs neon`
++has_lfs=`pkg-config --variable=has_lfs neon`
+ 
+ usage()
+ {
+@@ -23,7 +27,7 @@
+   --support FEATURE     exit with success if feature is supported
+ 
+  Known features: 
+-    dav [@NE_FLAG_DAV@], ssl [@NE_FLAG_SSL@], zlib [@NE_FLAG_ZLIB@], ipv6 [@NE_FLAG_IPV6@], lfs [@NE_FLAG_LFS@],
++    dav [@NE_FLAG_DAV@], ssl [@NE_FLAG_SSL@], zlib [@NE_FLAG_ZLIB@], ipv6 [@NE_FLAG_IPV6@], lfs [${has_lfs}],
+     i18n [@NE_FLAG_I18N@], ts_ssl [@NE_FLAG_TS_SSL@]
+ 
+ EOF
+@@ -69,11 +73,10 @@
+ 	;;
+ 
+     --cflags)
+-       	echo -I${includedir}/neon @NEON_CFLAGS@
++       	echo ${CFLAGS}
+        	;;
+ 
+     --libs)
+-        LIBS="-lneon @NEON_LIBS@"
+ 	# Don't add standard library paths
+         if test "$prefix" != "/usr"; then
+            LIBS="-L${libdir} ${LIBS}"
+@@ -93,7 +96,7 @@
+ 	zlib|ZLIB) support @NE_FLAG_ZLIB@ ;;
+ 	ipv6|IPV6) support @NE_FLAG_IPV6@ ;;
+ 	dav|DAV) support @NE_FLAG_DAV@ ;;
+-	lfs|LFS) support @NE_FLAG_LFS@ ;;
++	lfs|LFS) support ${has_lfs} ;;
+ 	i18n|I18N) support @NE_FLAG_I18N@ ;;
+ 	ts_ssl|TS_SSL) support @NE_FLAG_TS_SSL@ ;;
+ 	*) support no ;;
+--- neon-0.27.0/neon.pc.in.multilib
++++ neon-0.27.0/neon.pc.in
+@@ -2,6 +2,7 @@
+ exec_prefix=@exec_prefix@
+ libdir=@libdir@
+ includedir=@includedir@
++has_lfs=@NE_FLAG_LFS@
+ 
+ Name: neon
+ Description: HTTP/WebDAV client library
diff --git a/SOURCES/neon-0.30.2-warnings.patch b/SOURCES/neon-0.30.2-warnings.patch
new file mode 100644
index 0000000..2823b6f
--- /dev/null
+++ b/SOURCES/neon-0.30.2-warnings.patch
@@ -0,0 +1,284 @@
+--- test/request.c	(.../tags/0.30.2)	(revision 2045)
++++ test/request.c	(.../branches/0.30.x)	(revision 2045)
+@@ -902,8 +902,6 @@
+     ONREQ(ne_request_dispatch(req));
+ 
+     while ((cursor = ne_response_header_iterate(req, cursor, &name, &value))) {
+-        n = -1;
+-
+         ONV(strncmp(name, "x-", 2) || strncmp(value, "Y-", 2)
+             || strcmp(name + 2, value + 2)
+             || (n = atoi(name + 2)) >= MANY_HEADERS
+@@ -2358,6 +2356,21 @@
+     return await_server();
+ }
+ 
++static int safe_flags(void)
++{
++    ne_session *sess = ne_session_create("http", "localhost", 80);
++    ne_request *req = ne_request_create(sess, "GET", "/");
++
++    ne_set_request_flag(req, NE_REQFLAG_LAST, 0xAAAAAAAA);
++
++    ONN("flags array bound check failed", ne_get_session(req) != sess);
++
++    ne_request_destroy(req);
++    ne_session_destroy(sess);
++
++    return OK;
++}
++
+ /* TODO: test that ne_set_notifier(, NULL, NULL) DTRT too. */
+ 
+ ne_test tests[] = {
+@@ -2451,5 +2464,6 @@
+     T(socks_fail),
+     T(fail_lookup),
+     T(fail_double_lookup),
++    T(safe_flags),
+     T(NULL)
+ };
+--- test/lock.c	(.../tags/0.30.2)	(revision 2045)
++++ test/lock.c	(.../branches/0.30.x)	(revision 2045)
+@@ -73,11 +73,13 @@
+ 			   const char *token_href)
+ {
+     static char buf[BUFSIZ];
+-    sprintf(buf, 
+-	    "<?xml version=\"1.0\" encoding=\"utf-8\"?>\n"
+-	    "<D:prop xmlns:D=\"DAV:\">"
+-	    "<D:lockdiscovery>%s</D:lockdiscovery></D:prop>\n",
+-	    activelock(scope, depth, owner, timeout, token_href));
++
++    ne_snprintf(buf, sizeof buf,
++                "<?xml version=\"1.0\" encoding=\"utf-8\"?>\n"
++                "<D:prop xmlns:D=\"DAV:\">"
++                "<D:lockdiscovery>%s</D:lockdiscovery></D:prop>\n",
++                activelock(scope, depth, owner, timeout, token_href));
++
+     return buf;
+ }
+ 
+--- test/string-tests.c	(.../tags/0.30.2)	(revision 2045)
++++ test/string-tests.c	(.../branches/0.30.x)	(revision 2045)
+@@ -320,7 +320,7 @@
+ {
+     char expect[200], actual[200];
+     
+-    strncpy(expect, strerror(ENOENT), sizeof(expect));
++    strncpy(expect, strerror(ENOENT), sizeof(expect)-1);
+     ONN("ne_strerror did not return passed-in buffer",
+ 	ne_strerror(ENOENT, actual, sizeof(actual)) != actual);
+     
+--- test/util-tests.c	(.../tags/0.30.2)	(revision 2045)
++++ test/util-tests.c	(.../branches/0.30.x)	(revision 2045)
+@@ -203,18 +203,24 @@
+     return OK;
+ }
+ 
+-/* trigger segfaults in ne_rfc1036_parse() in <=0.24.5. */
+-static int regress_dates(void)
++#define BAD_DATE(format, result) \
++    ONN(format " date parse must fail", result != -1)
++
++/* Test for bad dates; trigger segfaults in ne_rfc1036_parse() in
++ * <=0.24.5. */
++static int bad_dates(void)
+ {
+     static const char *dates[] = {
+-        "AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA"
++        "AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA",
++        "Friday, 08-Jun-01",
+     };
+     size_t n;
+     
+     for (n = 0; n < sizeof(dates)/sizeof(dates[0]); n++) {
+-        ne_rfc1036_parse(dates[n]);
+-        ne_iso8601_parse(dates[n]);
+-        ne_rfc1123_parse(dates[n]);
++        BAD_DATE("rfc1036", ne_rfc1036_parse(dates[n]));
++        BAD_DATE("iso8601", ne_iso8601_parse(dates[n]));
++        BAD_DATE("rfc1123", ne_rfc1123_parse(dates[n]));
++        BAD_DATE("asctime", ne_asctime_parse(dates[n]));
+     }
+ 
+     return OK;
+@@ -303,7 +309,7 @@
+     T(md5),
+     T(md5_alignment),
+     T(parse_dates),
+-    T(regress_dates),
++    T(bad_dates),
+     T(versioning),
+     T(version_string),
+     T(support),
+--- src/ne_dates.c	(.../tags/0.30.2)	(revision 2045)
++++ src/ne_dates.c	(.../branches/0.30.x)	(revision 2045)
+@@ -171,11 +171,12 @@
+     int n;
+     time_t result;
+     
+-/*  it goes: Sun, 06 Nov 1994 08:49:37 GMT */
+-    n = sscanf(date, RFC1123_FORMAT,
+-	    wkday, &gmt.tm_mday, mon, &gmt.tm_year, &gmt.tm_hour,
+-	    &gmt.tm_min, &gmt.tm_sec);
+-    /* Is it portable to check n==7 here? */
++    /* it goes: Sun, 06 Nov 1994 08:49:37 GMT */
++    if (sscanf(date, RFC1123_FORMAT,
++               wkday, &gmt.tm_mday, mon, &gmt.tm_year, &gmt.tm_hour,
++               &gmt.tm_min, &gmt.tm_sec) != 7)
++        return (time_t) -1;
++
+     gmt.tm_year -= 1900;
+     for (n=0; n<12; n++)
+ 	if (strcmp(mon, short_months[n]) == 0)
+@@ -204,7 +205,6 @@
+ 	return (time_t)-1;
+     }
+ 
+-    /* portable to check n here? */
+     for (n=0; n<12; n++)
+ 	if (strcmp(mon, short_months[n]) == 0)
+ 	    break;
+@@ -232,11 +232,12 @@
+     char wkday[4], mon[4];
+     time_t result;
+ 
+-    n = sscanf(date, ASCTIME_FORMAT,
+-		wkday, mon, &gmt.tm_mday, 
+-		&gmt.tm_hour, &gmt.tm_min, &gmt.tm_sec,
+-		&gmt.tm_year);
+-    /* portable to check n here? */
++    if (sscanf(date, ASCTIME_FORMAT,
++               wkday, mon, &gmt.tm_mday, 
++               &gmt.tm_hour, &gmt.tm_min, &gmt.tm_sec,
++               &gmt.tm_year) != 7)
++        return (time_t)-1;
++
+     for (n=0; n<12; n++)
+ 	if (strcmp(mon, short_months[n]) == 0)
+ 	    break;
+--- src/ne_locks.c	(.../tags/0.30.2)	(revision 2045)
++++ src/ne_locks.c	(.../branches/0.30.x)	(revision 2045)
+@@ -32,6 +32,7 @@
+ #ifdef HAVE_LIMITS_H
+ #include <limits.h>
+ #endif
++#include <assert.h>
+ 
+ #include <ctype.h> /* for isdigit() */
+ 
+@@ -332,6 +333,9 @@
+     for (item = store->locks; item != NULL; item = item->next)
+ 	if (item->lock == lock)
+ 	    break;
++
++    /* API condition that lock is present in the store. */
++    assert(item);
+     
+     if (item->prev != NULL) {
+ 	item->prev->next = item->next;
+--- src/ne_session.c	(.../tags/0.30.2)	(revision 2045)
++++ src/ne_session.c	(.../branches/0.30.x)	(revision 2045)
+@@ -569,7 +569,8 @@
+     };
+     int n, flag = 0;
+ 
+-    strcpy(sess->error, _("Server certificate verification failed: "));
++    ne_strnzcpy(sess->error, _("Server certificate verification failed: "),
++                sizeof sess->error);
+ 
+     for (n = 0; reasons[n].bit; n++) {
+ 	if (failures & reasons[n].bit) {
+--- src/ne_xml.c	(.../tags/0.30.2)	(revision 2045)
++++ src/ne_xml.c	(.../branches/0.30.x)	(revision 2045)
+@@ -576,7 +576,7 @@
+         if (p->bom_pos == 0) {
+             p->bom_pos = 3; /* no BOM */
+         } else if (p->bom_pos > 0 && p->bom_pos < 3) {
+-            strcpy(p->error, _("Invalid Byte Order Mark"));
++            ne_strnzcpy(p->error, _("Invalid Byte Order Mark"), sizeof p->error);
+             return p->failure = 1;
+         }
+     }
+--- src/ne_request.c	(.../tags/0.30.2)	(revision 2045)
++++ src/ne_request.c	(.../branches/0.30.x)	(revision 2045)
+@@ -329,7 +329,7 @@
+                 /* errno was set */
+                 ne_strerror(errno, err, sizeof err);
+             } else {
+-                strcpy(err, _("offset invalid"));
++                ne_strnzcpy(err, _("offset invalid"), sizeof err);
+             }
+             ne_snprintf(offstr, sizeof offstr, "%" FMT_NE_OFF_T,
+                         req->body.file.offset);
+@@ -585,7 +585,7 @@
+ 
+ void ne_set_request_flag(ne_request *req, ne_request_flag flag, int value)
+ {
+-    if (flag < (ne_request_flag)NE_SESSFLAG_LAST) {
++    if (flag < (ne_request_flag)NE_REQFLAG_LAST) {
+         req->flags[flag] = value;
+     }
+ }
+--- src/ne_socket.c	(.../tags/0.30.2)	(revision 2045)
++++ src/ne_socket.c	(.../branches/0.30.x)	(revision 2045)
+@@ -27,7 +27,7 @@
+ #include "config.h"
+ 
+ #include <sys/types.h>
+-#ifdef HAVE_SYS_UIO_h
++#ifdef HAVE_SYS_UIO_H
+ #include <sys/uio.h> /* writev(2) */
+ #endif
+ #ifdef HAVE_SYS_TIME_H
+--- src/ne_openssl.c	(.../tags/0.30.2)	(revision 2045)
++++ src/ne_openssl.c	(.../branches/0.30.x)	(revision 2045)
+@@ -1130,7 +1130,10 @@
+     return 0;
+ }
+ 
+-#ifdef NE_HAVE_TS_SSL
++#if defined(NE_HAVE_TS_SSL) && OPENSSL_VERSION_NUMBER < 0x10101000L
++/* For OpenSSL 1.1.1 locking callbacks are no longer need at all. */
++#define WITH_OPENSSL_LOCKING (1)
++
+ /* Implementation of locking callbacks to make OpenSSL thread-safe.
+  * If the OpenSSL API was better designed, this wouldn't be necessary.
+  * In OpenSSL releases without CRYPTO_set_idptr_callback, it's not
+@@ -1184,8 +1187,6 @@
+     }
+ }
+ 
+-#endif
+-
+ /* ID_CALLBACK_IS_{NEON,OTHER} evaluate as true if the currently
+  * registered OpenSSL ID callback is the neon function (_NEON), or has
+  * been overwritten by some other app (_OTHER). */
+@@ -1196,6 +1197,8 @@
+ #define ID_CALLBACK_IS_OTHER (CRYPTO_get_id_callback() != NULL)
+ #define ID_CALLBACK_IS_NEON (CRYPTO_get_id_callback() == thread_id_neon)
+ #endif
++        
++#endif /* NE_HAVE_TS_SSL && OPENSSL_VERSION_NUMBER < 1.1.1 */
+ 
+ int ne__ssl_init(void)
+ {
+@@ -1205,7 +1208,7 @@
+     SSL_library_init();
+     OpenSSL_add_all_algorithms();
+ 
+-#ifdef NE_HAVE_TS_SSL
++#ifdef WITH_OPENSSL_LOCKING
+     /* If some other library has already come along and set up the
+      * thread-safety callbacks, then it must be presumed that the
+      * other library will have a longer lifetime in the process than
+@@ -1252,7 +1255,7 @@
+     /* Cannot call ERR_free_strings() etc here in case any other code
+      * in the process using OpenSSL. */
+ 
+-#ifdef NE_HAVE_TS_SSL
++#ifdef WITH_OPENSSL_LOCKING
+     /* Only unregister the callbacks if some *other* library has not
+      * come along in the mean-time and trampled over the callbacks
+      * installed by neon. */
diff --git a/SPECS/neon.spec b/SPECS/neon.spec
new file mode 100644
index 0000000..eddd3db
--- /dev/null
+++ b/SPECS/neon.spec
@@ -0,0 +1,354 @@
+Summary: An HTTP and WebDAV client library
+Name: neon
+Version: 0.30.2
+Release: 6%{?dist}
+License: LGPLv2+
+Group: System Environment/Libraries
+URL: http://www.webdav.org/neon/
+Source0: http://www.webdav.org/neon/neon-%{version}.tar.gz
+Patch0: neon-0.27.0-multilib.patch
+Patch1: neon-0.30.2-warnings.patch
+BuildRequires: expat-devel, openssl-devel, zlib-devel, krb5-devel, libproxy-devel
+BuildRequires: pkgconfig, pakchois-devel, gcc
+Requires: ca-certificates
+
+%description
+neon is an HTTP and WebDAV client library, with a C interface;
+providing a high-level interface to HTTP and WebDAV methods along
+with a low-level interface for HTTP request handling.  neon
+supports persistent connections, proxy servers, basic, digest and
+Kerberos authentication, and has complete SSL support.
+
+%package devel
+Summary: Development libraries and C header files for the neon library
+Group: Development/Libraries
+Requires: neon = %{version}-%{release}, openssl-devel, zlib-devel, expat-devel
+Requires: pkgconfig
+# Documentation is GPLv2+
+License: LGPLv2+ and GPLv2+
+
+%description devel
+The development library for the C language HTTP and WebDAV client library.
+
+%prep
+%setup -q
+%patch0 -p1 -b .multilib
+%patch1 -p0 -b .warnings
+
+# prevent installation of HTML docs
+sed -ibak '/^install-docs/s/install-html//' Makefile.in
+
+%build
+export CC="%{__cc} -pthread"
+%configure --with-expat --enable-shared --disable-static \
+        --enable-warnings \
+        --with-ssl=openssl --enable-threadsafe-ssl=posix \
+        --with-libproxy
+make %{?_smp_mflags}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
+
+sed -ri "/^dependency_libs/{s,-l[^ ']*,,g}" \
+      $RPM_BUILD_ROOT%{_libdir}/libneon.la
+
+%find_lang %{name}
+
+%post -p /sbin/ldconfig
+
+%postun -p /sbin/ldconfig
+
+%files -f %{name}.lang
+%defattr(-,root,root)
+%doc AUTHORS BUGS TODO src/COPYING.LIB NEWS README THANKS
+%{_libdir}/*.so.*
+
+%files devel
+%defattr(-,root,root)
+%{_bindir}/*
+%{_includedir}/*
+%{_libdir}/pkgconfig/neon.pc
+%{_mandir}/man1/*
+%{_mandir}/man3/*
+%{_libdir}/*.*a
+%{_libdir}/*.so
+
+%changelog
+* Tue Dec 11 2018 Joe Orton <jorton@redhat.com> - 0.30.2-6
+- fix covscan warnings (#1602627)
+
+* Thu Feb 08 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.30.2-5
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
+
+* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.30.2-4
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
+
+* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.30.2-3
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
+
+* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.30.2-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
+
+* Fri Sep 30 2016 Joe Orton <jorton@redhat.com> - 0.30.2-1
+- update to 0.30.2
+
+* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.30.1-4
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
+
+* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.30.1-3
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
+
+* Tue Sep 23 2014 Joe Orton <jorton@redhat.com> - 0.30.1-2
+- switch to OpenSSL
+
+* Tue Sep 23 2014 Joe Orton <jorton@redhat.com> - 0.30.1-1
+- update to 0.30.1
+
+* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.30.0-4
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
+
+* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.30.0-3
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
+
+* Wed Jul 31 2013 Joe Orton <jorton@redhat.com> - 0.30.0-2
+- prevent installation of HTML docs
+
+* Wed Jul 31 2013 Joe Orton <jorton@redhat.com> - 0.30.0-1
+- update to 0.30.0 (#983563, #926212)
+
+* Mon Mar 18 2013 Joe Orton <jorton@redhat.com> - 0.29.6-6
+- fix strict-aliasing warning (upstream r1896)
+
+* Mon Feb 25 2013 Tomáš Mráz <tmraz@redhat.com> - 0.29.6-5
+- fix build with gnutls3 - patch by Bartosz Brachaczek
+
+* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.29.6-4
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
+
+* Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.29.6-3
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
+
+* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.29.6-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
+
+* Tue May  3 2011 Joe Orton <jorton@redhat.com> - 0.29.6-1
+- update to 0.29.6
+- correct -devel License; drop old Conflicts
+
+* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.29.5-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
+
+* Thu Oct 14 2010 Joe Orton <jorton@redhat.com> - 0.29.5-1
+- update to 0.29.5
+
+* Fri Oct  1 2010 Joe Orton <jorton@redhat.com> - 0.29.4-1
+- update to 0.29.4
+
+* Thu Mar 25 2010 Joe Orton <jorton@redhat.com> - 0.29.3-1
+- update to 0.29.3
+
+* Fri Jan  8 2010 Joe Orton <jorton@redhat.com> - 0.29.2-1
+- update to 0.29.2
+
+* Tue Dec 15 2009 Joe Orton <jorton@redhat.com> - 0.29.1-1
+- update to 0.29.1
+
+* Sun Sep 13 2009 Joe Orton <jorton@redhat.com> 0.29.0-3
+- enable libproxy support
+
+* Sun Sep 13 2009 Joe Orton <jorton@redhat.com> 0.29.0-1
+- update to 0.29.0
+
+* Wed Aug 19 2009 Joe Orton <jorton@redhat.com> 0.28.6-1
+- update to 0.28.6
+
+* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.28.5-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
+
+* Thu Jul  9 2009 Joe Orton <jorton@redhat.com> 0.28.5-1
+- update to 0.28.5
+
+* Fri Mar  6 2009 Joe Orton <jorton@redhat.com> 0.28.4-1
+- update to 0.28.4
+
+* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.28.3-4
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
+
+* Mon Jan 19 2009 Joe Orton <jorton@redhat.com> 0.28.3-3
+- use install-p in "make install" (Robert Scheck, #226189)
+
+* Thu Aug 28 2008 Joe Orton <jorton@redhat.com> 0.28.3-2
+- update to 0.28.3
+
+* Wed Jun 25 2008 Joe Orton <jorton@redhat.com> 0.28.2-4
+- rebuild for new GnuTLS
+
+* Mon Jun  2 2008 Joe Orton <jorton@redhat.com> 0.28.2-3
+- require ca-certificates package
+
+* Thu Apr  3 2008 Joe Orton <jorton@redhat.com> 0.28.2-2
+- update to 0.28.2
+
+* Wed Apr  2 2008 Joe Orton <jorton@redhat.com> 0.28.1-3
+- use the OpenSSL CA bundle
+
+* Mon Mar 10 2008 Joe Orton <jorton@redhat.com> 0.28.1-2
+- update to 0.28.1
+
+* Tue Feb 26 2008 Joe Orton <jorton@redhat.com> 0.28.0-3
+- rebuild against pakchois
+
+* Wed Dec  5 2007 Joe Orton <jorton@redhat.com> 0.27.2-4
+- trim dependency_libs in .la file
+
+* Tue Dec  4 2007 Joe Orton <jorton@redhat.com> 0.27.2-3
+- rebuild against GnuTLS
+- drop static library
+
+* Tue Sep 25 2007 Joe Orton <jorton@redhat.com> 0.27.2-2
+- update to 0.27.2
+
+* Thu Sep 20 2007 Joe Orton <jorton@redhat.com> 0.27.0-3
+- fix Negotiate response verification
+
+* Thu Aug 30 2007 Joe Orton <jorton@redhat.com> 0.27.0-2
+- enable OpenSSL thread-safety hooks
+
+* Wed Aug 22 2007 Joe Orton <jorton@redhat.com> 0.27.0-1
+- update to 0.27.0 (#243638)
+
+* Mon Aug 20 2007 Joe Orton <jorton@redhat.com> 0.25.5-7
+- fix License
+
+* Mon Feb  5 2007 Joe Orton <jorton@redhat.com> 0.25.5-6
+- remove trailing dot in -devel Summary
+- use standard BuildRoot
+- change Group to System Environment/Libraries
+- drop Prefix
+
+* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.25.5-5.1
+- rebuild
+
+* Thu Jun  1 2006 Joe Orton <jorton@redhat.com> 0.25.5-5
+- have -devel require pkgconfig (#193355)
+
+* Wed May 24 2006 Joe Orton <jorton@redhat.com> 0.25.5-4
+- add multilib fixes for neon-config (#192734)
+
+* Wed May 17 2006 Joe Orton <jorton@redhat.com> 0.25.5-3
+- rebuild
+
+* Mon Feb 27 2006 Joe Orton <jorton@redhat.com> 0.25.5-2
+- don't trim exported libraries (#182997)
+
+* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.25.5-1.2
+- bump again for double-long bug on ppc(64)
+
+* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.25.5-1.1
+- rebuilt for new gcc4.1 snapshot and glibc changes
+
+* Tue Jan 31 2006 Joe Orton <jorton@redhat.com> 0.25.5-1
+- update to 0.25.5
+
+* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
+- rebuilt
+
+* Wed Dec  7 2005 Joe Orton <jorton@redhat.com> 0.24.7-10
+- strip unnecessary exports from .la file/neon-config
+
+* Tue Nov  8 2005 Tomas Mraz <tmraz@redhat.com> 0.24.7-9
+- rebuilt with new openssl
+
+* Fri Sep 23 2005 Joe Orton <jorton@redhat.com> 0.24.7-8
+- restore static libs for rpm
+
+* Mon Sep 19 2005 Joe Orton <jorton@redhat.com> 0.24.7-7
+- drop static libs, doc/html from devel docdir
+
+* Wed Mar  2 2005 Joe Orton <jorton@redhat.com> 0.24.7-6
+- rebuild
+
+* Thu Feb 10 2005 Joe Orton <jorton@redhat.com> 0.24.7-5
+- don't define min() in ne_utils.h (Caolan McNamara, #147228)
+
+* Tue Oct 12 2004 Joe Orton <jorton@redhat.com> 0.24.7-4
+- update to GSSAPI code from trunk
+
+* Fri Jul 23 2004 Joe Orton <jorton@redhat.com> 0.24.7-3
+- rebuild
+
+* Tue Jul 20 2004 Joe Orton <jorton@redhat.com> 0.24.7-2.1
+- rebuild
+
+* Tue Jul  6 2004 Joe Orton <jorton@redhat.com> 0.24.7-2
+- devel requires neon of same release, expat-devel (#127330)
+
+* Mon Jul  5 2004 Joe Orton <jorton@redhat.com> 0.24.7-1
+- update to 0.24.7
+
+* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
+- rebuilt
+
+* Wed May 19 2004 Joe Orton <jorton@redhat.com> 0.24.6-1
+- update to 0.24.6
+
+* Wed Apr 14 2004 Joe Orton <jorton@redhat.com> 0.24.5-2
+- rebuild
+
+* Wed Apr 14 2004 Joe Orton <jorton@redhat.com> 0.24.5-1
+- update to 0.24.5 for CVE CAN-2004-0179 fix
+
+* Thu Mar 25 2004 Joe Orton <jorton@redhat.com> 0.24.4-4
+- implement the Negotate auth scheme, and only over SSL
+
+* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
+- rebuilt
+
+* Wed Feb 25 2004 Joe Orton <jorton@redhat.com> 0.24.4-3
+- use BuildRequires not BuildPrereq, drop autoconf, libtool;
+  -devel requires {openssl,zlib}-devel (#116744)
+
+* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com> 0.24.4-2
+- rebuilt
+
+* Mon Feb  9 2004 Joe Orton <jorton@redhat.com> 0.24.4-1
+- update to 0.24.4
+
+* Thu Oct  9 2003 Joe Orton <jorton@redhat.com> 0.24.3-1
+- update to 0.24.3
+
+* Wed Sep 24 2003 Joe Orton <jorton@redhat.com> 0.24.2-1
+- update to 0.24.2
+
+* Tue Jul 22 2003 Nalin Dahyabhai <nalin@redhat.com> 0.23.9-7
+- rebuild
+
+* Tue Jun 24 2003 Joe Orton <jorton@redhat.com> 0.23.9-6
+- never print libdir in --libs output
+
+* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
+- rebuilt
+
+* Tue Jun  3 2003 Joe Orton <jorton@redhat.com> 0.23.9-4
+- don't regenerate docs; limit conflict with subversion
+
+* Wed May 28 2003 Jeff Johnson <jbj@redhat.com> 0.23.9-3
+- build.
+
+* Sat May 24 2003 Florian La Roche <Florian.LaRoche@redhat.de>
+- add ldconfig to post/postun
+
+* Tue May 20 2003 Jeff Johnson <jbj@redhat.com> 0.23.9-2
+- force expat, include neon-config, for subversion build.
+- do "make check" (but ignore failure for now)
+
+* Mon May 19 2003 Jeff Johnson <jbj@redhat.com> 0.23.9-1
+- upgrade to 0.23.9.
+- avoid xmlto breakage generating man pages for now.
+
+* Mon Nov 11 2002 Jeff Johnson <jbj@redhat.com> 0.23.5-2
+- avoid subversion-devel until libxml2 vs. expat is resolved.
+
+* Sat Nov  9 2002 Jeff Johnson <jbj@redhat.com> 0.23.5-1
+- Create.