6772ca import ncurses-6.1-9.20180224.el8

Authored and Committed by centosrcm 3 years ago
    import ncurses-6.1-9.20180224.el8
    
        
SOURCES/ncurses-cve-2019-17594.patch ADDED
@@ -0,0 +1,28 @@
1
+ From snapshot 6.1-20191012
2
+
3
+ diff --git a/ncurses/tinfo/comp_hash.c b/ncurses/tinfo/comp_hash.c
4
+ index 21f165ca..a62d38f9 100644
5
+ --- a/ncurses/tinfo/comp_hash.c
6
+ +++ b/ncurses/tinfo/comp_hash.c
7
+ @@ -63,7 +63,9 @@ _nc_find_entry(const char *string,
8
+
9
+ hashvalue = data->hash_of(string);
10
+
11
+ - if (data->table_data[hashvalue] >= 0) {
12
+ + if (hashvalue >= 0
13
+ + && (unsigned) hashvalue < data->table_size
14
+ + && data->table_data[hashvalue] >= 0) {
15
+
16
+ real_table = _nc_get_table(termcap);
17
+ ptr = real_table + data->table_data[hashvalue];
18
+ @@ -96,7 +98,9 @@ _nc_find_type_entry(const char *string,
19
+ const HashData *data = _nc_get_hash_info(termcap);
20
+ int hashvalue = data->hash_of(string);
21
+
22
+ - if (data->table_data[hashvalue] >= 0) {
23
+ + if (hashvalue >= 0
24
+ + && (unsigned) hashvalue < data->table_size
25
+ + && data->table_data[hashvalue] >= 0) {
26
+ const struct name_table_entry *const table = _nc_get_table(termcap);
27
+
28
+ ptr = table + data->table_data[hashvalue];
SOURCES/ncurses-cve-2019-17595.patch ADDED
@@ -0,0 +1,16 @@
1
+ From snapshot 6.1-20191012
2
+
3
+ diff --git a/progs/dump_entry.c b/progs/dump_entry.c
4
+ index d0e420ec..8a47084a 100644
5
+ --- a/progs/dump_entry.c
6
+ +++ b/progs/dump_entry.c
7
+ @@ -1136,7 +1136,8 @@ fmt_entry(TERMTYPE2 *tterm,
8
+ *d++ = '\\';
9
+ *d = ':';
10
+ } else if (*d == '\\') {
11
+ - *++d = *s++;
12
+ + if ((*++d = *s++) == '\0')
13
+ + break;
14
+ }
15
+ d++;
16
+ *d = '\0';
SOURCES/ncurses-tputx.patch ADDED
@@ -0,0 +1,15 @@
1
+ From snapshot 6.1-20180630
2
+
3
+ diff --git a/progs/tput.c b/progs/tput.c
4
+ index fd051eb4..88e75799 100644
5
+ --- a/progs/tput.c
6
+ +++ b/progs/tput.c
7
+ @@ -293,7 +293,7 @@ main(int argc, char **argv)
8
+
9
+ term = getenv("TERM");
10
+
11
+ - while ((c = getopt(argc, argv, "ST:V")) != -1) {
12
+ + while ((c = getopt(argc, argv, "ST:Vx")) != -1) {
13
+ switch (c) {
14
+ case 'S':
15
+ cmdline = FALSE;
file modified
+14 -1
SPECS/ncurses.spec CHANGED
@@ -2,7 +2,7 @@
2
2
Summary: Ncurses support utilities
3
3
Name: ncurses
4
4
Version: 6.1
5
- Release: 7.%{revision}%{?dist}
5
+ Release: 9.%{revision}%{?dist}
6
6
License: MIT
7
7
Group: System Environment/Base
8
8
URL: https://invisible-island.net/ncurses/ncurses.html
@@ -13,6 +13,9 @@ Patch8: ncurses-config.patch
13
13
Patch9: ncurses-libs.patch
14
14
Patch11: ncurses-urxvt.patch
15
15
Patch12: ncurses-kbs.patch
16
+ Patch13: ncurses-cve-2019-17594.patch
17
+ Patch14: ncurses-cve-2019-17595.patch
18
+ Patch15: ncurses-tputx.patch
16
19
BuildRequires: gcc gcc-c++ gpm-devel pkgconfig
17
20
18
21
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
@@ -127,6 +130,9 @@ The ncurses-static package includes static libraries of the ncurses library.
127
130
%patch9 -p1 -b .libs
128
131
%patch11 -p1 -b .urxvt
129
132
%patch12 -p1 -b .kbs
133
+ %patch13 -p1 -b .cve-2019-17594
134
+ %patch14 -p1 -b .cve-2019-17595
135
+ %patch15 -p1 -b .tputx
130
136
131
137
for f in ANNOUNCE; do
132
138
iconv -f iso8859-1 -t utf8 -o ${f}{_,} &&
@@ -293,6 +299,13 @@ bzip2 NEWS
293
299
%{_libdir}/lib*.a
294
300
295
301
%changelog
302
+ * Tue May 18 2021 Miroslav Lichvar <mlichvar@redhat.com> 6.1-9.20180224
303
+ - fix tput to accept -x option (#1916340)
304
+
305
+ * Tue May 18 2021 Miroslav Lichvar <mlichvar@redhat.com> 6.1-8.20180224
306
+ - fix buffer overflow in terminfo entry hashtable (CVE-2019-17594)
307
+ - handle missing character after backslash in terminfo entry (CVE-2019-17595)
308
+
296
309
* Wed Jan 16 2019 Miroslav Lichvar <mlichvar@redhat.com> 6.1-7.20180224
297
310
- disable stripping on program installation (#1665177)
298
311