fc565f import mutter-3.28.3-19.el8_0

Authored and Committed by centosrcm 5 years ago
    import mutter-3.28.3-19.el8_0
    
        
SOURCES/0001-backends-x11-Support-synaptics-configuration.patch CHANGED
@@ -1,4 +1,4 @@
1
- From 23996c5290918e264d9385dbf68b90247423187d Mon Sep 17 00:00:00 2001
1
+ From 39d66b990adfaed99e0a5ea473c8d1d0116c0757 Mon Sep 17 00:00:00 2001
2
2
From: Carlos Garnacho <carlosg@gnome.org>
3
3
Date: Thu, 19 Jan 2017 15:03:41 +0100
4
4
Subject: [PATCH] backends/x11: Support synaptics configuration
@@ -6,11 +6,11 @@ Subject: [PATCH] backends/x11: Support synaptics configuration
6
6
The code is taken mostly as-is from g-s-d, so we can drag the
7
7
dead horse a bit longer.
8
8
---
9
- src/backends/x11/meta-input-settings-x11.c | 266 +++++++++++++++++++++
10
- 1 file changed, 266 insertions(+)
9
+ src/backends/x11/meta-input-settings-x11.c | 269 ++++++++++++++++++++-
10
+ 1 file changed, 268 insertions(+), 1 deletion(-)
11
11
12
12
diff --git a/src/backends/x11/meta-input-settings-x11.c b/src/backends/x11/meta-input-settings-x11.c
13
- index 9687fb36f..1d84dfccf 100644
13
+ index 9687fb3..effcc5f 100644
14
14
--- a/src/backends/x11/meta-input-settings-x11.c
15
15
+++ b/src/backends/x11/meta-input-settings-x11.c
16
16
@@ -26,6 +26,7 @@
@@ -227,8 +227,13 @@ index 9687fb36f..1d84dfccf 100644
227
227
change_property (device, "libinput Accel Speed",
228
228
XInternAtom (xdisplay, "FLOAT", False),
229
229
32, &value, 1);
230
- @@ -245,6 +431,19 @@ meta_input_settings_x11_set_left_handed (MetaInputSettings *settings,
231
- else
230
+ @@ -242,9 +428,23 @@ meta_input_settings_x11_set_left_handed (MetaInputSettings *settings,
231
+ change_property (device, "Wacom Rotation",
232
+ XA_INTEGER, 8, &value, 1);
233
+ }
234
+ - else
235
+ + else if (device_type == CLUTTER_POINTER_DEVICE ||
236
+ + device_type == CLUTTER_TOUCHPAD_DEVICE)
232
237
{
233
238
value = enabled ? 1 : 0;
234
239
+
@@ -247,7 +252,7 @@ index 9687fb36f..1d84dfccf 100644
247
252
change_property (device, "libinput Left Handed Enabled",
248
253
XA_INTEGER, 8, &value, 1);
249
254
}
250
- @@ -268,6 +467,20 @@ meta_input_settings_x11_set_tap_enabled (MetaInputSettings *settings,
255
+ @@ -268,6 +468,20 @@ meta_input_settings_x11_set_tap_enabled (MetaInputSettings *settings,
251
256
{
252
257
guchar value = (enabled) ? 1 : 0;
253
258
@@ -268,7 +273,7 @@ index 9687fb36f..1d84dfccf 100644
268
273
change_property (device, "libinput Tapping Enabled",
269
274
XA_INTEGER, 8, &value, 1);
270
275
}
271
- @@ -290,6 +503,27 @@ meta_input_settings_x11_set_invert_scroll (MetaInputSettings *settings,
276
+ @@ -290,6 +504,27 @@ meta_input_settings_x11_set_invert_scroll (MetaInputSettings *settings,
272
277
{
273
278
guchar value = (inverted) ? 1 : 0;
274
279
@@ -296,7 +301,7 @@ index 9687fb36f..1d84dfccf 100644
296
301
change_property (device, "libinput Natural Scrolling Enabled",
297
302
XA_INTEGER, 8, &value, 1);
298
303
}
299
- @@ -303,6 +537,22 @@ meta_input_settings_x11_set_edge_scroll (MetaInputSettings *settings,
304
+ @@ -303,6 +538,22 @@ meta_input_settings_x11_set_edge_scroll (MetaInputSettings *settings,
300
305
guchar *current = NULL;
301
306
guchar *available = NULL;
302
307
@@ -319,7 +324,7 @@ index 9687fb36f..1d84dfccf 100644
319
324
available = get_property (device, "libinput Scroll Methods Available",
320
325
XA_INTEGER, 8, SCROLL_METHOD_NUM_FIELDS);
321
326
if (!available || !available[SCROLL_METHOD_FIELD_EDGE])
322
- @@ -332,6 +582,22 @@ meta_input_settings_x11_set_two_finger_scroll (MetaInputSettings *set
327
+ @@ -332,6 +583,22 @@ meta_input_settings_x11_set_two_finger_scroll (MetaInputSettings *set
323
328
guchar *current = NULL;
324
329
guchar *available = NULL;
325
330
@@ -343,5 +348,5 @@ index 9687fb36f..1d84dfccf 100644
343
348
XA_INTEGER, 8, SCROLL_METHOD_NUM_FIELDS);
344
349
if (!available || !available[SCROLL_METHOD_FIELD_2FG])
345
350
--
346
- 2.20.1
351
+ 2.21.0
347
352
file modified
+5 -1
SPECS/mutter.spec CHANGED
@@ -7,7 +7,7 @@
7
7
8
8
Name: mutter
9
9
Version: 3.28.3
10
- Release: 18%{?dist}
10
+ Release: 19%{?dist}
11
11
Summary: Window and compositing manager based on Clutter
12
12
13
13
License: GPLv2+
@@ -362,6 +362,10 @@ desktop-file-validate %{buildroot}/%{_datadir}/applications/%{name}.desktop
362
362
%{_datadir}/mutter/tests
363
363
364
364
%changelog
365
+ * Tue Apr 02 2019 Carlos Garnacho <cgarnach@redhat.com> - 3.28.3-19
366
+ - Fix synaptics/evdev driver support forward port to not break tablet pads
367
+ Resolves: #1687949
368
+
365
369
* Thu Feb 21 2019 Jonas Ã…dahl <jadahl@redhat.com> - 3.28.3-18
366
370
- Remove patch enabling monitor framebuffer scaling
367
371
Related: #1668883