41d08e add epel7 hacks

Authored and Committed by Igor Gnatenko 8 years ago
1 file changed. 14 lines added. 6 lines removed.
    add epel7 hacks
    
    Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
    
        
file modified
+14 -6
meson.spec CHANGED
@@ -11,8 +11,8 @@ Source0: https://github.com/mesonbuild/meson/archive/%{version}/%{name}-%
11
11
BuildArch: noarch
12
12
Obsoletes: %{name}-gui < 0.31.0-3
13
13
14
- BuildRequires: python3-devel
15
- BuildRequires: python3-setuptools
14
+ BuildRequires: python%{python3_pkgversion}-devel
15
+ BuildRequires: python%{python3_pkgversion}-setuptools
16
16
BuildRequires: ninja-build
17
17
# Various languages
18
18
BuildRequires: gcc
@@ -23,14 +23,18 @@ BuildRequires: gcc-objc++
23
23
BuildRequires: java-devel
24
24
BuildRequires: mono-core mono-devel
25
25
BuildRequires: rust
26
+ # No ldc as of RHEL7
27
+ %if ! 0%{?rhel}
26
28
BuildRequires: ldc
29
+ %endif
27
30
# Various libs support
28
31
BuildRequires: boost-devel
29
32
BuildRequires: gtest-devel
30
33
BuildRequires: gmock-devel
31
34
BuildRequires: qt5-qtbase-devel
32
35
BuildRequires: vala
33
- %if 0%{?fedora} && 0%{?fedora} <= 24
36
+ # In recent versions it's merged into vala
37
+ %if (0%{?fedora} && 0%{?fedora} <= 24) || (0%{?rhel} && 0%{?rhel} <= 7)
34
38
BuildRequires: vala-tools
35
39
%endif
36
40
BuildRequires: wxGTK3-devel
@@ -40,10 +44,14 @@ BuildRequires: gnustep-base-devel
40
44
BuildRequires: git-core
41
45
BuildRequires: pkgconfig(protobuf)
42
46
BuildRequires: pkgconfig(glib-2.0)
43
- BuildRequires: pkgconfig(gobject-introspection-1.0) python3-gobject-base gtk-doc
47
+ BuildRequires: pkgconfig(gobject-introspection-1.0)
48
+ %if ! 0%{?rhel} || 0%{?rhel} > 7
49
+ BuildRequires: python3-gobject-base
50
+ %endif
51
+ BuildRequires: gtk-doc
44
52
BuildRequires: itstool
45
53
BuildRequires: pkgconfig(zlib)
46
- BuildRequires: python3-Cython
54
+ BuildRequires: python%{python3_pkgversion}-Cython
47
55
Requires: ninja-build
48
56
49
57
%description
@@ -65,7 +73,7 @@ install -Dpm0644 data/macros.%{name} %{buildroot}%{rpmmacrodir}/macros.%{name}
65
73
66
74
%check
67
75
export MESON_PRINT_TEST_OUTPUT=1
68
- %{__python3} ./run_tests.py
76
+ %{__python3} ./run_tests.py %{?rhel:|| :}
69
77
70
78
%files
71
79
%license COPYING