7b5483 release candidate 1 of 0.10.0

Authored and Committed by Daniel Veillard 12 years ago
    release candidate 1 of 0.10.0
    
        
build-Link-security-manager-into-libvirt.so.patch DELETED
@@ -1,115 +0,0 @@
1
- From 2f2ca021951905439fbb47ae02d0796837eb4f53 Mon Sep 17 00:00:00 2001
2
- From: Jiri Denemark <jdenemar@redhat.com>
3
- Date: Thu, 2 Aug 2012 14:10:31 +0200
4
- Subject: [PATCH] build: Link security manager into libvirt.so
5
-
6
- Security manager is not a dynamically loadable driver, it's a common
7
- infrastructure similar to util, conf, cpu, etc. used by individual
8
- drivers. Such code is allowed to be linked into libvirt.so.
9
-
10
- This reverts commit ec5b7bd2ecbf40ceff5b2d4fc00d5cfdfba966a4 and most of
11
- aae5cfb69948fddef556f8f5b9f80a444f9c6125.
12
-
13
- This patch is supposed to fix virdrivermoduletest failures for qemu and
14
- lxc drivers as well as libvirtd's ability to load qemu and lxc drivers.
15
- ---
16
- daemon/Makefile.am | 1 -
17
- src/Makefile.am | 3 +--
18
- src/libvirt_private.syms | 31 +++++++++++++++++++++++++++++++
19
- tests/Makefile.am | 5 ++---
20
- 4 files changed, 34 insertions(+), 6 deletions(-)
21
-
22
- diff --git a/daemon/Makefile.am b/daemon/Makefile.am
23
- index b8ecbef..928aeaf 100644
24
- --- a/daemon/Makefile.am
25
- +++ b/daemon/Makefile.am
26
- @@ -164,7 +164,6 @@ endif
27
- if WITH_NWFILTER
28
- libvirtd_LDADD += ../src/libvirt_driver_nwfilter.la
29
- endif
30
- -libvirtd_LDADD += ../src/libvirt_driver_security.la
31
- endif
32
-
33
- libvirtd_LDADD += ../src/libvirt.la
34
- diff --git a/src/Makefile.am b/src/Makefile.am
35
- index 844e648..7663ad7 100644
36
- --- a/src/Makefile.am
37
- +++ b/src/Makefile.am
38
- @@ -1161,8 +1161,7 @@ endif
39
-
40
- libvirt_driver_security_la_SOURCES = $(SECURITY_DRIVER_SOURCES)
41
- noinst_LTLIBRARIES += libvirt_driver_security.la
42
- -# Stateful, so linked to daemon instead
43
- -#libvirt_la_BUILT_LIBADD += libvirt_driver_security.la
44
- +libvirt_la_BUILT_LIBADD += libvirt_driver_security.la
45
- libvirt_driver_security_la_CFLAGS = \
46
- -I$(top_srcdir)/src/conf $(AM_CFLAGS)
47
- libvirt_driver_security_la_LDFLAGS = $(AM_LDFLAGS)
48
- diff --git a/src/libvirt_private.syms b/src/libvirt_private.syms
49
- index 0b026b8..aace748 100644
50
- --- a/src/libvirt_private.syms
51
- +++ b/src/libvirt_private.syms
52
- @@ -961,6 +961,37 @@ virSecretUsageTypeTypeFromString;
53
- virSecretUsageTypeTypeToString;
54
-
55
-
56
- +# security_driver.h
57
- +virSecurityDriverLookup;
58
- +
59
- +
60
- +# security_manager.h
61
- +virSecurityManagerClearSocketLabel;
62
- +virSecurityManagerFree;
63
- +virSecurityManagerGenLabel;
64
- +virSecurityManagerGetDOI;
65
- +virSecurityManagerGetModel;
66
- +virSecurityManagerGetProcessLabel;
67
- +virSecurityManagerNew;
68
- +virSecurityManagerNewStack;
69
- +virSecurityManagerNewDAC;
70
- +virSecurityManagerReleaseLabel;
71
- +virSecurityManagerReserveLabel;
72
- +virSecurityManagerRestoreImageLabel;
73
- +virSecurityManagerRestoreAllLabel;
74
- +virSecurityManagerRestoreHostdevLabel;
75
- +virSecurityManagerRestoreSavedStateLabel;
76
- +virSecurityManagerSetAllLabel;
77
- +virSecurityManagerSetDaemonSocketLabel;
78
- +virSecurityManagerSetImageFDLabel;
79
- +virSecurityManagerSetImageLabel;
80
- +virSecurityManagerSetHostdevLabel;
81
- +virSecurityManagerSetProcessLabel;
82
- +virSecurityManagerSetSavedStateLabel;
83
- +virSecurityManagerSetSocketLabel;
84
- +virSecurityManagerVerify;
85
- +virSecurityManagerGetMountOptions;
86
- +
87
- # sexpr.h
88
- sexpr_append;
89
- sexpr_cons;
90
- diff --git a/tests/Makefile.am b/tests/Makefile.am
91
- index 6a1b18b..ac26bc5 100644
92
- --- a/tests/Makefile.am
93
- +++ b/tests/Makefile.am
94
- @@ -295,8 +295,7 @@ endif
95
-
96
- if WITH_QEMU
97
-
98
- -qemu_LDADDS = ../src/libvirt_driver_qemu_impl.la \
99
- - ../src/libvirt_driver_security.la
100
- +qemu_LDADDS = ../src/libvirt_driver_qemu_impl.la
101
- if WITH_NETWORK
102
- qemu_LDADDS += ../src/libvirt_driver_network_impl.la
103
- endif
104
- @@ -521,7 +520,7 @@ virauthconfigtest_LDADD = $(LDADDS)
105
-
106
- seclabeltest_SOURCES = \
107
- seclabeltest.c
108
- -seclabeltest_LDADD = $(LDADDS) ../src/libvirt_driver_security.la
109
- +seclabeltest_LDADD = $(LDADDS)
110
-
111
- virbuftest_SOURCES = \
112
- virbuftest.c testutils.h testutils.c
113
- --
114
- 1.7.11.2
115
-
libvirt-0.10.0-rc0-release-naming.patch DELETED
@@ -1,67 +0,0 @@
1
- commit 1d170d3f9afce53b748acdbc0612758bba39aa35
2
- Author: Eric Blake <eblake@redhat.com>
3
- Date: Wed Aug 1 11:00:35 2012 -0600
4
-
5
- build: commit to 0.10.0 release naming
6
-
7
- With 0.10.0-rc0 out the door, we are committed to the next version
8
- number.
9
-
10
- * src/libvirt_public.syms (LIBVIRT_0.9.14): Rename...
11
- (LIBVIRT_0.10.0): ...to this.
12
- * docs/formatdomain.html.in: Fix fallout.
13
- * src/openvz/openvz_driver.c (openvzDriver): Likewise.
14
- * src/remote/remote_driver.c (remote_driver): Likewise.
15
-
16
- diff --git a/docs/formatdomain.html.in b/docs/formatdomain.html.in
17
- index c834577..f97c630 100644
18
- --- a/docs/formatdomain.html.in
19
- +++ b/docs/formatdomain.html.in
20
- @@ -780,7 +780,7 @@
21
- CPU model will fail. Supported values for <code>fallback</code>
22
- attribute are: <code>allow</code> (this is the default), and
23
- <code>forbid</code>. The optional <code>vendor_id</code> attribute
24
- - (<span class="since">Since 0.9.14</span>) can be used to set the
25
- + (<span class="since">Since 0.10.0</span>) can be used to set the
26
- vendor id seen by the guest. It must be exactly 12 characters long.
27
- If not set the vendor id of the host is used. Typical possible
28
- values are "AuthenticAMD" and "GenuineIntel".</dd>
29
- diff --git a/src/libvirt_public.syms b/src/libvirt_public.syms
30
- index 5004182..e3ba119 100644
31
- --- a/src/libvirt_public.syms
32
- +++ b/src/libvirt_public.syms
33
- @@ -544,7 +544,7 @@ LIBVIRT_0.9.13 {
34
- virDomainSnapshotRef;
35
- } LIBVIRT_0.9.11;
36
-
37
- -LIBVIRT_0.9.14 {
38
- +LIBVIRT_0.10.0 {
39
- global:
40
- virDomainGetHostname;
41
- virConnectRegisterCloseCallback;
42
- diff --git a/src/openvz/openvz_driver.c b/src/openvz/openvz_driver.c
43
- index 4cc7f46..48b5219 100644
44
- --- a/src/openvz/openvz_driver.c
45
- +++ b/src/openvz/openvz_driver.c
46
- @@ -2170,7 +2170,7 @@ static virDriver openvzDriver = {
47
- .domainIsUpdated = openvzDomainIsUpdated, /* 0.8.6 */
48
- .isAlive = openvzIsAlive, /* 0.9.8 */
49
- .domainUpdateDeviceFlags = openvzDomainUpdateDeviceFlags, /* 0.9.13 */
50
- - .domainGetHostname = openvzDomainGetHostname, /* 0.9.14 */
51
- + .domainGetHostname = openvzDomainGetHostname, /* 0.10.0 */
52
- };
53
-
54
- int openvzRegister(void) {
55
- diff --git a/src/remote/remote_driver.c b/src/remote/remote_driver.c
56
- index 9354cb4..b9e2127 100644
57
- --- a/src/remote/remote_driver.c
58
- +++ b/src/remote/remote_driver.c
59
- @@ -5366,7 +5366,7 @@ static virDriver remote_driver = {
60
- .domainGetDiskErrors = remoteDomainGetDiskErrors, /* 0.9.10 */
61
- .domainSetMetadata = remoteDomainSetMetadata, /* 0.9.10 */
62
- .domainGetMetadata = remoteDomainGetMetadata, /* 0.9.10 */
63
- - .domainGetHostname = remoteDomainGetHostname, /* 0.9.14 */
64
- + .domainGetHostname = remoteDomainGetHostname, /* 0.10.0 */
65
- };
66
-
67
- static virNetworkDriver network_driver = {
libvirt-build-Link-security-driver-into-daemon.patch DELETED
@@ -1,30 +0,0 @@
1
- From 840b80b48c0189423993db6268f85dd5eac345ac Mon Sep 17 00:00:00 2001
2
- From: Jiri Denemark <jdenemar@redhat.com>
3
- Date: Wed, 1 Aug 2012 09:59:43 +0200
4
- Subject: [PATCH] build: Link security driver into daemon
5
- To: libvir-list@redhat.com
6
-
7
- Commit aae5cfb69948fddef556f8f5b9f80a444f9c6125 removed security driver
8
- from libvirt_la but forgot to link it into libvirtd in case libvirt is
9
- built without modules.
10
-
11
- Signed-off-by: Daniel Veillard <veillard@redhat.com>
12
- ---
13
- daemon/Makefile.am | 1 +
14
- 1 files changed, 1 insertions(+), 0 deletions(-)
15
-
16
- diff --git a/daemon/Makefile.am b/daemon/Makefile.am
17
- index 928aeaf..b8ecbef 100644
18
- --- a/daemon/Makefile.am
19
- +++ b/daemon/Makefile.am
20
- @@ -164,6 +164,7 @@ endif
21
- if WITH_NWFILTER
22
- libvirtd_LDADD += ../src/libvirt_driver_nwfilter.la
23
- endif
24
- +libvirtd_LDADD += ../src/libvirt_driver_security.la
25
- endif
26
-
27
- libvirtd_LDADD += ../src/libvirt.la
28
- --
29
- 1.7.7.6
30
-
file modified
+17 -9
libvirt.spec CHANGED
@@ -106,6 +106,7 @@
106
106
%define with_sanlock 0%{!?_without_sanlock:0}
107
107
%define with_systemd 0%{!?_without_systemd:0}
108
108
%define with_numad 0%{!?_without_numad:0}
109
+ %define with_firewalld 0%{!?_without_firewalld:0}
109
110
110
111
# Non-server/HV driver defaults which are always enabled
111
112
%define with_python 0%{!?_without_python:1}
@@ -146,6 +147,11 @@
146
147
%define with_systemd 1
147
148
%endif
148
149
150
+ # Fedora 18 / RHEL-7 are first where firewalld support is enabled
151
+ %if 0%{?fedora} >= 17 || 0%{?rhel} >= 7
152
+ %define with_firewalld 1
153
+ %endif
154
+
149
155
# RHEL-5 has restricted QEMU to x86_64 only and is too old for LXC
150
156
%if 0%{?rhel} == 5
151
157
%define with_qemu_tcg 0
@@ -309,7 +315,7 @@
309
315
Summary: Library providing a simple virtualization API
310
316
Name: libvirt
311
317
Version: 0.10.0
312
- Release: 0rc0.2%{?dist}%{?extra_release}
318
+ Release: 0rc1%{?dist}%{?extra_release}
313
319
License: LGPLv2+
314
320
Group: Development/Libraries
315
321
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
@@ -318,10 +324,7 @@ URL: http://libvirt.org/
318
324
%if %(echo %{version} | grep -o \\. | wc -l) == 3
319
325
%define mainturl stable_updates/
320
326
%endif
321
- Source: http://libvirt.org/sources/%{?mainturl}libvirt-%{version}-rc0.tar.gz
327
+ Source: http://libvirt.org/sources/%{?mainturl}libvirt-%{version}-rc1.tar.gz
322
- Patch0: libvirt-0.10.0-rc0-release-naming.patch
323
- Patch1: libvirt-build-Link-security-driver-into-daemon.patch
324
- Patch2: build-Link-security-manager-into-libvirt.so.patch
325
328
326
329
%if %{with_libvirtd}
327
330
Requires: libvirt-daemon = %{version}-%{release}
@@ -1023,9 +1026,6 @@ of recent versions of Linux (and other OSes).
1023
1026
1024
1027
%prep
1025
1028
%setup -q
1026
- %patch0 -p1
1027
- %patch1 -p1
1028
- %patch2 -p1
1029
1029
1030
1030
%build
1031
1031
%if ! %{with_xen}
@@ -1192,6 +1192,10 @@ of recent versions of Linux (and other OSes).
1192
1192
%define _without_driver_modules --without-driver-modules
1193
1193
%endif
1194
1194
1195
+ %if %{with_firewalld}
1196
+ %define _with_firewalld --with-firewalld
1197
+ %endif
1198
+
1195
1199
%define when %(date +"%%F-%%T")
1196
1200
%define where %(hostname)
1197
1201
%define who %{?packager}%{!?packager:Unknown}
@@ -1250,6 +1254,7 @@ autoreconf -if
1250
1254
%{?_without_audit} \
1251
1255
%{?_without_dtrace} \
1252
1256
%{?_without_driver_modules} \
1257
+ %{?_with_firewalld} \
1253
1258
%{with_packager} \
1254
1259
%{with_packager_version} \
1255
1260
--with-qemu-user=%{qemu_user} \
@@ -1338,7 +1343,7 @@ make
1338
1343
for i in nodeinfotest seclabeltest virdrivermoduletest
1339
1344
do
1340
1345
rm -f $i
1341
- printf 'int main(void) { return(0); }' > $i.c
1346
+ printf 'int main(void) { return 0; }' > $i.c
1342
1347
printf '#!/bin/sh\nexit 0\n' > $i
1343
1348
chmod +x $i
1344
1349
done
@@ -1848,6 +1853,9 @@ rm -f $RPM_BUILD_ROOT%{_sysconfdir}/sysctl.d/libvirtd
1848
1853
%endif
1849
1854
1850
1855
%changelog
1856
+ * Thu Aug 23 2012 Daniel Veillard <veillard@redhat.com> - 0.10.0-0rc1
1857
+ - release candidate 1 of 0.10.0
1858
+
1851
1859
* Tue Aug 14 2012 Daniel P. Berrange <berrange@redhat.com> - 0.10.0-0rc0.2
1852
1860
- Enable autotools to make previous patch work
1853
1861
file modified
+1 -1
sources CHANGED
@@ -1 +1 @@
1
- 75fffe250104c44e23a6bf8e4925311f libvirt-0.10.0-rc0.tar.gz
1
+ 98eb952881fcb7e85a9d1cae67406a1c libvirt-0.10.0-rc1.tar.gz